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Error message when you try to use Windows Media Player to stream audio or video from Windows Media Services: "The specified protocol is not supported"

Article ID:940029
Last Review:February 18, 2008
Revision:3.0
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SYMPTOMS

Problem 1

When you try to stream audio or video from Microsoft Windows Media Services, you may receive an error message that resembles the following in Microsoft Windows Media Player:
The specified protocol is not supported.
Note This problem does not occur when you play content that is stored on a hard disk drive.

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Problem 2

When you click the Network tab of the Windows Media Player Options menu, nothing happens.

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Problem 3

On the Windows Media Player Network tab, the "Streaming proxy settings" protocol listing is empty.

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CAUSE

This problem may occur if any one of the following conditions is true:
The Wmnetmgr.dll file is unregistered.

Note The Wmnetmgr.dll file is located in the C:\Windows\System32 folder.
The Wmsdkns.xml file is corrupted.

Note The file is Windows Media Player's network namespace file.
The Wmsdkns.xml file has incorrect permissions.

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RESOLUTION

To resolve this problem, use one of the following methods.

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Method 1

Register the Wmnetmgr.dll file by using an account that is in the Administrators group. At a command prompt, run the following command.
regsvr32 wmnetmgr.dll

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Method 2

Make sure that the user account that is using Windows Media Player has Modify permissions for the Wmsdkns.xml file.

Note In Windows Vista, the file is located in the C:\Users\Userame\AppData\Local\Microsoft\Windows Media\11.0 folder. In Windows XP, the file is located in the C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\Windows Media\11.0 folder.

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Method 3

Delete the Wmsdkns.xml file. After you delete it, Windows Media Player will re-create the Wmsdkns.xml file.

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MORE INFORMATION

Steps to reproduce the problem

1.Unregister the Wmnetmgr.dll file by using an account that is in the Administrators group. At the command prompt, run the following command.
regsvr32 /u wmnetmgr.dll
2.Make sure that the user account that is using Windows Media Player has Deny permissions for the Wmsdkns.xml file.

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APPLIES TO
Microsoft Windows Media Player 11

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Keywords: 
kbtshoot kbprb KB940029

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