ID do artigo: 940520 - Última revisão: segunda-feira, 3 de outubro de 2011 - Revisão: 5.0

Uma atualização está disponível para corrigir um problema do Serviço de Transferência Inteligente em Segundo Plano (BITS) em um computador baseado em Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Após baixar atualizações do Windows Update em um computador baseado em Windows Vista, os seguintes sintomas poderão ser enfrentados:
  • Uma caixa de diálogo é exibida, indicando que o processo do host para Serviços do Windows parou de funcionar.
  • Após reiniciar o computador, uma caixa de diálogo do Windows Update é exibida. Essa caixa de diálogo contém a seguinte mensagem:
    Algumas atualizações não foram instaladas
    Falhou: xx atualizações
    Erro(s) encontrado(s):
    Código 800706BA
  • Um evento que se assemelha ao seguinte é registrado no log de aplicativo:

    Tipo de evento: Erro
    Origem do evento: Erro do aplicativo
    Categoria do evento: Nenhuma
    Identificação do evento: 1000
    Data: data
    Hora: hora
    Computador: nome do computador
    Usuário: N/A
    Descrição: Aplicativo com falha svchost.exe_BITS, versão 6.0.6000.16386, carimbo de data/hora 0x4549adc4, módulo com falha qmgr.dll, versão 7.0.6000.16386, carimbo de data/hora 0x4549bd9f, código de exceção 0xc0000005

Causa

Este problema ocorre porque os arquivos de estado do Serviço de Transferência Inteligente em Segundo Plano (BITS) estão corrompidos. Esse problema interrompe o processo do host para Serviços do Windows. Esse comportamento impede que você use o BITS para transferir arquivos.

Resolução

Uma atualização está disponível para resolver esse problema. A ferramenta de reparo do BITS ajudará você a corrigir um problema causado pelo dano aos arquivos de estado do BITS. O problema interrompe o processo do host para Serviços do Windows. Esse comportamento impede que você use o BITS para transferir arquivos. Utilize essa ferramenta para resolver o dano e habilitar novamente as transferências do BITS. Após a execução dessa ferramenta, talvez seja necessário reiniciar o computador.

Informações sobre o download

O seguinte arquivo está disponível para download no Centro de Download da Microsoft:

Versões de 32 bits do Windows Vista

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Download
Baixe o pacote 940520 agora. (http://www.microsoft.com/downloads/details.aspx?displaylang=pt-br&FamilyID=2829e460-4045-435b-b165-2c1496cd94a4)

Versões de 64 bits do Windows Vista

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Download
Baixe o pacote 940520 agora. (http://www.microsoft.com/downloads/details.aspx?displaylang=pt-br&FamilyID=c9e36415-e97b-46a6-ab7e-4f89fff4d8af)

Para obter informações adicionais sobre como baixar os arquivos de suporte da Microsoft, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
119591  (http://support.microsoft.com/kb/119591/[PT]/ ) Como obter arquivos de suporte da Microsoft nos serviços online
A Microsoft examinou este arquivo em busca de vírus. A Microsoft usou o mais recente software de detecção de vírus disponível na data em que o arquivo foi publicado. O arquivo está armazenado em servidores de segurança avançada que ajudam a evitar quaisquer alterações não autorizadas no arquivo.

Você também pode resolver esse problema manualmente, usando um dos métodos a seguir.

Método 1

  1. Habilite a opção Exibir arquivos ocultos. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       botão Iniciar
      em Painel de Controle, clique em Opções de pasta e na guia Modo de exibição.
    2. Clique em Mostrar pastas e arquivos ocultos e em OK.
  2. Como administrador do Sistema, localize a pasta Programdata\Microsoft\Network\Downloader e, em seguida, exclua todos os arquivos que tenham um nome de arquivo que comece com Qmgr. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       o botão Iniciar
      , digite \Programdata\Microsoft\network\downloader na caixa Iniciar pesquisa e pressione ENTER.
    2. Na janela Downloader, selecione e, em seguida, exclua todos os arquivos que comecem com Qmgr. Por exemplo, exclua os seguintes arquivos:
      • Qmgr0.dat
      • Qmgr1.dat
      Observações
      • Se os arquivos não forem excluídos, reinicie o computador no modo de segurança sem rede. Para fazer isso, utilize o Método 2 ou o Método 3.
      • Se os arquivos forem excluídos com êxito, abra imediatamente o Windows Update e, em seguida, instale as atualizações mais recentes.

Método 2

  1. Reinicie o computador.
  2. Pressione a tecla F8 enquanto o computador reinicia.

    Observação É necessário pressionar a tecla F8 antes do indicador de progresso do Windows Vista aparecer.
  3. Quando o menu Opções de inicialização avançada aparecer use as teclas de direção para selecionar Modo de segurança e pressione ENTER.
  4. Habilite a opção Exibir arquivos ocultos. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       o botão Iniciar
      , em Painel de Controle, clique em Opções de pasta e na guia Exibir.
    2. Clique em Mostrar pastas e arquivos ocultos e em OK.
  5. Como administrador do Sistema, localize a pasta Programdata\Microsoft\Network\Downloader e, em seguida, exclua todos os arquivos que tenham um nome de arquivo que comece com Qmgr. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       o botão Iniciar
      , digite \Programdata\Microsoft\network\downloader na caixa Iniciar pesquisa e pressione ENTER.
    2. Na janela Downloader, selecione e, em seguida, exclua todos os arquivos que comecem com Qmgr. Por exemplo, exclua os seguintes arquivos:
      • Qmgr0.dat
      • Qmgr1.dat
  6. Abra imediatamente o Windows Update e, em seguida, instale as atualizações mais recentes.

Método 3

  1. Reinicie o computador no modo de segurança sem rede. Para fazer isto, execute as seguintes etapas:
    1. Saia de todos os programas abertos.
    2. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       botão Iniciar
      , digite Executar na caixa Iniciar pesquisa e pressione ENTER.
    3. Digite msconfig e clique em OK.

      O Utilitário de configuração do sistema será exibido.
    4. Clique na guia Inicialização do sistema, marque a caixa de seleção Inicialização segura , marque a caixa de seleção Mínima e clique em OK.
    5. Ao ser solicitado, reinicie o computador.
  2. Habilite a opção Exibir arquivos ocultos. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       o botão Iniciar
      , em Painel de Controle, clique em Opções de pasta e na guia Exibir.
    2. Clique em Mostrar pastas e arquivos ocultos e em OK.
  3. Como administrador do Sistema, localize a pasta Programdata\Microsoft\Network\Downloader e, em seguida, exclua todos os arquivos que tenham um nome de arquivo que comece com Qmgr. Para fazer isto, execute as seguintes etapas:
    1. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       o botão Iniciar
      , digite \Programdata\Microsoft\network\downloader na caixa Iniciar pesquisa e pressione ENTER.
    2. Na janela Downloader, selecione e exclua todos os arquivos que começam com Qmgr. Por exemplo, exclua os seguintes arquivos:
      • Qmgr0.dat
      • Qmgr1.dat
  4. Reinicie o computador no modo normal. Para fazer isto, execute as seguintes etapas:
    1. Saia de todos os programas abertos.
    2. Clique em Iniciar
      Recolher esta imagemExpandir esta imagem
       botão Iniciar
      , digite Executar na caixa Iniciar pesquisa e pressione ENTER.
    3. Digite msconfig e clique em OK. O Utilitário de configuração do sistema é exibido.
    4. Na guia Inicialização, limpe a caixa de seleção Inicialização segura e clique em OK para reiniciar o computador.
    5. Reinicie o computador ao ser solicitado.
  5. Abra imediatamente o Windows Update e, em seguida, instale as atualizações mais recentes.

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palavras-chave: 
kbexpertisebeginner kbtshoot kbprb KB940520