ID článku: 943996 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky
Zdroj: Podpora společnosti Microsoft

Výsledek

V počítači se systémem Windows Vista zjistíte, že není spuštěna služba Windows Firewall. Při pokusu o manuální spuštění této služby se zobrazí níže uvedená chybová zpráva. Podobné potíže se mohou vyskytnout i u služby klienta DHCP nebo u služby DPS (Diagnostic Policy Service).

Toto jsou chybové zprávy v případě služby Windows Firewall:
Systém Windows nemohl v počítači Místní počítač spustit službu Windows Firewall. Další informace naleznete v systémovém protokolu událostí. Pokud se nejedná o službu společnosti Microsoft, obraťte se na dodavatele služby a sdělte kód chyby týkající se služby 5.


V systémovém protokolu událostí najdete následující událost:
Zdroj: Service Control manager Eventlog Provider.
ID události: 7024
Služba Windows Firewall byla ukončena s vlastním kódem chyby 5 (0x5).

Příčina

Tato chyba znamená odepření přístupu. K tomu může dojít v případě, že účet MpsSvc nemá dostatečná oprávnění pro související klíče registru.

Účet NT Service\MpsSvc potřebuje oprávnění pro následující klíče:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch
    Potřebné oprávnění: Dotazovat se na hodnotu, Nastavit hodnotu
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy 
    Potřebné oprávnění: Úplné řízení, Číst
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Defaults\FirewallPolicy
    Potřebné oprávnění: Úplné řízení, Číst

V případě služby klienta DHCP může tento problém nastat, pokud nemá účet NT Service\DHCP dostatečná oprávnění pro následující klíče:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
    Potřebné oprávnění: Dotazovat se na hodnotu; Vytvořit hodnoty, Vytvořit výčet podklíčů, Upozornit, Číst informace o řízení
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Configurations
    Potřebné oprávnění: Úplné řízení, Číst

V případě služby DPS (Diagnostic Policy Service) může tento problém nastat, pokud nemá účet Trustedinstaller oprávnění pro následující klíč:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS\Parameters
Potřebné oprávnění: Úplné řízení, Číst

Řešení

Můžete provést automatickou diagnózu a opravu běžných potíží se službou Windows Firewall, jako jsou tyto:
  • Služba Windows Firewall není výchozí bránou firewall.
  • Služba Windows Firewall se nespustí.
  • Spuštění služby Windows Firewall systémem Windows Vista se nezdaří.
  • Chyba specifická pro službu 5 (0x5): Vzdálená pomoc nefunguje.
  • Nelze získat přístup ke sdíleným složkám a tiskárnám.
Chcete-li stáhnout a spustit tohoto automatického poradce při potížích, klikněte na odkaz Opravit tyto potíže:
Opravit tyto potíže
Automatizovaná služba řešení potíží společnosti Microsoft: Diagnostika a automatická oprava potíží se službou Windows Firewall


Pokud nechcete použít výše uvedeného automatického poradce při potížích a chcete potíže vyřešit sami, přidejte pro účet oprávnění k těmto klíčům registru. Zde jsou například kroky pro službu Windows Firewall:
  1. V programu Editor registru přejděte na klíč, pro který potřebujete přidat oprávnění.
  2. Klikněte na tento klíč pravým tlačítkem myši a klikněte na položku Oprávnění.
  3. Ujistěte se, zda je v poli Umístění vybrán místní počítač.
  4. Do pole Zadejte názvy objektů k výběru zadejte hodnotu NT SERVICE\mpssvc. Klikněte na položku Zkontrolovat název.
  5. Klikněte na tlačítko OK.
  6. Pak vyberte účet, který se zobrazí v seznamu, a přidejte pro něj příslušná oprávnění.
  7. Jakmile budete hotovi, klikněte na tlačítko OK.

Poznámka: Toto je článek určený k rychlému zveřejnění, který vydala přímo služba podpory společnosti Microsoft. Uvedené informace jsou poskytovány jako odpověď na vzniklé problémy. Vzhledem k požadavku na rychlé zveřejnění je možné, že zpráva obsahuje typografické chyby, a může být kdykoli bez ohlášení revidována. Další pokyny naleznete v dokumentu Podmínky užití.

Vlastnosti

ID článku: 943996 - Poslední aktualizace: 13. října 2010 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Klíčová slova: 
kbnomt kbrapidpub kbfixme kbmatsfixme KB943996

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com