Artikel-id: 943996 - Få vist de produkter, som denne artikel refererer til.
Udvid alle | Skjul alle
Kilde: Microsoft Support

Resultat

På computere med Windows Vista, kan du opleve, at Windows Firewall ikke kører. Når du forsøger manuelt at starte tjenesten, får du fejlen, der nævnes herunder. Dette problem kan også forekomme for tjenesten DHCP Client eller tjenesten "Diagnostic Policy Service".

Her ses fejlmeddelelserne for tjenesten "Windows Firewall":
Windows kunne ikke starte Windows Firewall på lokal computer. Du kan se flere oplysninger i System Event Log. Hvis dette er en ikke-Microsoft-tjeneste, skal du kontakte tjenesteudbyderen og referere til den tjenestespecifikke fejlkode 5.


I System Event Log vises følgende hændelse:
Kilde: Service Control manager Eventlog Provider.
Hændelses-id: 7024
Tjenesten Windows Firewall afsluttedes med en tjenestespecifik fejl 5 (0x5)

Årsag

Fejlen betyder "Adgang nægtet". Dette kan forekomme, hvis kontoen "MpsSvc" ikke har de nødvendige tilladelser til de relaterede nøgler i registreringsdatabasen.

Kontoen NT Service\MpsSvc skal have tilladelser til følgende nøgler:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch
    nødvendig tilladelse: Forespørgsel af værdier;Indstilling af værdier
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy 
    nødvendig tilladelse: Fuld kontrol;Læsning
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Defaults\FirewallPolicy
    nødvendig tilladelse: Fuld kontrol;Læsning

For tjeneste DHCP Client kan problemet opstå, hvis kontoen "NT Service\DHCP" ikke har de nødvendige tilladelser til følgende nøgler:
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
    nødvendig tilladelse: Forespørgsel af værdier, Oprettelse af undernøgler, Optælling af undernøgler, Give besked, Læsekontrol
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp\Configurations
    nødvendig tilladelse: Fuld kontrol, Læsning

For tjenesten "Diagnostic Policy Service" kan problemet opstå, hvis kontoen Trustedinstaller mangler tilladelser til nøglen herunder:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS\Parameters
nødvendig tilladelse: Fuld kontrol, Læsning

Løsning

Diagnosticer og løs almindelige Windows Firewall-problemer, som f.eks.:
  • Windows Firewall er ikke standardfirewall
  • Windows Firewall starter ikke
  • Windows Vista kunne ikke starte Windows Firewall
  • Fjernassistance for den tjenestespecifikke fejl 5 (0x5) virker ikke
  • Du har ikke adgang til delte filer og printere
Du kan hente og køre den automatiske fejlfinding ved at klikke på linket Løs dette problem:
Løs dette problem
Microsoft Automated Troubleshooting Services: Diagnosticer og løs problemer med tjenesten Windows Firewall automatisk


Hvis du foretrækker selv at løse problemet, i stedte for at anvende den automatiske fejlfinding, skal du tilføje tilladelser for kontoen til disse nøgler i registreringsdatabasen. Her er f.eks. trinnene for tjenesten Windows Firewall:
  1. I registreringsdatabasen skal du gå til den nøgle, som du skal føje tilladelser til.
  2. Højreklik på nøglen og klik på Tilladelser.
  3. Kontrollér at Placeringer er valgt til at være den lokale computer.
  4. I feltet "Skriv objektnavnet, der skal vælges" skal du skrive "NT SERVICE\mpssvc". Klik derefter på "Kontroller navne".
  5. Klik på OK.
  6. Vælg derefter den konto, som vises på listen, og tilføj de relevante tilladelser.
  7. Klik på OK, når du har gjort dette.

Bemærk! Dette er en artikel til hurtig udgivelse, som er oprettet direkte i Microsofts supportafdeling. Oplysningerne i artiklen præsenteres som de og behandler aktuelle problemer. Fordi artiklen er blevet udgivet hurtigt, kan der forekomme slåfejl, og artiklen kan blive redigeret uden varsel. Se andre forbehold under Vilkår for anvendelse.

Egenskaber

Artikel-id: 943996 - Seneste redigering: 13. oktober 2010 - Redigering: 2.0
Oplysningerne i denne artikel gælder:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Nøgleord: 
kbnomt kbrapidpub kbfixme kbmatsfixme KB943996

Send feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com