Artigo: 947215 - Última revisão: segunda-feira, 1 de Agosto de 2011 - Revisão: 6.0

Mensagem de erro: ?O Serviço de Perfis de Utilizador não conseguiu iniciar sessão. Não foi possível carregar o perfil de utilizador", ao iniciar sessão no Windows 7 ou Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Ao iniciar sessão num computador baseado no Windows Vista ou no Windows 7 utilizando um perfil temporário, recebe a seguinte mensagem de erro:
O Serviço de Perfis de Utilizador não conseguiu iniciar sessão. Não foi possível carregar o perfil de utilizador.
Este erro pode ocorrer caso a definição de Política de Grupo ?Não iniciar sessão de utilizadores com perfis temporários? esteja configurada.

Causa

Este problema poderá ocorrer se a pasta do perfil de utilizador for eliminada de forma manual. Uma pasta de perfil que é manualmente eliminada não remove o Identificador de Segurança (SID) da lista de perfis no registo. 

AVISO: A Microsoft recomenda que NÃO faça deste método de remoção de perfis de utilizadores uma prática comum. É preferível utilizar a abordagem documentada e suportada das Definições Avançadas do Sistema nas propriedades do sistema, em definições de ?Perfis de Utilizador?. Para as aplicações, este recurso é disponibilizado através da API ?DeleteProfile?.

Se o SID estiver presente, o Windows tentará carregar o perfil utilizando o caminho ProfileImagePath que aponta para um caminho inexistente. Por este motivo, não é possível carregar o perfil.

Resolução


Importante:

Ocasionalmente, o Windows poderá não ler de forma correcta o perfil do utilizador, por exemplo, se o seu software antivírus estiver a analisar o seu computador enquanto tenta iniciar a sessão. Antes de proceder com os seguintes métodos, tente restaurar o seu computador e iniciar a sessão novamente com a sua conta de utilizador para resolver o problema.


Se o reiniciar do seu computador não resolver este problema, siga os passos indicados nos métodos abaixo.

Nota: será necessário iniciar sessão numa conta de administrador para corrigir o seu perfil de utilizador ou copiar os dados para uma nova conta. Antes de começar a solucionar o problema, inicie sessão no Windows com outra conta que tenha permissões administrativas ou inicie o computador em modo de segurança para iniciar sessão com a conta de Administrador incorporada. Para mais informações sobre como iniciar o computador em modo de segurança, visite o seguinte Web site da Microsoft:

Método 1: Corrigir o perfil de Conta de utilizador


Para o fazer, siga os passos abaixo:

Importante: esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo da forma incorrecta. Assim, certifique-se de que segue estes passos cuidadosamente. Para uma maior segurança, efectue uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como criar uma cópia de segurança e restaurar o registo no Windows
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
  2. Na área Iniciar procura (Windows Vista) ou em Procurar programas e ficheiros (Windows 7), escreva regedit e prima Enter.
  3. Caso seja solicitado pelo Controlo de Conta de Utilizador, clique em Continuar (Windows Vista) ou em Sim (Windows 7).
  4. No Editor de registo, avance para:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
  5. No painel da esquerda, procure o nome de pasta que começa por S-1-5 (chave SID) seguido de um número extenso. Em seguida, clique em cada uma das pastas, localize ProfileImagePath no painel direito e faça duplo clique para verificar que se se trata do perfil da conta de utilizador que tem o erro.
    Reduzir esta imagemExpandir esta imagem

    • Caso existam duas pastas cujo nome comece por S-1-5 seguido de números igualmente extensos e uma delas termine em .bak. Altere a pasta .bak para pasta normal. Para o fazer, siga os passos abaixo:
      1. Clique com o botão direito do rato na pasta sem a extensão .bak e seleccione Mudar o nome. Em seguida, adicione .ba no final do nome da pasta.
        Reduzir esta imagemExpandir esta imagem
      2. Clique com o botão direito do rato na pasta com a extensão .bak e seleccione Mudar o nome. Em seguida, remova .bak no final do nome da pasta.
        Reduzir esta imagemExpandir esta imagem
      3. Clique com o botão direito do rato na pasta com a extensão .ba e seleccione Mudar o nome. Em seguida, altere .ba para .bak no final do nome da pasta.
        Reduzir esta imagemExpandir esta imagem
    • Caso exista apenas uma pasta cujo nome comece por S-1-5 seguido de um número extenso e termine em .bak. Clique com o botão direito do rato na pasta e seleccione Mudar o nome. Em seguida, remova .bak no final do nome da pasta.
  6. Seleccione a pasta sem a extensão .bak no painel da direita, faça duplo clique em RefCount, escreva 0 e, em seguida, clique em OK.
    Reduzir esta imagemExpandir esta imagem
  7. Seleccione a pasta sem a extensão .bak no painel da direita, faça duplo clique em State, escreva 0 e, em seguida, clique em OK.
    Reduzir esta imagemExpandir esta imagem
  8. Feche o Editor de Registo.
  9. Reinicie o computador.
  10. Inicie nova sessão com a sua conta.
Esta informação foi útil? Envie-nos os seus comentários

Método 2: Iniciar sessão no Windows e copiar dados para uma nova conta

Crie uma nova conta e copie os dados da conta anterior para a nova conta. Para obter informações sobre como fazê-lo, visite um dos seguintes Web sites da Microsoft:

Windows 7 Windows Vista

Método 3: Eliminar o SID com erro e criar um novo perfil


Para eliminar o SID com erro e criar um novo perfil, siga os passos abaixo:
  1. Elimine o SID com erro.
    Para nos solicitar a correcção deste problema, consulte a secção ?Corrigir por mim?. Se preferir corrigir o problema sozinho, consulte a secção ?Deixar-me corrigir o problema?.

    Corrigir por mim

    Para corrigir este problema automaticamente, clique na hiperligação Corrigir este problema. Em seguida, clique em Executar na caixa de diálogo Transferência de Ficheiros e siga os passos indicados neste assistente.
    Corrigir este problema
    Correcção de problemas da Microsoft 50446

    Nota: este assistente pode estar apenas em inglês; contudo, a correcção automática também funciona em versões do Windows noutros idiomas.

    Nota: se não estiver a trabalhar no computador que tem o problema, pode guardar a correcção automática numa unidade Flash ou num CD e, em seguida, pode executá-la no computador que tem o problema.

    Deixar-me corrigir o problema

    Importante: esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo da forma incorrecta. Assim, certifique-se de que segue estes passos cuidadosamente. Para uma maior segurança, efectue uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:
    322756 Como criar uma cópia de segurança e restaurar o registo no Windows

    Para resolver este problema sozinho, siga estes passos:
    1. Elimine o perfil utilizando a caixa de diálogo Propriedades do Computador. Para tal, siga estes passos:
      1. Clique em Iniciar, clique com o botão direito do rato em Computador e, em seguida, clique em Propriedades.
      2. Clique em Alterar definições.
      3. Na caixa de diálogo Propriedades do Sistema, clique no separador Avançadas.
      4. Em Perfis de Utilizador, clique em Definições.
      5. Na caixa de diálogo Perfis de Utilizador, seleccione o perfil que pretende eliminar, clique em Eliminar e, em seguida, clique em OK.
    2. Clique em Iniciar
      Reduzir esta imagemExpandir esta imagem
      o botão Iniciar
      , escreva regedit na caixa Iniciar procura e prima ENTER.
    3. Localize e expanda a seguinte subchave do registo:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
    4. Clique com o botão direito do rato no SID que pretende remover e, em seguida, clique em Eliminar.
  2. Inicie sessão no computador e crie um novo perfil.
Esta informação foi útil? Envie-nos os seus comentários

Mais Informação

Os seguintes eventos são registados no registo de aplicações:

Clique aqui para mostrar ou ocultar as informações detalhadas

A informação contida neste artigo aplica-se a:
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Palavras-chave: 
kbtshoot kberrmsg kbexpertisebeginner kbprb kbfixme kbmsifixme kbcip KB947215