Id. de artículo: 947366 - Ver los productos a los que se aplica este artículo

El soporte técnico para Windows Vista sin ningún Service Pack instalado finalizará el 13 de abril de 2010. Para seguir recibiendo actualizaciones de seguridad para Windows, asegúrese de que está ejecutando Windows Vista con Service Pack 2 (SP2). Si desea más información, consulte esta página web de Microsoft: El soporte técnico finalizará para algunas versiones de Windows

Expandir todo | Contraer todo

En esta página

Síntomas

El artículo analiza cómo solucionar problemas durante la instalación de un Service Pack para Windows Vista o para Windows Server 2008.

Cuando intenta instalar un Service Pack, puede aparecer uno de los mensajes de error siguientes:
La instalación no se realizó correctamente
Error interno al instalar el Service Pack
El mensaje de error también se puede referir a uno de los siguientes códigos de error:
  • 0x80070002
  • 0x8007000D
  • 0x80073712
  • 0x800B0100
  • 0x8024200D
Nota: este artículo no enumera todos los posibles mensajes o códigos de error que puede recibir. Recomendamos las soluciones de este artículo a los problemas de instalación, con independencia de los mensajes o códigos de error que pueda recibir.

Nota: si aparece el código de error "0x80070490", visite el siguiente sitio web de Microsoft para solucionar el problema:
958044 Cuando usa los sitios web de Windows Update o Microsoft Update para instalar actualizaciones, aparece el código de error "0x80070490"

Causa

Este problema puede producirse por los motivos siguientes:
  • Un programa de su equipo interfirió con la instalación del Service Pack.
  • Se ha producido una incoherencia en Windows Servicing Store. Windows Servicing Store es un componente necesario para instalar los Service Pack.

Solucionar problemas de instalación de un Service Pack en Windows Vista y Windows Server 2008

Para resolver este problema, intente las soluciones de las secciones "Solución de problemas generales" y "Solución de problemas avanzada" en el orden en que se presentan. Después de intentar una solución, intente instalar de nuevo el Service Pack. Si sigue sin poder instalar el Service Pack, pruebe la solución siguiente.

Solución de problemas generales

Solución 1: Instalar el paquete independiente del Service Pack en lugar de utilizar Windows Update para instalar el Service Pack

Contraer esta imagenAmpliar esta imagen
assets folding start expanded
Nota: si ya ha intentado instalar el paquete independiente del Service Pack, y ha encontrado problemas, omita esta solución y vaya a la solución 2.

Si no está seguro de si ha intentado instalar el paquete independiente para el Service Pack, se recomienda que pruebe los siguientes pasos pata instalarlo. Al usar el paquete independiente del Service Pack, elimina los problemas de instalación que podrían estar relacionados con Windows Update. De esta forma se simplifica el proceso de solución de problemas.

Cómo obtener un paquete independiente del Service Pack

Para obtener el Service Pack, consulte los siguientes artículos de Microsoft Knowledge Base correspondientes a su sistema operativo y, a continuación, busque la opción de instalar el Service Pack desde el Centro de descarga de Microsoft.
935791 Cómo obtener el Service Pack más reciente para Windows Vista
968849 Cómo obtener el Service Pack más reciente para Windows Server 2008
Contraer esta imagenAmpliar esta imagen
assets folding end

Solución 2: Ejecutar la herramienta System Update Readiness, reiniciar el equipo y, a continuación, instalar el Service Pack

Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
La herramienta System Update Readiness comprueba el equipo e intenta resolver determinadas condiciones que podrían interferir con la instalación de actualizaciones o de otro software. Pero antes de descargar la herramienta, tendrá que determinar si su equipo está ejecutando una versión de 32 o de 64 bits del sistema operativo Windows Vista. Si su equipo tiene instalado Windows Vista y sabe la versión que ejecuta, consulte la sección Cómo descargar la herramienta System Update Readiness".

Si no está seguro acerca de qué versión ha instalado en su equipo, siga estos pasos:
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed

  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    .
  2. Escriba sistema en el cuadro Iniciar búsqueda y, a continuación, haga clic en Sistema en la lista Programas.

    Contraer esta imagenAmpliar esta imagen
    2819869
El sistema operativo se muestra del siguiente modo:
  • Para un sistema operativo de la versión de 32 bits, aparece Sistema operativo de 32 bits para el tipo de sistema bajo Sistema.
  • Para un sistema operativo de la versión de 64 bits, aparece Sistema operativo de 64 bits para el tipo de sistema bajo Sistema.
Contraer esta imagenAmpliar esta imagen
2819870


Nota: sistema operativo de 32 bits=sistema operativo x86 y sistema operativo de 64 bits=sistema operativo x64.
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed


Una vez que ha determinado la versión de Windows Vista que se ejecuta en su equipo, descargue la herramienta System Update Readiness.

Cómo descargar la herramienta System Update Readiness

Puede hacer clic aquí para descargar la herramienta System Update Readiness desde el siguiente sitio web del Centro de descarga de Microsoft. Los archivos siguientes pueden descargarse desde el Centro de descarga de Microsoft:
Contraer esta imagenAmpliar esta imagen
Descargar
Descargue ahora el paquete de la herramienta System Update Readiness para Windows Vista (KB947821).

Contraer esta imagenAmpliar esta imagen
Descargar
Descargue ahora el paquete de la herramienta System Update Readiness para Windows Vista x64 (KB947821).

Contraer esta imagenAmpliar esta imagen
Descargar
Descargue ahora el paquete de la herramienta System Update Readiness para Windows Server 2008 (KB947821).

Contraer esta imagenAmpliar esta imagen
Descargar
Descargue ahora el paquete de la herramienta System Update Readiness para Windows Server 2008 x64 (KB947821).

Contraer esta imagenAmpliar esta imagen
Descargar
Descargue ahora el paquete de la herramienta System Update Readiness para sistemas basados en Itanium (KB947821).

Después de descargar y ejecutar la herramienta System Update Readiness, reinicie el equipo. A continuación, intente instalar inmediatamente el paquete de descarga completo para el Service Pack que ha descargado anteriormente del siguiente sitio web del Centro de descarga de Microsoft: Para obtener más información acerca de la herramienta System Update Readiness, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
947821 Descripción de la herramienta System Update Readiness para Windows Vista y Windows Server 2008
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed

Solución 3: Cerrar o deshabilitar cualquier aplicación que pueda estar ejecutándose, reiniciar el equipo y, a continuación, instalar el Service Pack.

Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Importante: estos pasos pueden aumentar el riesgo de seguridad. También pueden hacer que el equipo o la red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como los virus. Recomendamos seguir el proceso que se describe en este artículo para permitir que los programas funcionen como están diseñados o implementar determinadas capacidades de los programas. Pero antes de realizar estos cambios, le recomendamos que evalúe los riesgos asociados a la implementación de este proceso en su entorno concreto. Si decide implementar este proceso, tome las medidas adicionales oportunas para ayudar a proteger el sistema. Le recomendamos que utilice este proceso sólo si realmente lo necesita.

Durante la instalación, una de las causas más frecuentes de los errores es cuando una aplicación de terceros abre un archivo o bloquea un archivo que el programa de instalación del Service Pack ha de usar. Por ejemplo, este problema lo puede causar una aplicación antivirus o anti spyware. Para minimizar esta posibilidad, siga estos pasos:
  1. Cierre todas las aplicaciones y reinicie el equipo.
  2. Una vez que el equipo se haya reiniciado, deshabilite cualquier aplicación antivirus o anti spyware que pueda cargarse durante el proceso de inicio. Normalmente puede deshabilitar la aplicación desde el área de notificación. Este área está ubicada en la esquina inferior derecha de la pantalla del equipo. Para deshabilitar una aplicación del área de notificación, siga estos pasos:
    1. Haga clic con el botón secundario en el icono correspondiente al programa de terceros.
    2. Haga clic en Cerrar, Deshabilitar, Salir o en un término similar de la lista de opciones. Si estas opciones no están disponibles, tendrá que abrir la aplicación y, después, deshabilitarla o cerrarla.
  3. En cuanto cierre el programa antivirus o la aplicación antispyware, intente hacer clic aquí para instalar el paquete de descarga completo para el Service Pack que ha descargado anteriormente del siguiente sitio web del Centro de descarga de Microsoft:
  4. Una vez completada la instalación del Service Pack, habilite la aplicación antivirus o anti spyware que deshabilitó en los pasos anteriores.
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed

Solución avanzada de problemas

Si todavía no ha resuelto el problema, puede intentar los pasos de la solución avanzada de problemas por sí mismo, o ponerse en contacto con el servicio de soporte técnico de Microsoft.

Solución 4: Desinstalar cualquier aplicación de seguridad, reiniciar el equipo y, a continuación, instalar el Service Pack.

Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Importante: estos pasos pueden aumentar el riesgo de seguridad. También pueden hacer que el equipo o la red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como los virus. Recomendamos seguir el proceso que se describe en este artículo para permitir que los programas funcionen como están diseñados o implementar determinadas capacidades de los programas. Pero antes de realizar estos cambios, le recomendamos que evalúe los riesgos asociados a la implementación de este proceso en su entorno concreto. Si decide implementar este proceso, tome las medidas adicionales oportunas para ayudar a proteger el sistema. Le recomendamos que utilice este proceso sólo si realmente lo necesita.

Una aplicación de seguridad de terceros (como una aplicación antivirus, un firewall o una aplicación anti spyware) puede seguir causando el error de la instalación incluso después de intentar deshabilitar la aplicación. La instalación de Windows Vista SP1 requiere varios reinicios del equipo y la aplicación de seguridad se puede recargar después del primer reinicio. También las aplicaciones que proporcionan características de reparación del Registro pueden causar el error de la instalación.

Puede desinstalar la aplicación de seguridad de terceros antes de instalar el Service Pack. Pero solo debería hacerlo si tiene la seguridad de que puede reinstalar la aplicación en cuanto haya terminado la instalación del Service Pack. Para reinstalar la aplicación de seguridad de terceros, necesitará el soporte de instalación original de la aplicación o la descarga original. Es posible que para reinstalar la aplicación de seguridad de terceros necesite también una clave de producto.

Si está seguro de que puede reinstalar la aplicación de terceros, desinstálela desde el elemento Programas y características del Panel de control. Para ello, siga estos pasos:
  1. Cierre todas las aplicaciones y reinicie el equipo.
  2. Cuando haya reiniciado el equipo, haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    .
  3. En el cuadro Iniciar búsqueda, escriba programas.
  4. Haga clic en Programas y características.
  5. Haga clic en el nombre del programa de seguridad que quiere desinstalar.
  6. Haga clic en Desinstalar.
  7. Después de desinstalar el programa, reinicie el equipo.
  8. Intente hacer clic aquí para instalar el paquete de descarga completo para el Service Pack que ha descargado anteriormente del siguiente sitio web del Centro de descarga de Microsoft.
    Nota: ha desinstalado su software de seguridad y su equipo es más vulnerable a los ataques de usuarios malintencionados o de software malintencionado, como los virus. Le recomendamos que no explore la Web, use el correo electrónico ni use Instant Messenger hasta que haya terminado de solucionar el problema y haya reinstalado su software de seguridad.
  9. Tras haber completado la instalación de Windows Vista SP1, reinstale el programa de seguridad que desinstaló en los pasos anteriores.
Nota: si el problema persiste, lamentamos comunicarle que este contenido no puede ofrecerle más ayuda. Quizá desee visitar el siguiente sitio web de Microsoft:
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed

Soluciones y problemas similares

Para obtener más información, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
971204 Error 0x80004005 de instalación del Service Pack para Windows Vista y Windows Server 2008
939399 Aparece un mensaje de error cuando intenta hacer una copia de seguridad en un equipo basado en Windows Vista: "0x80071A91"
931712 El cuadro de diálogo "Características de Windows" está vacío en Windows Vista o se recibe un mensaje de error que incluye el código siguiente al intentar usar Windows Update: "0x80073712"
Si no se resuelve el problema, desafortunadamente este contenido no puede ayudarle más. Quizá desee buscar otras soluciones en Microsoft Knowledge Base. Para realizar una búsqueda en Microsoft Knowledge Base, visite el siguiente sitio web de Microsoft:

Propiedades

Id. de artículo: 947366 - Última revisión: viernes, 22 de febrero de 2013 - Versión: 11.0
La información de este artículo se refiere a:
  • Service Pack 1 para Windows Vista sobre las siguientes plataformas
    • Windows Vista Ultimate
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Home Premium
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Home Basic
    • Windows Vista Home Basic 64-bit edition
  • Windows Vista Service Pack 2 sobre las siguientes plataformas
    • Windows Vista Ultimate
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Home Premium
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Home Basic
    • Windows Vista Home Basic 64-bit edition
Palabras clave: 
kbproductlink kbexpertisebeginner kbtshoot kbpubtypekc kberrmsg kbprb kbcip KB947366

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com