文書番号: 947366 - 最終更新日: 2011年11月1日 - リビジョン: 6.0

Windows Vista および Windows Server 2008 Service Pack のインストールの問題のトラブルシューティング方法

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。

Service Pack がインストールされていない Windows Vista のサポートは 2010 年 4 月 13 日に終了しました。 Windows 用のセキュリティ更新プログラムを継続して入手するには、Windows Vista Service Pack 2 (SP2) を実行していることを確認してください。詳細については、次のマイクロソフト Web ページを参照してください。Windows の一部バージョンのサポート終了のお知らせ

すべて展開する | すべて折りたたむ

現象

この資料では、Windows Vista または Windows Server 2008 用の Service Pack のインストール時の問題のトラブルシューティング方法について説明します。

Service Pack のインストール時に、以下のいずれかのエラー メッセージが表示されることがあります。
インストールは成功しませんでした
Service Pack のインストール中に内部エラーが発生しました
このエラー メッセージは、以下のいずれかのエラー コードを指していることもあります。
  • 0x80070002
  • 0x8007000D
  • 0x80073712
  • 0x800B0100
  • 0x8024200D
注: この資料は、可能性のあるすべてのエラー コードまたはメッセージの一覧を示すものではありません。この資料で示す解決方法は、表示されるエラー コードまたはメッセージとは関係なく、インストールの問題を解決するために推奨されます。

原因

この問題は、以下の状況のいずれかに該当する場合に発生することがあります。
  • Service Pack のインストールとコンピューター上のプログラムが干渉している。
  • Windows Servicing Store に不整合がある。Windows Servicing Store は、Service Pack を正常にインストールするために必要なコンポーネントです。

Windows Vista および Windows Server 2008 Service Pack のインストールのトラブルシューティング

この問題を解決するには、「一般的なトラブルシューティング」と「高度なトラブルシューティング」にあるそれぞれの解決方法を、示されている順に従って実行してください。解決方法を実行したら、再度 Service Pack のインストールを実行します。これまでの手順を実行しても Service Pack をインストールできない場合は、以下の方法に進みます。

一般的なトラブルシューティング

解決方法 1: Windows Update を使用して Service Pack をインストールするのではなく、Service Pack のスタンドアロン パッケージをインストールする

詳細情報の表示/非表示を切り替えるにはここをクリック

解決方法 2システム更新準備ツールを実行する

詳細情報の表示/非表示を切り替えるにはここをクリック

解決方法 3: 実行中のアプリケーションをすべて終了または無効にし、コンピューターを再起動してから Service Pack をインストールする

詳細情報の表示/非表示を切り替えるにはここをクリック

高度なトラブルシューティング

依然として問題が解決されない場合、自分で高度なトラブルシューティング手順を試すか、マイクロソフトのサポートに問い合わせることができます。

解決方法 4: セキュリティ プログラムをすべてアンインストールし、コンピューターを再起動してから Service Pack をインストールする

詳細情報の表示/非表示を切り替えるにはここをクリック

類似した問題と解決方法

詳細については、以下のサポート技術情報番号をクリックしてください。
971204 Windows Vista および Windows Server 2008 Service Pack のインストールがエラー 0x80004005 で失敗する
939399 Windows Vista ベースのコンピューターでバックアップを実行するときに、エラー メッセージ "0x80071A91" が表示される
931712 Windows Vista で空の [Windows の機能] ダイアログ ボックスが表示される、または Windows Update を使用するときにコード "0x80073712" を含むエラー メッセージが表示される
これでも問題が解決しない場合は、この資料に記載されている方法では、発生している問題を解決できません。以下のマイクロソフト Web サイトにアクセスし、その他の解決方法について、サポート技術情報を検索してください。サポート技術情報を検索するには、以下のマイクロソフト Web サイトにアクセスします。

この資料は以下の製品について記述したものです。
  • Windows Vista Service Pack 1?を以下の環境でお使いの場合
    • Windows Vista Ultimate
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Home Premium
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Home Basic
    • Windows Vista Home Basic 64-bit edition
  • Windows Vista Service Pack 2?を以下の環境でお使いの場合
    • Windows Vista Ultimate
    • Windows Vista Ultimate 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Enterprise 64-bit edition
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Home Premium
    • Windows Vista Home Premium 64-bit edition
    • Windows Vista Home Basic
    • Windows Vista Home Basic 64-bit edition
キーワード:?
kbproductlink kbexpertisebeginner kbtshoot kbpubtypekc kberrmsg kbprb kbcip KB947366
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"