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Windows Media Player stops responding after you install a third-party product that registers its own version of the Wmp.dll file

Article ID:947541
Last Review:February 18, 2008
Revision:2.2
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows XP and Windows Vista

SYMPTOMS

When you install a third-party product that registers its own version of the Wmp.dll file on a Windows Vista-based computer, Windows Media Player stops responding.

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CAUSE

This problem occurs because the third-party product uses its own installation directory to install the Wmp.dll file on the Windows Vista-based computer. When this occurs, the InstalledVersions corruption check that Windows Media Player performs is bypassed and Windows Media Player is blocked or stops responding.

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RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To resolve this problem, follow these steps:
1.Log on as an administrator.
2.Click Start, type cmd in the Start Search text box, right-click cmd.exe, click Run as administrator, and then click Continue.
3.An the command prompt, type regsvr32 wmp.dll, and then click OK.
4.Start Notepad.
5.Paste the following text into Notepad:
REGEDIT4 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA71-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.WMZ" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA72-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.AIFF" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA73-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.AU" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA74-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.MIDI" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA76-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.MP3" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA77-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.MP3" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA78-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.M3U" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA7B-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.WAV" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA83-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.WAX" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA84-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.WMA" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA88-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.AVI" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA89-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.MPEG" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA8F-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.ASX" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA90-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.ASX" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA92-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.ASF" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA93-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.ASX" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA94-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.WMV" 
[HKEY_CLASSES_ROOT\CLSID\{CD3AFA95-B84F-48F0-9393-7EDC34128127}\ProgID] @="WMP11.AssocFile.WVX" 
[HKEY_CLASSES_ROOT\CLSID\{EE4DA6A4-8C52-4a63-BBB8-97C93D7E1B6C}\ProgID] @="WMP11.AssocFile.WMD"
6.Save the file as VistaWMPFix.reg.
7.Start Registry Editor.
8.Click File, and then click Import.
9.Select the VistaWMPFix.reg file that you created in step 6, and then click OK.

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APPLIES TO
Windows Vista Enterprise
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Ultimate

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Keywords: 
kbtshoot kbbug kbregistry kbprb kbexpertiseinter KB947541

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