Help and Support

Windows Vista Service Pack 1 is not available for installation from Windows Update and is not offered by Automatic Updates

Article ID:948343
Last Review:May 5, 2008
Revision:9.0

SYMPTOMS

Windows Vista Service Pack 1 (SP1) is not available for installation from Windows Update, and Automatic Updates does not offer Windows Vista SP1 for installation.

In mid-April 2008, Microsoft will begin distributing Windows Vista SP1 by using the Automatic Update (AU) system for English, German, French, Spanish, and Japanese. Microsoft will begin distribution of Windows Vista SP1 to a small percentage of Windows Vista users each day and will slowly increase distribution over time. If you do not want to wait for the regular AU distribution, you may scan Windows Update manually and Windows Vista SP1 will be offered for installation on most systems. The only systems Windows Vista SP1 will not automatically offer to are those that meet one of the conditions mentioned in this article.

For more information about how to obtain Windows Vista Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
935791 (http://support.microsoft.com/kb/935791/) How to obtain the latest Windows Vista service pack

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CAUSE

This problem occurs because of one or more of the following causes.

Cause 1

You are already running Windows Vista SP1.

Cause 2

You use the third-party program vLite to configure the system, and you may have removed required system components that must be available for Windows Vista SP1 to be installed. For more information, visit the following vLite Web site:
http://www.vlite.net (http://www.vlite.net)

Cause 3

Windows Service Pack Blocker Tool is used to block the delivery of Windows Vista SP1 from Automatic Updates or from Windows Update.

Cause 4

You tried to install Windows Vista SP1, and the installation failed with a known inconsistency in the file or registry structure.

Cause 5

A hardware device driver or device software was problematic when you updated to Windows Vista SP1.

The Windows Update service can detect the small set of device drivers and software that falls into this category. The Windows Update service will not offer Windows Vista SP1 until an update for the hardware device driver or the device software has been installed.

Cause 6

You have installed a prerelease version of Windows Vista SP1, and you must uninstall the prerelease version, or start with a new installation of Windows Vista.

Cause 7

You see one or more updates for Windows Vista when you run Windows Update. However, you do not see Windows Vista SP1 listed.

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RESOLUTION

To resolve this problem, use one or more of the following methods, as appropriate for your situation.

Method for Cause 1

Determine whether you are running Windows Vista SP1. To do this, follow these steps:
1.Click StartStart button, right-click Computer, and then click Properties.
2.If Windows Vista SP1 is installed, you will see that a reference to Windows Vista SP1 is displayed at the bottom of the Windows Edition section.
Method for Cause 2

The third-party program (vLite) can be used to remove required system components. For more information, visit the following vLite Web site:
http://www.vlite.net (http://www.vlite.net)
Method for Cause 3

For more information about Windows Service Pack Blocker Tool, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/windowsvista/bb927794.aspx?wt.svl=leftnav (http://technet.microsoft.com/en-us/windowsvista/bb927794.aspx?amp;wt.svl=leftnav)
Method for Cause 4

You may have experienced a known inconsistency in the file system or in the registry for the current set of installed Windows components. If the system has one of a set of repairable inconsistencies, Windows Update will offer an update that will repair this issue. Reopen Windows Update, and then click Check for Updates again. To do this, follow these steps:
1.Click StartStart button, type Windows Update in the Start Search box, and then press ENTER.
2.Click Check for updates.
If your computer has this known inconsistency, we will now offer an update that will make the correction and that will let Windows Vista SP1 be offered and installed when Windows Update is next checked.

Note For most users, Automatic Updates will offer this solution, and then it will re-offer Windows Vista SP1 without any interaction required.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
947821 (http://support.microsoft.com/kb/947821/) Description of the System Update Readiness Tool for Windows Vista
Method for Cause 5

To help ensure a positive update experience, Windows Update will temporarily not offer Windows Vista SP1 to systems that have the following device drivers installed. In some cases, these device drivers are problematic on Windows Vista-based computers when you update to Windows Vista SP1. By installing updated device drivers, you will resolve the issue and enable Windows Update to offer Windows Vista SP1.

Audio drivers

Realtek AC'97
For x86-based computers: Alcxwdm.sys - version 6.0.1.6242 or earlier
For x64-based computers: Alcwdm64.sys - version 6.0.1.6242 or earlier
IDT/SigmaTel
For x86-based computers: Sthda.cat - published 12/17/07 or earlier
For x64-based computers: Sthda64.cat - published 12/17/07 or earlier
IDT/SigmaTel
For x86-based computers: Stwrt.cat - published 12/17/07 or earlier
For x64-based computers: Stwrt64.cat - published 12/17/07 or earlier

Exceptions for IDT/SigmaTel drivers were made on certain models of Dell, HP, and Sony computers because these drivers were updated to address this issue before the 12/17/07 publish date.
Creative Audigy
For x86-based and x64-based computers: Ctaud2k.sys - version 6.0.1.1242 or earlier
For x86-based and x64-based computers: P17.sys – version 5.12.1.2004 or earlier
Conexant HD Audio
For x86-based computers: Chdart.sys - version 4.32.0.0 or earlier
For x64-based computers: Chdart64.sys - version 4.32.0.0 or earlier
Biometric (Fingerprint) Sensors
AuthenTec Fingerprint Sensor with the Atswpdrv.sys driver file – version 7.7.1.7 or earlier
UPEK Fingerprint Sensor with the Tcusb.sys driver file – version 1.9.2.99 or earlier
Display drivers

Intel Display
For x86-based computers: Igdkmd32.sys – versions between and including driver 7.14.10.1322 and 7.14.10.1403
For x64-based computers: Igdkmd64.sys – versions between and including driver 7.14.10.1322 and 7.14.10.1403
Other drivers

Texas Instruments Smart Card Controller with the GTIPCI21.sys driver file – version 1.0.1.19 or earlier

Sierra Wireless AirCard 580 with the Watcher.exe application – version 3.4.0.9 or earlier (This application is located in the AirCard 580 Program Files folder.) A solution for this is now available from Sierra Wireless. For more information, visit the following Sierra wireless Web site:
http://www.sierrawireless.com/faq/ShowFAQ.aspx?ID=1217 (http://www.sierrawireless.com/faq/ShowFAQ.aspx?ID=1217)
Symantec software driver for Symantec Endpoint Protection and for Symantec Network Access Control clients
For x86-based computers: Wgx.sys – versions 11.0.1000.1091 or earlier
For x64-based computers: Wgx64.sys – versions 11.0.1000.1091 or earlier
Note Symantec is aware of this issue and has a solution. For more information, visit the Symantec web site:
http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007121216494948?Open&docid=2007121216360648&nsf=ent-security.nsf&view=docid_p (http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007121216494948?Open&docid=2007121216360648&nsf=ent-security.nsf&view=docid_p)
Additional Windows Vista SP1 driver information for the Fujitsu-Siemens Amilo LA Notebook (Laptop)

Additionally, Windows update will not offer Windows Vista SP1 to Fujitsu-Siemens Amilo LA 1703 Notebooks that have a BIOS release date of March 14, 2008 or earlier. This corresponds to Bios Revision numbers 8.6T1-0023-M007 or earlier. This block reflects an incorrect power management setting that will be resolved in an updated BIOS revision. For more information, visit the following Fujitsu-Siemens support site:
http://support.fujitsu-siemens.com/com/support/downloads.html (http://support.fujitsu-siemens.com/com/support/downloads.html)
Select Notebooks and AMILO La 1703. An updated BIOS (8.6 or a later version) will be posted soon.

If the resolution for the driver blocking issue is not listed above, you may be able to resolve it using one of the methods below:

Resolution 1: Install device driver updates from Windows Update
1.Click StartStart button, type Windows Update in the Start Search box, and then press ENTER.
2.Click Check for updates.
3.Review the list of all the updates, including those that are marked as Optional. Install any hardware device drivers that are listed.
4.When driver installation is complete, click Check for updates again to see whether Windows Vista SP1 is now offered.
Resolution 2: Install manufacturer's updates

Visit the driver download site on your computer manufacturer’s Web site. Look for recently updated device drivers that have not yet been installed. As soon as you have updated your computer, return to Windows Update, and then click Check for Updates again to see whether Windows Vista SP1 is now offered.

Method for Cause 6

Resolution 1: For users who installed the prerelease update package for Windows Vista SP1

If you have installed a prerelease version of the Windows Vista SP1 update, you must uninstall this version to install the final release of the service pack. To do this, follow these steps:
1.Click Start, type Programs and Features in the Start Search box, and then click Programs and Features in the Programs list. If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
2.In the Tasks pane, click View installed updates.
3.Click Service Pack for Microsoft Windows (KB936330), and then click Uninstall.
Resolution 2: For users who installed the full version of the prerelease of Windows Vista with SP1

If you have installed the full version of the prerelease of Windows Vista with SP1, you must upgrade to the final version of Windows Vista SP1, or you must perform a clean installation of the final version. (Full versions of prereleased software are not licensed to be run after the Beta period.) To do this, follow these steps:
1.Obtain a full version of Windows Vista with SP1. You may be able to download this from the same source that offered you the prerelease version, or you may have to obtain a copy from a local retailer when it is released for sale.
2.Insert the Windows Vista DVD, and then follow instructions about how to install Windows Vista. You must enter a genuine licensed product key when you are asked.
3. At the installation choice screen, you will be offered either the upgrade option or the custom installation option. Select the appropriate option with the understanding that a custom installation choice will cause you to lose access to your data and your installed programs.
Method for Cause 7

Windows Vista SP1 cannot be installed together with any other updates. It must be installed by itself. Therefore, if there are any pending updates on Windows Update, such as security updates, Windows Update will not offer Windows Vista SP1 until the updates are installed. To install all pending updates, follow these steps:
1.Click Start, type Windows Update in the Start Search box, and then press ENTER.
2.Click Check for updates. Review the list of updates, and then verify that all updates that are marked Important or Recommended are checked.
3.Click Install Updates to begin the installation. You may be asked to restart the computer when the installation is complete.
Windows Vista SP1 will be offered after all pending updates are installed by re-checking Check for updates.

Hiding updates as an alternative resolution for Cause 7

You can select not to install an offered update by un-checking the item from the Windows Update list and agreeing to hide the update. Microsoft does not recommend doing this. Specifically, Windows Vista SP1 will not be offered to users who hide one of the following updates:
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935509 (http://support.microsoft.com/kb/935509/) A software update is available for versions of Windows Vista that include the Windows BitLocker Drive Encryption feature
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
938371 (http://support.microsoft.com/kb/938371/) A software update is available for the Windows Vista installation components
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
937287 (http://support.microsoft.com/kb/937287/) A software update is available for the Windows Vista installation software feature
Important information about installing Windows Vista SP1 by using WSUS Users who run a Windows Server Update Services (WSUS) environment are only affected by Causes 1 through 4 and by Cause 6. System Administrators should review the list of devices and the device drivers that are listed in the "Method for Cause 5" section. In some cases, these device drivers are problematic on Windows Vista-based computers when you update to Windows Vista SP1. Check for updates to these drivers before you install Windows Vista SP1.

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MORE INFORMATION

For information about how to contact hardware and software vendors, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416 (http://support.microsoft.com/kb/65416/) Hardware and software vendor contact information, A-K

60781 (http://support.microsoft.com/kb/60781/) Hardware and software vendor contact information, L-P

60782 (http://support.microsoft.com/kb/60782/) Hardware and software vendor contact information, Q-Z


The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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APPLIES TO
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate
Windows Vista Business
Windows Vista Enterprise
Windows Vista Starter
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Service Pack 1

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Keywords: 
kbexpertisebeginner kbtshoot kbprb KB948343

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