Article ID: 949914 - Last Review: May 28, 2008 - Revision: 1.0

Citrix ICA clients may crash when they are connecting to a Windows Server 2008-based terminal server that has Citrix Presentation Server installed

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SYMPTOMS

Users connect Citrix ICA clients to a Windows Server 2008-based terminal server that has Citrix Presentation Server installed. However, the ICA clients may crash during the connection process.

CAUSE

The size of the public key that is used to encrypt Terminal Services Client Access Licenses (TS CAL) is increased from 512 bytes to 2,048 bytes. The terminal server does not negotiate with clients when it uses the new key size. Therefore, the Citrix Virtual Channel for older versions of ICA clients may fail.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

This hotfix automatically creates the following registry entry:

Subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM
Registry entry: Use512LenPropCert
Data type: REG_DWORD
Value: 0 or 1

After you apply this hotfix, the Use512LenPropCert registry entry is automatically created. The value of this registry entry does not control the hotfix behavior. If the Use512LenPropCert registry entry is present, the size of the public key that is selected and used to encrypt TS CALs depends on the version of the client. Clients that support 2,048-byte public keys receive 2,048-byte public keys. Down-level clients receive 512-byte public keys.

To revert to the pre-hotfix status, delete this registry entry, and then restart the computer.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll6.0.6001.2216284,99218-Apr-200805:30x86
Windows Server 2008, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll6.0.6001.22162232,96018-Apr-200809:29IA-64
Windows Server 2008, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mstlsapi.dll6.0.6001.22162139,26418-Apr-200806:41x64

WORKAROUND

To work around this problem, upgrade Citrix ICA clients to a version that is compatible with Windows Server 2008.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

APPLIES TO
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
Keywords: 
kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe KB949914
 

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