Article ID: 951430 - Last Review: August 13, 2009 - Revision: 1.0

A non-administrator user cannot log on to a domain from a computer that is running Windows Server 2008 if you set the locale information for the user by using a Group Policy preference setting

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SYMPTOMS

Consider the following scenario:
  • You use a Group Policy preference setting to configure the locale information for a user in an Active Directory domain environment. The locale is set to a locale other than English (United States), such as English (United Kingdom).
  • The user tries to log on to the domain from a computer that is running Windows Server 2008.
In this scenario, the user cannot log on to the domain successfully. When this issue occurs, you can still log on to the domain by using an administrator account from this computer. After you log on to the domain, you find that the Windows Event Log service and other services have the "starting" status.

Note To check the status of a service, you view the Services Microsoft Management Console (MMC) snap-in window.

CAUSE

This problem occurs because the Group Policy preference setting sets incorrect locale data into a registry key. This behavior causes an exception in the Windows Event Log service. Therefore, the logon attempt by the user fails.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Gpprefcl.dll6.0.6001.22474638,97617-Jul-200914:26x86
Gpprefcl.dll6.0.6002.22179638,97617-Jul-200914:16x86
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gpprefcl.dll6.0.6001.22474833,02417-Jul-200914:37x64SP1Not Applicable
Gpprefcl.dll6.0.6001.22474638,97617-Jul-200914:26x86SP1WOW
Gpprefcl.dll6.0.6002.22179833,02417-Jul-200914:07x64SP2Not Applicable
Gpprefcl.dll6.0.6002.22179638,97617-Jul-200914:16x86SP2WOW
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gpprefcl.dll6.0.6001.224741,646,59217-Jul-200914:34IA-64SP1Not Applicable
Gpprefcl.dll6.0.6001.22474638,97617-Jul-200914:26x86SP1WOW
Gpprefcl.dll6.0.6002.221791,646,59217-Jul-200914:00IA-64SP2Not Applicable
Gpprefcl.dll6.0.6002.22179638,97617-Jul-200914:16x86SP2WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684   (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB951430
 

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