Error message when you try to install an application on a Windows Vista SP1-based or Windows 7 computer: "Command line option syntax error."

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Article ID: 952211 - View products that this article applies to.
Support for Windows Vista Service Pack 1 (SP1) ends on July 12, 2011. To continue receiving security updates for Windows, make sure you're running Windows Vista with Service Pack 2 (SP2). For more information, refer to this Microsoft web page: Support is ending for some versions of Windows.
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SYMPTOMS

Consider the following scenario.
  • You are running a Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) or a Windows 7 based computer
  • You use a user name that includes a double-byte character set (DBCS) character.
When you try to install an application that uses the Microsoft Visual C++ 2005 Redistributable Package, you receive the following error message:
Command line option syntax error. Type command/? For help.

CAUSE

This problem occurs because the Win32 Cabinet Self-Extractor tool cannot handle the DBCS characters in the user name.

RESOLUTION

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50794


Notes
  • The Fix it solution will not work if your account is not an administrator account.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To resolve this problem, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , right-click Computer, and then click Properties.
  2. In the Computer name, domain, and workgroup settings area, click Change settings.

    Collapse this imageExpand this image
     User Account Control permission
    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
  3. Click Change Settings and then selct the Advanced tab. Click on the Environment variables button
  4. In the User variables area, click TEMP, and then click Edit.
  5. In the Variable value box, type C:\Temp, and then click OK two times.
  6. Click Apply, and then click OK.
  7. Follow steps 4 through 6 for the TMP environment variable as well.
  8. Confirm that C:\Temp folder exists, if not create one.
  9. Restart the computer.
  10. Attempt to install the application again.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.

Properties

Article ID: 952211 - Last Review: December 1, 2011 - Revision: 4.0
APPLIES TO
  • Windows 7 Home Premium
  • Windows 7 Home Premium E
  • Windows 7 Home Premium N
  • Windows 7 Enterprise
  • Windows 7 Enterprise E
  • Windows 7 Enterprise N
  • Windows 7 Home Basic
  • Windows 7 Professional
  • Windows 7 Professional E
  • Windows 7 Professional N
  • Windows 7 Starter
  • Windows 7 Starter E
  • Windows 7 Starter N
  • Windows 7 Ultimate
  • Windows 7 Ultimate E
  • Windows 7 Ultimate N
  • Windows Vista Service Pack 1
  • Microsoft Windows XP Service Pack 3
Keywords: 
kberrmsg kb3rdpartyhardware kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme KB952211

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