Applies ToMicrosoft System Center Configuration Manager 2007

Problem description

When you use System Center Configuration Manager on a site that has many packages or distribution points, the Distribution Manager component may be unavailable for package processing for several hours after startup.Additionally, messages that resemble the following are logged in the Distribution Manager log (Distmgr.log):

Setting SigURL to <URL> for package <package name> on DP <DP path> SMS_DISTRIBUTION_MANAGER <date> <time>

Cause

During the startup process, Distribution Manager sets the signature and content path URLs for each package on each distribution point. Distribution Manager takes a long time to finish this activity. And because Distribution Manager does not handle package distribution before this activity is finished, you experience a long delay.

Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:

971348 List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Apply the hotfix

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have System Center Configuration Manager 2007 Service Pack 1 installed.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Distmgr.dll

4.0.6221.1114

449,464

30-Nov-2008

20:05

x86

Note The file attribute information applies to both International Client Pack 1 ( ICP1) and International Client Pack 2 (ICP)2.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsTo resolve this issue, apply hotfix 956194 on System Center Configuration Manager 2007 site servers.

Disable DP property-checking

After you apply this hotfix to a site, you can resolve the issue by disabling DP property-checking during the Distribution Manager startup process. To have us fix this problem for you, go to the "Fix it for me" section. If you'd rather fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problemlink. Then, click Runin theFile Downloaddialog box and follow the steps in this wizard.

Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem. Now go to the "Did this fix the problem?" section.

Let me fix it myself

To disable DP property-checking by changing the registry, follow these steps:

  1. Locate the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Components\SMS_DISTRIBUTION_MANAGER

  2. Create the following new value:

    Name: DoNotVerifyDPPropertiesOnStartUpType: REG_DWORDValue: 1Note This disables the verification that Distribution Manager runs on DP properties at startup.If the DoNotVerifyDPPropertiesOnStartUp item does not exist, or if its value is set to 0, Distribution Manager will verify DP properties during the startup process. If the value of the DoNotVerifyDPPropertiesOnStartUp item is set to 1, this verification behavior is disabled.

Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the problem is not fixed, you can contact support.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

This delay is caused by a verification step that occurs when the Distribution Manager component is restarted. This hotfix lets a Configuration Manager administrator disable this task.For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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