Article ID: 956197 - Last Review: April 20, 2009 - Revision: 6.3

Some Web sites may not be displayed correctly or work correctly in Windows Internet Explorer 8

Guided help to troubleshoot Web sites that are not displayed correctly or that do not work correctly
This Knowledge Base article is intended for advanced users, for support professionals, for network administrators, for Web content developers, and for Web site administrators.

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For self-help steps for beginning-to-intermediate computer users, visit the following Microsoft Web site:
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Guided Help for Web sites that are not displayed correctly or that do not work correctly in Internet Explorer 8 (http://support.microsoft.com/gp/pc_ie_v8intro)

Note This Guided Help content may not be available in all languages.

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SYMPTOMS

Some Web sites may not be displayed correctly or work correctly in Windows Internet Explorer 8. This problem does not occur in earlier versions of Internet Explorer, and the affected Web sites continue to be displayed correctly and to work correctly in Windows Internet Explorer 7.

For example, you may experience any of the following symptoms in Internet Explorer 8:
  • Menus, images, or text are in the wrong positions on some Web sites.
  • Some Web site features do not work.
  • You receive script error messages on some Web sites.
  • Internet Explorer stops working or crashes on some Web sites.

CAUSE

Some Web sites are designed for older browsers. You may experience compatibility issues on these sites until they are updated for Internet Explorer 8.

WORKAROUND

Internet Explorer 8 includes a Compatibility View feature that displays Web sites that were created for older browsers as they were designed to appear. You can enable Compatibility View in Internet Explorer or on the Web server.
  • Enable Compatibility View for a single computer. To do this, try Method 1 for each Web site that is not displayed correctly or that does not work correctly. If this problem occurs on many Web sites that you frequently visit, you can enable Compatibility View for all Web sites by using Method 2. These methods are intended for users who are running Internet Explorer.
  • Enable Compatibility View in Internet Explorer for multiple computers in an enterprise environment. To do this, use Method 3. This method is intended for enterprise network administrators.

Enable Compatibility View in Internet Explorer

Method 1: Enable Compatibility View for specific Web sites by using Internet Explorer

To enable Compatibility View for specific Web sites that are not displayed correctly or that are not working correctly, follow these steps:
  1. Open the Web site that is not displayed correctly or that does not work correctly in Internet Explorer 8.
  2. Click the Compatibility View button that is located directly to the right side of the address bar next to the Refresh button.

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    Compatibility View button


    Or, on the Tools menu, click Compatibility View.

    Note If the Compatibility View button does not appear to the right side of the address bar, or if the command is not available on the Tools menu, you cannot use this method. You may be experiencing a different problem, or the network administrator may have used a Group Policy setting to configure the Compatibility View settings on your computer. Compatibility View is not required, and the Compatibility View commands will not be available if the Web site was designed for earlier versions of Internet Explorer.
If this method worked, and the Web site is now displayed correctly and works correctly, you are finished. However, you may have to repeat this method for each Web site that experiences these problems.

Note When you use this method to fix a Web site, Internet Explorer saves your Compatibility View setting for that Web site. Every time that you visit that site, Compatibility View will be used. To stop a Web site from running in Compatibility View, repeat this method by clicking the Compatibility View button again for that Web site. You can also add or remove specific Web sites from Compatibility View without actually visiting each Web site. To do this, click Tools, and then click Compatibility View Settings.

If this method did not work, and the Web site is still not displayed correctly or still is not working, you are experiencing a different problem. See the "Similar problems and solutions and support information" section for alternative steps.

Method 2: Enable Compatibility View for all Web sites by using Internet Explorer

Most Web sites that you frequently visit are not displayed correctly or are not working correctly. You have tried Method 1 on some of these Web sites, and that method worked. However, you may want to enable Compatibility View for all Web sites. To do this, follow these steps:
  1. Start Internet Explorer 8.
  2. On the Tools menu, click Compatibility View Settings.

    If Compatibility View Settings is not available, the network administrator may have used a Group Policy setting to configure the options for you. Contact your administrator or the help desk.
  3. Click to select the Display all websites in Compatibility View check box, and then click Close.

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    Compatibility View Settings
Visit several Web sites that were not displayed correctly or that were not working to see whether the problem is now resolved.

If this method worked, and all Web sites are now displayed correctly and work correctly, you are finished.

If this method did not work, and some or all of the Web sites are still not displayed correctly or are not working, you are experiencing a different problem. See the "Similar problems and solutions and support information" section for alternative steps.

Enable Compatibility View in Internet Explorer for multiple computers

Method 3: Set Compatibility View options for multiple computers in an enterprise environment by using Group Policy settings

To enable Compatibility View for multiple computers in an enterprise environment, administrators can use the following new Compatibility View Group Policy settings that are available for Internet Explorer 8:
  • Turn on Internet Explorer 7 Standards Mode: This setting enables Compatibility View for all Web sites and prevents users from enabling or disabling Compatibility View for any Web sites.
  • Turn off Compatibility View: This setting disables Compatibility View for all Web sites and prevents users from enabling or disabling Compatibility View for any Web sites.
  • Turn on Internet Explorer Standards Mode for Local Intranet: This setting disables Compatibility View (enables Standards Mode) for all intranet Web sites.
  • Use Policy List of Internet Explorer 7 sites: This setting lets administrators add specific sites that must be viewed in Compatibility View. Users can add or remove sites from the list. However, they cannot remove sites that are specified by the administrator.
  • Turn off Compatibility View button: This setting prevents users from using the Compatibility View button to try to fix Web sites. This setting does not work in Windows Internet Explorer 8.
These settings are available for both Users and Computers in the following location for each site, domain, and organizational unit:
Administrative Templates/Windows Components/Internet Explorer/Compatibility View
For more information about these Group Policy settings, see the explanations in the Group Policy user interface.

Similar problems and solutions and support information

To troubleshoot similar problems and solutions if you are a beginning-to-intermediate computer user, try our Guided Help. For more information about advanced solutions, click the following article number to view the article in the Microsoft Knowledge Base:
968499  (http://support.microsoft.com/kb/968499/ ) Advanced solutions: Some Web sites may not be displayed correctly or work correctly in Windows Internet Explorer 8
To contact support for Internet Explorer 8, visit the following Microsoft Web site:
http://support.microsoft.com/oas/default.aspx?prid=12357 (http://support.microsoft.com/oas/default.aspx?prid=12357)
To view the release notes for Internet Explorer 8, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/ie/dd441788.aspx (http://msdn.microsoft.com/en-us/ie/dd441788.aspx)

APPLIES TO
  • Windows Internet Explorer 8
Keywords: 
kbexpertisebeginner kbgraphxlink kbtshoot KB956197
 

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