Numéro d'article: 956197 - Dernière mise à jour: mercredi 21 octobre 2009 - Version: 6.3

Il se peut que certains sites Web ne s'affichent pas correctement ou ne fonctionnent pas dans Windows Internet Explorer 8

Aide interactive pour le dépannage de sites Web qui ne s'affichent pas correctement ou qui ne fonctionnent pas
Cet article de la Base de connaissances est destiné aux utilisateurs expérimentés, aux spécialistes du support technique, aux administrateurs réseau, aux développeurs Web et aux administrateurs de sites Web.

Réduire cette imageAgrandir cette image
Vous trouverez des étapes d'auto-assistance destinées aux utilisateurs débutants ou de niveau intermédiaire sur le site Web Microsoft suivant :
Réduire cette imageAgrandir cette image
Aide interactive pour les sites Web qui ne s'affichent pas correctement ou qui ne fonctionnent pas dans Internet Explorer 8 (http://support.microsoft.com/gp/pc_ie_v8intro)

Remarque Cette Aide interactive n'est pas disponible dans toutes les langues.

Sommaire

Agrandir tout | Réduire tout

Symptômes

Il se peut que certains sites Web ne s'affichent pas correctement ou ne fonctionnent pas dans Windows Internet Explorer 8. Ce problème ne se pose pas dans d'anciennes versions d'Internet Explorer, et les sites concernés s'affichent correctement et fonctionnent dans Windows Internet Explorer 7.

Par exemple, vous pouvez rencontrer l'un des problèmes suivants dans Internet Explorer 8 :
  • position incorrecte des menus, des images ou du texte sur certains sites Web :
  • certaines fonctionnalités du site Web ne fonctionnent pas ;
  • vous recevez des messages relatifs à des erreurs de script sur certains sites Web ;
  • Internet Explorer cesse de fonctionner ou se bloque sur certains sites Web.

Cause

Certains sites Web sont conçus pour d'anciens navigateurs. Des problèmes de compatibilité peuvent survenir sur ces sites jusqu'à ce qu'ils soient mis à jour pour Internet Explorer 8.

Contournement

Internet Explorer 8 comprend un mode Affichage de compatibilité qui affiche les sites Web créés pour d'anciens navigateurs de la façon prévue à l'origine. Vous pouvez activer l'affichage de compatibilité dans Internet Explorer ou sur le serveur Web.
  • Activation de l'affichage de compatibilité pour un seul ordinateur. Pour ce faire, utilisez la méthode 1 pour chaque Web qui ne s'affiche pas correctement ou qui ne fonctionne pas. Si ce problème se pose dans de nombreux sites Web que vous visitez fréquemment, vous pouvez activer l'affichage de compatibilité pour tous les sites Web en employant la méthode 2. Ces méthodes sont destinées aux utilisateurs d'Internet Explorer.
  • Activez l'affichage de compatibilité dans Internet Explorer pour plusieurs ordinateurs dans un environnement d'entreprise. Pour cela, appliquez la méthode 3. Cette méthode est destinée aux administrateurs de réseaux d'entreprise.

Activation de l'affichage de compatibilité dans Internet Explorer

Méthode 1 : activation de l'affichage de compatibilité pour certains sites à l'aide d'Internet Explorer

Pour activer l'affichage de compatibilité pour certains sites Web, qui ne s'affichent pas correctement ou ne fonctionnent pas, procédez comme suit :
  1. Ouvrez le site Web qui ne s'affiche pas correctement ou qui ne fonctionne pas dans Internet Explorer 8
  2. Cliquez sur le bouton Affichage de compatibilité qui se trouve à droite de la barre d'adresses, à côté du bouton Actualiser.

    Réduire cette imageAgrandir cette image
    Bouton Affichage de compatibilité


    Alternativement, dans le menu Outils, cliquez sur Affichage de compatibilité.

    Remarque Si le bouton Affichage de compatibilité ne figure pas à droite de la barre d'adresses ou si cette commande n'est pas disponible dans le menu Outils, il est impossible d'employer cette méthode. Il se peut que vous soyez confronté à un problème différent ou que l'administrateur réseau ait employé un paramètre de stratégie de groupe pour configurer les paramètres d'affichage de compatibilité sur votre ordinateur. Si le site Web a été conçu pour d'anciennes versions d'Internet Explorer, l'affichage de compatibilité n'est pas nécessaire et les commandes Affichage de compatibilité ne fonctionneront pas.
Si cette méthode a fonctionné et que le site Web s'affiche correctement et fonctionne, vous avez terminé. Il peut toutefois être nécessaire de répéter l'opération pour chaque site Web où se problème se pose.

Remarque Lorsque vous employez cette méthode pour corriger un problème sur un site Web, Internet Explorer enregistre vos paramètres d'affichage de compatibilité pour ce site. À chaque fois que vous y accéderez, l'affichage de compatibilité sera utilisé. Pour cesser d'utiliser un site Web en mode d'affichage de compatibilité, répétez l'opération en cliquant à nouveau sur le bouton Affichage de compatibilité lorsque vous y accédez. Vous pouvez également ajouter ou supprimer des sites Web précis de la fonctionnalité Affichage de compatibilité sans visiter chacun d'eux. Pour ce faire, cliquez sur Outils, puis sur Paramètres d'affichage de compatibilité.

Si cette méthode n'a pas fonctionné, et si le site Web n'est toujours pas affiché correctement ou ne fonctionne pas, c'est que vous avez rencontré un problème différent. Reportez-vous à la section « Problèmes similaires et solutions et informations du support technique », où vous trouverez des étapes alternatives.

Méthode 2 : Activation de l'affichage de compatibilité pour tous les sites Web à l'aide d'Internet Explorer

La plupart des sites Web que vous visitez régulièrement ne s'affichent pas correctement ou ne fonctionnent pas. Vous avez essayé la méthode 1 avec certains sites Web, et elle a fonctionné. Toutefois, il peut être utile d'activer l'affichage de compatibilité pour tous les sites Web. Pour cela, procédez comme suit :
  1. Démarrez Internet Explorer 8.
  2. Dans le menu Outils, cliquez sur Paramètres d'affichage de compatibilité.

    Si la commande Paramètres d'affichage de compatibilité n'est pas disponible, il se peut que l'administrateur réseau ait employé une stratégie de groupe pour configurer les options pour vous. Contactez votre administrateur ou le service d'assistance.
  3. Activez la case à cocher Afficher tous les sites Web dans Affichage de compatibilité, puis cliquez sur Fermer.

    Réduire cette imageAgrandir cette image
    Paramètres d'affichage de compatibilité
Visitez plusieurs sites Web qui ne s'affichaient pas correctement ou qui ne fonctionnaient pas, de façon à vous assurer que le problème a été résolu.

Si cette méthode a fonctionné et que tous les sites Web s'affichent correctement et fonctionnent, vous avez terminé.

Si cette méthode n'a pas fonctionné, et si certains sites Web (ou tous) ne sont toujours pas affichés correctement ou ne fonctionnent pas, c'est que vous avez rencontré un problème différent. Reportez-vous à la section « Problèmes similaires et solutions et informations du support technique », où vous trouverez des étapes alternatives.

Activation de l'affichage de compatibilité dans Internet Explorer pour plusieurs ordinateurs

Méthode 3 : définition des options d'affichage de compatibilité pour plusieurs ordinateurs dans un environnement d'entreprise à l'aide de paramètres de stratégie de groupe

Pour activer l'affichage de compatibilité pour plusieurs ordinateurs dans un environnement d'entreprise, les administrateurs peuvent utiliser les nouveaux paramètres de stratégie de groupe d'affichage de compatibilité disponibles pour Internet Explorer 8 :
  • Activer le mode standard d'Internet Explorer 7 : Ce paramètre active l'affichage de compatibilité pour tous les sites Web et interdit aux utilisateurs d'activer ou de désactiver l'affichage de compatibilité pour le moindre site Web.
  • Désactiver l'affichage de compatibilité : Ce paramètre désactive l'affichage de compatibilité pour tous les sites Web et interdit aux utilisateurs d'activer ou de désactiver l'affichage de compatibilité pour le moindre site Web.
  • Activer le mode standard d'Internet Explorer pour l'intranet local : Ce paramètre désactive l'affichage de compatibilité (et active le mode standard) pour tous les sites Web de l'intranet.
  • Utiliser la liste des sites d'Internet Explorer 7 : Ce paramètre permet aux administrateurs d'ajouter des sites précis qui doivent être affichés en mode Affichage de compatibilité. Les utilisateurs peuvent ajouter des sites à la liste ou en supprimer. Il leur est toutefois impossible de supprimer les sites spécifiés par l'administrateur.
  • Bouton Désactiver l'affichage de compatibilité : ce paramètre interdit aux utilisateurs d'employer le bouton Affichage de compatibilité pour tenter de corriger des sites Web. Ce paramètre ne fonctionne pas dans Windows Internet Explorer 8.
Ces paramètres sont disponibles pour les Utilisateurs et les Ordinateurs à l'endroit suivant pour chaque site, domaine et unité d'organisation :
Modèles d'administration/Composants Windows/Internet Explorer/Affichage de compatibilité
Pour plus d'informations sur ces paramètres de stratégie de groupe, consultez ces explications dans l'interface utilisateur de la stratégie de groupe.

Problèmes similaires et solutions et informations du support technique

Si vous êtes un utilisateur débutant ou de niveau intermédiaire, employez notre Aide interactive pour résoudre des problèmes similaires. Pour plus d'informations sur les solutions avancées, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
968499  (http://support.microsoft.com/kb/968499/ ) Solutions avancées : il se peut que certains sites Web ne s'affichent pas correctement ou ne fonctionnent pas dans Windows Internet Explorer 8
Pour contacter le service d'assistance relatif à Internet Explorer 8, reportez-vous au site Web Microsoft suivant :
http://support.microsoft.com/oas/default.aspx?prid=12357 (http://support.microsoft.com/oas/default.aspx?prid=12357)
Pour afficher les notes de publication d'Internet Explorer 8, visitez le site Web Microsoft suivant :
http://msdn.microsoft.com/fr-fr/ie/dd441788.aspx (http://msdn.microsoft.com/fr-fr/ie/dd441788.aspx)

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows Internet Explorer 8
Mots-clés : 
kbexpertisebeginner kbgraphxlink kbtshoot KB956197
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
 

Traductions disponibles