Help and Support

文書番号: 956197 - 最終更新日: 2009年6月30日 - リビジョン: 6.1

Windows Internet Explorer 8 で一部の Web サイトが正しく表示されない、または正常に動作しないことがある

正しく表示されない、または正しく機能しない Web サイトのトラブルシューティングを行うためのガイド付きヘルプ
このサポート技術情報の資料は、上級レベルのユーザー、サポート担当者、ネットワーク管理者、Web コンテンツ開発者、および Web サイト管理者を対象としています。

元に戻す画像を拡大する
初級レベルから中級レベルのコンピューター ユーザーを対象としたセルフ ヘルプの手順については、次のマイクロソフト Web サイトを参照してください。
: このガイド付きヘルプの内容は、すべての言語で提供されているわけではありません。

目次

すべて展開する | すべて折りたたむ

現象

Windows Internet Explorer 8 で一部の Web サイトが正しく表示されない、または正常に動作しないことがあります。この問題は、以前のバージョンの Internet Explorer では発生しません。また、Windows Internet Explorer 7 では、問題の対象となる Web サイトは引き続き正しく表示され、正常に動作します。

たとえば、Internet Explorer 8 で次のいずれかの現象が発生することがあります。
  • 一部の Web サイトで、メニュー、画像、またはテキストが誤った位置に表示される。
  • 一部の Web サイトの機能が動作しない。
  • 一部の Web サイトでスクリプト エラー メッセージが表示される。
  • 一部の Web サイトで Internet Explorer が応答を停止する、または動作を停止する。

原因

一部の Web サイトは古いブラウザー用に設計されています。これらのサイトでは、サイトが Internet Explorer 8 用に更新されるまで、互換性の問題が発生することがあります。

回避策

Internet Explorer 8 には、古いブラウザー用に作成された Web サイトを設計されたとおりに表示する、互換表示機能が含まれています。Internet Explorer または Web サーバーで互換表示を有効にすることができます。
  • 1 台のコンピューターの互換表示を有効にするには、正しく表示されない、または正常に動作しない Web サイトのそれぞれに対して、方法 1 を試します。頻繁にアクセスする多数の Web サイトでこの問題が発生する場合は、方法 2 を使用してすべての Web サイトの互換表示を有効にできます。これらの方法は Internet Explorer を実行しているユーザーを対象にしています。
  • 企業環境で複数のコンピューターに対して互換表示を有効にするには、方法 3 を使用します。この方法は企業のネットワーク管理者を対象としています。

Internet Explorer で互換表示を有効にする

方法 1: Internet Explorer を使用して、特定の Web サイトの互換表示を有効にする

正しく表示されない、または正常に動作しない特定の Web サイトの互換表示を有効にするには、以下の手順を実行します。
  1. Internet Explorer 8 で正しく表示されない、または正しく機能しない Web サイトを開きます。
  2. アドレス バーのすぐ右 ([更新] ボタンの隣) にある [互換表示] ボタンをクリックします。

    元に戻す画像を拡大する
    互換表示ボタン


    または、[ツール] メニューの [互換表示] をクリックします。

    : [互換表示] ボタンがアドレス バーの右に表示されない場合、または [ツール] メニューでコマンドが選択できない場合は、この方法を使用できません。別の問題が発生している、またはネットワーク管理者がグループ ポリシー設定を使用して、コンピューターの互換表示の設定を構成している可能性があります。
    • ご自宅のコンピューターを使用している場合は、「類似した問題と解決方法およびサポート情報」を参照して、別の手順を確認してください。
    • 企業環境でコンピューターを使用している場合は、管理者またはヘルプ デスクに問い合わせてください。
    以前のバージョンの Internet Explorer 用に Web サイトが設計されている場合は、互換表示は必要ありません。また、互換表示コマンドは利用できません。
この方法で問題が解決して、Web サイトが正しく表示され、正常に動作するようになった場合、作業は完了です。ただし、この問題が発生する各 Web サイトに対して、この方法を繰り返すことが必要な場合があります。

: この方法を使用して Web サイトを修正すると、Internet Explorer ではその Web サイトに対する互換表示設定が保存されます。そのサイトにアクセスするたびに、互換表示が使用されます。Web サイトでの互換表示の実行を停止するには、その Web サイトで [互換表示] アイコンを再度クリックして、この方法を繰り返します。実際に各 Web サイトにアクセスせずに、特定の Web サイトに互換表示を追加したり、削除したりすることもできます。これを行うには、[ツール] をクリックし、[互換表示設定] をクリックします。

この方法で問題が解決されず、Web サイトが依然として正しく表示されない、または正常に動作しない場合は、別の問題が発生しています。「類似した問題と解決方法およびサポート情報」を参照して、別の手順を確認してください。

方法 2: Internet Explorer を使用して、すべての Web サイトの互換表示を有効にする

頻繁にアクセスするほとんどの Web サイトが正しく表示されない、または正常に動作しないとします。これらの Web サイトのいくつかに対して、方法 1 を試し、この方法で問題が解決しました。この場合、すべての Web サイトに対して、互換表示を有効にすることが必要な場合があります。この作業は、以下の手順で実行します。
  1. Internet Explorer 8 を起動します。
  2. [ツール] メニューの [互換表示設定] をクリックします。

    [互換表示設定] が選択できない場合は、ネットワーク管理者がグループ ポリシー設定を使用して、ユーザーのオプションを構成している可能性があります。管理者またはヘルプ デスクに問い合わせてください。
  3. [互換表示ですべての Web サイトを表示する] チェック ボックスをオンにし、[閉じる] をクリックします。

    元に戻す画像を拡大する
    互換表示設定
正しく表示されない、または正常に動作しないいくつかの Web サイトにアクセスして、問題が解決されたかどうかを確認します。

この方法で問題が解決して、すべての Web サイトが正しく表示され、正常に動作するようになった場合、作業は完了です。

一部またはすべての Web サイトが依然として正しく表示されない、または正常に動作しない場合は、別の問題が発生しています。「類似した問題と解決方法およびサポート情報」を参照して、別の手順を確認してください。

複数のコンピューターの Internet Explorer で互換表示を有効にする

方法 3: 企業環境でグループ ポリシー設定を使用して、複数のコンピューターに対して互換表示オプションを設定する

企業環境で複数のコンピューターに対して互換表示を有効にするために、管理者は Internet Explorer 8 で利用できる、次の新しい互換表示グループ ポリシー設定を使用できます。
  • Internet Explorer 7 標準モードを有効にする: すべての Web サイトの互換表示を有効にし、ユーザーがどの Web サイトの互換表示も有効または無効にできないようにします。
  • 互換表示を無効にする: すべての Web サイトの互換表示を無効にし、ユーザーがどの Web サイトの互換表示も有効または無効にできないようにします。
  • ローカル イントラネットで Internet Explorer 標準モードを有効にする: すべてのイントラネット Web サイトの互換表示を無効にします (標準モードを有効にします)。
  • Internet Explorer 7 サイトのポリシー一覧を使用: 管理者が、互換表示で表示する必要のある特定のサイトを追加できるようにします。ユーザーは一覧へのサイトの追加または削除はできますが、管理者によって指定されたサイトは削除できません。
  • [互換表示] ボタンを無効にする: ユーザーが [互換表示] ボタンを使用して Web サイトを修正できないようにします。この設定は、Windows Internet Explorer 8 では機能しません。
これらの設定は、各サイト、ドメイン、および組織単位の以下の場所で、[ユーザー] と [コンピューター] の両方で使用できます。
管領用テンプレート/Windows コンポーネント/Internet Explorer/互換表示
これらのグループ ポリシー設定の詳細については、グループ ポリシーのユーザー インターフェイスの説明を参照してください。

類似した問題と解決方法およびサポート情報

初級から中級のコンピューター ユーザーの場合、類似した問題と解決方法のトラブルシューティングを行うには、ガイド付きヘルプを試してください。 高度な解決方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
968499? (http://support.microsoft.com/kb/968499/ ) 高度な解決方法: Windows Internet Explorer 8 で一部の Web サイトが正しく表示されない、または正常に動作しないことがある
Internet Explorer 8 のサポートに問い合わせるには、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/oas/default.aspx?prid=12357 (http://support.microsoft.com/oas/default.aspx?prid=12357)
Internet Explorer 8 のリリース ノートを参照する場合は、次のマイクロソフト Web サイトにアクセスしてください。
http://msdn.microsoft.com/ja-jp/ie/dd441788.aspx (http://msdn.microsoft.com/ja-jp/ie/dd441788.aspx)

この資料は以下の製品について記述したものです。
  • Windows Internet Explorer 8
キーワード:?
kbexpertisebeginner kbgraphxlink kbtshoot KB956197
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers