Article ID: 956702 - Last Review: September 13, 2011 - Revision: 4.0

Error code 0x800B0100 when using Windows Update or Microsoft Update to install updates

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SYMPTOMS

When you try to install updates from the Windows Update Web site or from the Microsoft Update Web site, you may receive the following error message:
0x800B0100

CAUSE

This issue occurs if Windows security .dll files are registered incorrectly.

RESOLUTION

To resolve this issue, use the following methods according to the specific Microsoft Windows operating system that
you use.

Method for Windows 7, Windows Vista or Windows Server 2008

To resolve this issue, run the System Update Readiness Tool (Checksur.exe). To do this, follow these steps:
  1. Download and run the System Update Readiness Tool. This tool runs a one-time scan for inconsistencies that may prevent future servicing operations.
    For more information about how to download and run the Checksur.exe tool, click the following article number to view the article in the Microsoft Knowledge Base:
    947821 (http://support.microsoft.com/kb/947821) Description of the System Update Readiness Tool for Windows Vista
  2. Try to install updates again.
Note After you run the tool, the Checksur.log file is located in the following location: %systemroot%\Logs\CBS\

In a default installation of Windows 7 and Windows Vista, this file is in the following folder:

C:\Windows\Logs\CBS

Method for Windows 2000, Windows XP, or Windows Server 2003

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. In the File Download dialog box, click Run and then follow the steps in the Fix it Wizard.


Fix this problem
Microsoft Fix it 50652


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To resolve this issue, register the Softpub.dll, Wintrust.dll, Initpki.dll, and Mssip32.dll files. To register these files, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type regsvr32 Softpub.dll /s, and then press ENTER.
  3. At the command prompt, type regsvr32 Wintrust.dll /s, and then press ENTER.
  4. At the command prompt, type regsvr32 Initpki.dll /s, and then press ENTER.
  5. At the command prompt, type regsvr32 Mssip32.dll /s, and then press ENTER.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) message.

APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
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