Article ID: 957310 - Last Review: October 11, 2011 - Revision: 2.0

Error Code 0x80073712 when using Windows Update or Microsoft Update to install updates

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SYMPTOMS

When you try to install updates or components in Windows 7 or in Windows Vista, you may experience the following symptoms:

  • When you try to install an update by using the Windows Update Web site, you receive an error message that includes the error code: 0x80073712. The update does not install.
  • When you click Turn Windows features on or off in the Programs and Features Control Panel item, the Windows Features dialog box is empty. No features are shown.



CAUSE

This issue may occur if the Component-Based Servicing (CBS) manifest is corrupted.

RESOLUTION

To resolve this problem, use one of the following methods. For these methods to work, you must be logged on to your computer by using a computer administrator user account. Or, you must be able to supply a user account name and password for an account that has administrative credentials. If you are using your home computer, chances are that you are already logged on by using a computer administrator user account. For more information about how to log in as an administrator, visit the following Windows Help & How To article:

How do I log on as an administrator? (http://windows.microsoft.com/en-US/windows7/How-do-I-log-on-as-an-administrator)

Method 1: Run the System Update Readiness tool (Checksur.exe)

  1. Download and run the System Update Readiness tool. This tool runs a one-time scan for inconsistencies that may prevent future servicing operations.
    1. To download and run the System Update Readiness tool (Checksur.exe), visit: What is the System Update Readiness Tool? (http://windows.microsoft.com/en-US/windows7/What-is-the-System-Update-Readiness-Tool)
  2. Install the updates again.
If you still cannot install the updates or turn on Windows features, proceed to Method 2.

Method 2: Install the latest Service Pack for your version of Windows.

If you have not yet installed the latest Service Pack for your version of Windows, visit the Service Pack Center to download and install it.
  1. Click the following link:http://windows.microsoft.com/en-US/windows/downloads/service-packs (http://windows.microsoft.com/en-US/windows/downloads/service-packs)
  2. Click the Service Pack download link for your version of Windows.
  3. Follow the on screen instructions to download and install the latest Service Pack.
  4. Restart your computer.
  5. Try to install the updates again.

If you still cannot install updates or turn on Windows features, go to Method 3.

Method 3: Run the System File Checker (SFC.exe) tool with the sfc /scannow command

To run the System File Checker, follow these steps:
  1. Click the Start button, then type cmd in the Start Search box (Windows Vista) or the Search programs and files box (Windows 7), then press Enter.
  2. Right click cmd.exe, and then click Run as administrator. Click Continue if you are the administrator or type the administrator password. Then, click Continue.
  3. In the command box window, type Sfc /scannow, and then press Enter.
The scan may take some time, so be patient. Windows will repair any corrupted or missing files that it finds. If information from the installation CD is needed to repair the problem, you may be prompted to insert your Windows Vista or Windows 7 CD.

After the scan is complete, try to install the updates again. If you still cannot install the updates or turn on Windows features, proceed to Method 4.

Method 4: Perform an in-place upgrade.

An in-place upgrade is the final alternative and should only be attempted if the previous methods don't seem to resolve your issue. 
Note that it takes the same amount of time to do the upgrade as to reinstall the operating system. Also, some of your customized Windows settings may be lost through this process.

To perform an in-place upgrade, follow the steps below:

Note Performing a repair installation will not damage files and applications that are currently installed on your computer.

  1. Close all the running applications.
  2. Insert the Windows Vista, Windows Server 2008, Windows 7 or Windows Server 2008 R2 DVD in the computer's DVD drive.
  3. In the Setup window, click Install Now. Note If Windows does not automatically detect the DVD, follow these steps:
    1. Click the Start button, and then type Drive:\setup.exe in the Start Search box. Note: The Drive placeholder is the drive letter of the computer's DVD drive.
    2. In the Programs list, click Setup.exe.
    3. In the Setup window, click Install Now.
  4. Click Go online to obtain the latest updates for installation (recommended).
  5. Type the CD key if you are prompted to do this.
  6. Select the operating system in Install Windows page you want to Upgrade or Inplace.
  7. Click Yes to accept the Microsoft Software License Terms.
  8. On the Which type of installation do you want? screen, click Upgrade.
  9. When the installation is complete, restart your computer.

After your in-place upgrade is complete, try to run Windows Update. Or, try to turn Windows features off and on to see whether the problem is resolved. If you still cannot install Windows Updates or turn on Windows features, visit the following Microsoft web site to contact support:

http://support.microsoft.com/contactus (http://support.microsoft.com/contactus)


APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
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