Vous recevez le code d'erreur 0x8007F0DA lorsque utilisez le site Windows Update Web ou le site Microsoft Update Web pour installer les mises à jour :

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Sommaire

Symptômes

Lorsque vous essayez d'installer les mises à jour à partir du site Windows Update Web ou à partir du site Microsoft Update Web, vous recevez le code d'erreur suivant :
0x8007F0DA

Cause

Ce problème se produit si Windows Update ou Microsoft Update ne peut pas vérifier le fichier update.inf.

Résolution

Pour résoudre ce problème, procédez comme suit :

Étape 1: Configurer le service services de cryptographie sur automatique

Pour définir les services de cryptographie sur automatique, procédez comme suit :
  1. Cliquez sur Démarrer, sur exécuter, tapez services.msc et cliquez sur OK.
  2. Dans la liste des services disponibles, cliquez avec le bouton droit sur Services de chiffrement, puis cliquez sur Propriétés.
  3. Dans la liste déroulante type de démarrage, sélectionnez l'option automatique, puis cliquez sur Appliquer.
  4. Dans la section état des services, cliquez sur Démarrer.
  5. Essayez à nouveau d'installer les mises à jour.
Remarque Windows 2000 ne répertorie pas les services de cryptographie dans l'utilitaire Services d'administration.

Si vous ne pouvez toujours pas installer les mises à jour, passez à étape 2.

Étape 2: Réenregistrement de fichiers DLL associés aux services de cryptographie

Important Cette section, la méthode ou la tâche contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, assurez-vous que vous procédez comme suit avec soin. Pour plus de protection, sauvegardez le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre en cas de problème. Pour plus d'informations sur la façon de sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
322756Comment faire pour sauvegarder et restaurer le Registre dans Windows
Pour enregistrer les fichiers .dll qui sont associés avec les services de cryptographie, procédez comme suit :
  1. Démarrez le bloc-notes. Pour ce faire, cliquez sur Démarrer, sur exécuter, tapez notepad et cliquez sur OK.
  2. Copiez et collez ensuite les commandes suivantes dans le bloc-notes :
    regsvr32 /u softpub.dll /s
    regsvr32 /u wintrust.dll /s
    regsvr32 /u initpki.dll /s
    regsvr32 /u dssenh.dll /s
    regsvr32 /u rsaenh.dll /s
    regsvr32 /u gpkcsp.dll /s
    regsvr32 /u sccbase.dll
    regsvr32 /u slbcsp.dll /s
    regsvr32 /u mssip32.dll /s
    regsvr32 /u cryptdlg.dll /s
  3. Enregistrez le fichier de bloc-notes sur le bureau sous register.bat. Pour ce faire, procédez comme suit :
    1. Dans le bloc-notes, cliquez sur fichier, cliquez sur Enregistrer sous et tapez register.bat.
    2. Dans la liste Enregistrer dans, cliquez sur le bureau.
    3. Dans la liste type de fichier, cliquez sur tous les fichiers, puis cliquez sur Enregistrer.
  4. Sur le bureau, double-cliquez sur le fichier register.bat.

    Remarque Lorsque vous effectuez cette opération, les clés de Registre seront ajoutés au Registre Windows.
  5. Cliquez sur OK, puis essayez à nouveau d'installer les mises à jour.
  6. Si le problème est résolu, supprimez le fichier register.bat que vous avez enregistré dans le cadre de ces étapes.
Si le problème n'est pas résolu, passez à étape 3.

Étape 3: Renommer le dossier Catroot2

Important Ces étapes s'appliquent uniquement à Windows XP et Windows Server 2003. Ignorez cette méthode si votre ordinateur exécute Windows Vista, Windows 2000 ou Windows Server 2008.

Pour renommer le dossier Catroot2, procédez comme suit :
  1. Démarrez le bloc-notes. Pour ce faire, cliquez sur Démarrer, sur exécuter, tapez notepad et cliquez sur OK.
  2. Copiez et collez ensuite les commandes suivantes dans le bloc-notes.
    net stop cryptsvc
    CD %systemroot%\system32
    ren catroot2 catroot2old
    Net start cryptsvc
  3. Enregistrez le fichier sous rename.bat. Pour ce faire, procédez comme suit :
    1. Dans le bloc-notes, cliquez sur fichier, cliquez sur Enregistrer sous et tapez rename.bat.
    2. Dans la liste Enregistrer dans, cliquez sur le bureau.
    3. Dans la liste type de fichier, cliquez sur Tous les fichiers, puis cliquez sur Enregistrer.
  4. Sur le bureau, double-cliquez sur le fichier rename.bat pour enregistrer les fichiers de Windows Update.
  5. Essayez à nouveau d'installer les mises à jour.
  6. Si le problème est résolu, vous pouvez supprimer en toute sécurité le fichier rename.bat que vous avez créé dans le cadre de ces étapes.
Remarque Si vous rencontrez toujours des problèmes, contactez le support. Pour plus d'informations sur la façon de contacter le support technique, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/select/?target=hub

Plus d'informations

Dépannage avancé

Si les étapes de dépannage générales dans cet article n'ont pas résolu le problème, suivez les étapes de dépannage avancées dans l'article 822798.

Pour plus d'informations sur les étapes de dépannage avancés pour installer les mises à jour, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
822798Vous ne pouvez pas installer certains programmes ou mises à jour

Propriétés

Numéro d'article: 958050 - Dernière mise à jour: mardi 30 septembre 2008 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Update
  • Microsoft Windows Update
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Server
Mots-clés : 
kbmt kbwindowsupdate kbpubtypekc kbtshoot kbprb KB958050 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 958050
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