Puede recibir un código de error "0x8007F0F4" cuando intenta instalar actualizaciones desde el sitio Web de Windows Update o desde el sitio Web de Microsoft Update

Seleccione idioma Seleccione idioma
Id. de artículo: 958051 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta instalar actualizaciones desde el sitio Web de Windows Update o desde el sitio Web de Microsoft Update, puede recibir el código de error siguiente:
0x8007F0F4

Causa

Este problema puede producirse si alguno de los siguientes escenarios existe en el equipo:
  • Está intentando actualizar su equipo portátil cuando está funcionando con batería.
  • El programa de instalación de actualización detecta que la actualización es incorrecta para el equipo.
  • No se instalaron actualizaciones necesarias en el equipo.

Solución

Para resolver este problema, utilice los métodos siguientes que se aplican a su situación.

NotaPuede recibir el mensaje de error de 0x8007F0F4 al intentar instalar la actualización de seguridad 2686509. Para obtener más información acerca de cómo solucionar este problema, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2686509 MS12-034: Descripción de la actualización de seguridad para CVE-2012-0181 en Windows XP y Windows Server 2003: 8 de mayo de 2012

Método 1: Conectar el portátil a una fuente de alimentación de CA

Si ya está intentando actualizar un equipo portátil mientras se está ejecutando con batería, conectan temporalmente el equipo portátil a una fuente de alimentación de CA y, a continuación, intente volver a instalar las actualizaciones.

Método 2: Ocultar la actualización incorrecta

Si la aplicación de instalación de la actualización detecta que la actualización es correcta para el equipo, puede cumplirse una de las siguientes condiciones:
  • Es posible que la actualización halla sido instalada anteriormente.
  • La actualización es mas antigua que la actualización actualmente instalada.
  • La actualización no es compatible con el equipo.
Esta actualización debe pasa por alto o se oculta en la interfaz de Windows Update o Microsoft Update.

Para ocultar la actualización de forma que no se volverá a ofrecer, siga estos pasos:
  1. Visite el siguiente sitio Web de Microsoft Update:
    http://update.microsoft.com
  2. Tan pronto como haya terminado la búsqueda de actualizaciones, haga clic en Personalizar en la página de bienvenida a Microsoft Update .
  3. En el panel de exploración, haga clic en Hardware, opcional. Las actualizaciones disponibles se enumeran en la seleccionar actualizaciones de Hardware opcionales página.
  4. Busque el controlador de hardware que está asociado con el error, haga clic en el nombre de la actualización para ampliar los detalles de la actualización y, a continuación, haga clic para activar la casilla de verificación no mostrar de nuevo esta actualización .
  5. Haga clic en Revisar e instalar actualizaciones.
  6. Compruebe que las actualizaciones ocultas para el hardware no está presente y, a continuación, haga clic en Instalar actualizaciones.

Método 3: Descargar e instalar la actualización manualmente

Para descargar e instalar la actualización manualmente, siga estos pasos:
  1. Visite el siguiente sitio Web de Microsoft Update:
    http://update.microsoft.com
  2. Haga clic en Revisar el historial actualizado para ver el historial de actualización o examine el mensaje de error para determinar la actualización que desea instalar de forma manual.
  3. Visite el siguiente sitio Web de descargas de Windows:
    http://www.Microsoft.com/Windows/downloads/default.aspx
  4. Escriba el número de artículo de Microsoft Knowledge Base en la ventana de búsqueda en la página de descargas y, a continuación, haga clic en Ir.

    Por ejemplo, si el número de artículo que se muestra para la actualización es a KB123456, escriba 123456 en la búsqueda y a continuación, haga clic en Ir.
  5. Desplácese por la lista de contenido devuelto y, a continuación, busque el artículo de Knowledge Base que tiene un vínculo a la descarga.
  6. En el artículo de Knowledge Base, busque y, a continuación, haga clic en el vínculo que se parece al siguiente:
    Descargue ahora el paquete
    Nota Si se le pide a validar Windows, siga las instrucciones para validar Windows y, a continuación, continuar descargar la actualización.
  7. Haga clic en Descargary, a continuación, haga clic en Guardar en el cuadro de diálogo Descarga de archivos .
  8. En la lista Guardar en , seleccione la opción de escritorio y, a continuación, haga clic en Guardar.
  9. Busque el archivo que ha descargado en el escritorio y, a continuación, haga doble clic en el archivo para instalar la actualización.
Nota La instalación de la actualización todavía puede fallar si la actualización es correcta para el equipo.

Método 4: Buscar un archivo de registro existente para el error de actualización

Si los métodos 1, 2 o 3 no resuelven este problema, un archivo de registro debe utilizarse para recopilar más información. Microsoft Installer crea un archivo de registro para algunas actualizaciones y, a continuación, pone ese archivo de registro en el directorio de Windows. Si el archivo existe, un agente de soporte técnico de Microsoft puede ver ese archivo para determinar la causa del problema. Si el archivo no existe, el método 5 enumera los pasos que debe seguir para crear el archivo .log para el agente de asistencia.

Para comprobar si un archivo .log que se creó durante la actualización de error, siga estos pasos:
  1. Haga clic en Inicio, Todos los programasy, a continuación, haga clic en Windows Update o Microsoft Update.
  2. En el sitio Web de Microsoft Update o de Windows Update, haga clic en Revisar el historial de actualización.
  3. En la columna estado , busque la actualización que no se pudieron y tenga en cuenta el número de artículo de Knowledge Base asociado a dicha actualización.

    Nota Si no hay ningún artículo de Knowledge Base que está asociado el error al actualizar, pruebe el método 5.
  4. Cierre la ventana de Windows Update o Microsoft Update.
  5. Haga clic en Inicio, haga clic en Ejecutar, tipo % systemroot %y, a continuación, haga clic en Aceptar.
  6. Busque el archivo .log que se denomina con el artículo de Knowledge Base para la actualización fallida que anotó en el paso 3. Por ejemplo, para una actualización fallida asociado a KB123456, busque el archivo .log que se denomina 123456.log.
  7. Si existe este archivo .log, póngase en contacto con Microsoft Support y, a continuación, el número de artículo de la Knowledge Base de referencia cuando hable con un representante de soporte.Para obtener más información acerca de cómo ponerse en contacto con Microsoft Support, visite el siguiente sitio Web de Microsoft:
    http://support.Microsoft.com/contactus/?ws=support
  8. Si no existe el archivo .log, pruebe el método 5.

Método 5: Habilitar el registro de Microsoft Installer y, a continuación, póngase en contacto con soporte técnico

Importante: Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, copia de seguridad del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows
Si el método anterior no resuelve el problema, póngase en contacto con Microsoft Support para obtener ayuda. Para ahorrar tiempo, puede habilitar y generar un registro de instalador de Microsoft antes de ponerse en contacto con Microsoft Support. Para habilitar el registro de Microsoft Installer y generar el archivo de registro, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Bloc de notasy, a continuación, haga clic en Aceptar.
  2. Escriba los siguientes comandos en el Bloc de notas.
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
    
  3. En el menú archivo en el Bloc de notas, haga clic en Guardar como.
  4. En la lista Guardar en , seleccione la opción de escritorio .
  5. En el cuadro nombre de archivo , escriba LoggingOn.reg, seleccione la opción Todos los archivos en la lista Guardar como tipo y, a continuación, haga clic en Guardar.
  6. En el escritorio, haga doble clic en el archivo LoggingOn.reg para agregar las claves del registro para el registro de Windows.
  7. Cuando vea un cuadro de diálogo que indica que la instalación se realizó correctamente, haga clic en Aceptar.
  8. Intente volver a instalar la actualización para capturar la información de error en el archivo de log de Microsoft Installer.
Nota Puede tardar varios minutos en recopilar la información de registro y el proceso de actualización puede parecer estar funcionando incorrectamente. Asegúrese de que espere a que finalice el proceso.

Importante: Tan pronto como termine de Windows Update o Microsoft Update, deshabilitar el registro de Microsoft Installer. Si el registro permanece habilitado, instalación de actualizaciones puede tardar mucho tiempo, puede ralentizar el equipo y que requieren grandes cantidades de espacio en disco se pueden crear los archivos de registro.

Para deshabilitar el registro de Microsoft Installer, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Bloc de notasy, a continuación, haga clic en Aceptar.
  2. Escriba los siguientes comandos en el Bloc de notas.
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    
  3. En el menú archivo en el Bloc de notas, haga clic en Guardar como.
  4. En la lista Guardar en , seleccione la opción de escritorio .
  5. Tipo LoggingOff.reg en el cuadro nombre de archivo , seleccione la opción Todos los archivos en la lista Guardar como tipo y, a continuación, haga clic en Guardar.
  6. En el escritorio, haga doble clic en el archivo LoggingOff.reg para quitar los valores del registro en el registro de Windows.
  7. Cuando vea un cuadro de diálogo que indica que la instalación se realizó correctamente, haga clic en Aceptar.
  8. Elimine los archivos LoggingOn.reg y LoggingOff.reg desde el escritorio.
Póngase en contacto con Microsoft Support para obtener ayuda y, a continuación, hacer referencia a este artículo de Knowledge Base cuando hable con el agente de asistencia.

Más información

El registro de Microsoft Installer normalmente comienza con "msi" y termina con la extensión ". log". Por ejemplo, el archivo de registro de Microsoft Installer tiene un nombre similar al siguiente:
msib3a6g.log
Este archivo se encuentra en el directorio siguiente:
C:\Documents and Settings\Nombre de usuario\Local Settings\Temp\
Para abrir este directorio, haga clic en Inicio, haga clic en Ejecutar, tipo % temp %y, a continuación, haga clic en Aceptar.

Nota Esta información se supone que Windows está instalado en la unidad C. Si Windows no está instalado en la unidad C, ajustar la letra de unidad de la ruta de la carpeta para que coincida con la unidad de instalación.

Referencias

Para obtener más información acerca de cómo habilitar el registro de Microsoft Installer, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
314852 Cómo habilitar el registro en Windows XP

Propiedades

Id. de artículo: 958051 - Última revisión: sábado, 23 de noviembre de 2013 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Update
  • Microsoft Windows Update
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
Palabras clave: 
kbtshoot kbPubTypeKC kberrmsg kbprb kbmt KB958051 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 958051

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com