Applies ToMicrosoft Windows XP Home Edition Microsoft Windows XP Professional

Symptoms

On a Windows XP-based computer, you run the Dfrgntfs.exe tool to defragment a hard disk. However, the defragmentation process does not finish successfully. Additionally, the Defrag.exe tool stops responding. In Task Manager, you notice that the CPU usage for the Dfrgntfs.exe tool process increases to 100 percent and stays at that level.

Cause

This problem may occur if the Defrag.exe tool encounters a 0-byte attribute entry in the attribute list.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP with Service Pack 2, x86-based versions

File name

File version

File size

Date

Time

Platform

Dfrgntfs.exe

5.1.2600.3453

105,472

29-Sep-2008

09:54

x86

Windows XP with Service Pack 3, x86-based versions

File name

File version

File size

Date

Time

Platform

Dfrgntfs.exe

5.1.2600.5686

105,472

29-Sep-2008

10:52

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

930118 The Defrag.exe tool may stop responding when you run the Dfrgntfs.exe tool to defragment a hard disk on a Windows Server 2003 with Service Pack 1-based computerFor more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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