You receive a "0x0000007E" Stop error on Windows Server 2008-based computers that host Hyper-V virtual machines when you use the Hyper-V writer to back up virtual machines

Article translations Article translations
Article ID: 960038 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you use the Hyper-V writer to back up Hyper-V virtual machines on Windows Server 2008-based computers, you may receive the following Stop error message:
0x0000007e (0xffffffffc0000047, parameter2, parameter3, parameter4)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Notes
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "0x0000007E" Stop error messages are caused by this problem.
For example, you may experience this issue when you use System Center Data Protection Manager 2007 or the Windows Backup program to back up Hyper-V virtual machines.

CAUSE

This problem occurs because the Volsnap.sys driver may incorrectly release a semaphore two times because of a timing issue.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, you must have Windows Server 2008 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.0.6001.22321269,57603-Dec-200806:39x64
Volume.infNot Applicable2,08203-Dec-200801:09Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_volume.inf_31bf3856ad364e35_6.0.6001.22321_none_724a540dcd9f5754.manifestNot Applicable1,67303-Dec-200820:57Not Applicable
Package_for_kb960038_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37503-Dec-200820:48Not Applicable
Package_for_kb960038_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43903-Dec-200820:48Not Applicable
Package_for_kb960038_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,42903-Dec-200820:48Not Applicable
Package_for_kb960038_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43103-Dec-200820:48Not Applicable
Package_for_kb960038_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43303-Dec-200820:48Not Applicable
Package_for_kb960038_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43903-Dec-200820:48Not Applicable
Package_for_kb960038_winpesrv_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43003-Dec-200820:48Not Applicable
Package_for_kb960038_winpesrv~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43703-Dec-200820:48Not Applicable

Properties

Article ID: 960038 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Keywords: 
kbsurveynew kbautohotfix kbexpertiseadvanced kbfix kbqfe KB960038

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com