Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Quando reiniciar ou encerrar um computador baseado no Windows Server 2003, recebe uma das seguintes mensagens de erro de Stop durante o processo de encerramento:

Parar 0x000000CE (parâmetro1, 0x00000000, Parâmetro3, 0x00000000)
DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS

Parar 0x00000050 (parâmetro1, 0x00000000, Parâmetro3, 0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA

Notas

  • Os parâmetros destas mensagens de erro Stop podem variar, dependendo da configuração do computador.

  • Este problema ocorre aleatoriamente.

Causa

Quando o sistema é encerrado, um item de trabalho que está relacionado com o controlador MRxSmb. sys é inserido uma fila pela função ExQueueWorkItem . No entanto, a função ExQueueWorkItem não fornece um mecanismo para verificar se o objecto de dispositivo que está associado ao item de trabalho especificado está disponível antes do item de trabalho é processado. Por conseguinte, se o controlador MRxSmb. sys é descarregado antes de terminar de item em fila de trabalho, o sistema accionar um erro fatal.

Resolução

Informações sobre correção

Existe uma correção suportada pela Microsoft. No entanto, esta correção destina-se apenas a corrigir o problema descrito neste artigo. Aplique esta correção apenas em sistemas que tenham o problema descrito neste artigo. Esta correcção poderá ser submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afetado por este problema, recomendamos que aguarde pela próxima atualização de software que contenha esta correção.

Se a correcção estiver disponível para transferência, existirá uma secção de "Transferência de correcção disponível" na parte superior deste artigo da Base de dados de conhecimento. Se esta secção não for apresentada, contacte o Suporte ao Cliente da Microsoft para obter a correção.

Nota Caso ocorram problemas adicionais ou se for necessária a resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos de normais do suporte serão aplicados a questões de suporte adicional e problemas incluídos nesta correção específica. Para uma lista completa dos números de telefone de suporte e serviço de cliente da Microsoft ou para criar um pedido de assistência separado, visite o seguinte Web site da Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota O formulário "Transferência de correcção disponível" apresenta os idiomas nos quais a correcção está disponível. Se não visualizar o seu idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Para aplicar esta correcção, tem de ter o Windows Server 2003 Service Pack 1 ou Windows Server 2003 Service Pack 2 instalado.

Para mais informações, clique no número de artigo seguinte para visualizar o artigo na Base de Dados de Conhecimento Microsoft

889100 como obter o service pack mais recente do Windows Server 2003

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição da correção

Esta correcção não substitui quaisquer outras correcções.

Informações de ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são listadas na hora Universal Coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador Fuso horário no item data e hora no painel de controlo.

Windows Server 2003 com Service Pack 1, versões baseadas em x86

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.3276

438,784

07-Jan-2009

11:39

x86

Windows Server 2003 com Service Pack 2, versões baseadas em x86

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.4441

438,784

07-Jan-2009

11:44

x86

Windows Server 2003 com Service Pack 1, versões baseadas em Itanium

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.3276

1,172,992

07-Jan-2009

00:41

IA-64

Windows Server 2003 com Service Pack 2, versões baseadas em Itanium

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.4441

1,173,504

07-Jan-2009

00:47

IA-64

Windows Server 2003 com Service Pack 1, versões baseadas em x64

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.3276

786,944

07-Jan-2009

00:41

x64

Windows Server 2003 com Service Pack 2, versões baseadas em x64

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.4441

787,456

07-Jan-2009

00:49

x64

Windows XP Professional x64 Edition com Service Pack 1

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.3276

786,944

07-Jan-2009

00:41

x64

Windows XP Professional x64 Edition com Service Pack 2

Nome do ficheiro

Versão do ficheiro

Tamanho do ficheiro

Data

Hora

Plataforma

Mrxsmb.sys

5.2.3790.4441

787,456

07-Jan-2009

00:49

x64

Estado

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais informações

As funções ExInitializeWorkItem e ExQueueWorkItem podem ser utilizadas apenas quando o item de trabalho especificado não está associado a qualquer objecto de dispositivo ou pilha de dispositivos. Em todos os outros casos, os controladores devem utilizar as rotinas de IoAllocateWorkItem, IoFreeWorkIteme IoQueueWorkItem . Apenas estas rotinas garantem que o objecto de dispositivo que está associado ao item de trabalho especificado permanece disponível até que o item de trabalho foi processado.

Para mais informações, visite o seguinte site da Microsoft Developer Network Web:

http://msdn.microsoft.com/en-us/library/ms791491.aspxPara mais informações sobre a terminologia de atualização de software, clique no seguinte número de artigo para visualizar o artigo na Base de Dados de Conhecimento Microsoft:

824684 descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Suporte técnico para versões baseadas em x64 do Microsoft Windows

Se o hardware veio com uma edição do Microsoft Windows x64 já instalada, o fabricante do hardware fornece suporte técnico e assistência para a edição x64 do Windows. Neste caso, o fabricante do hardware fornece suporte porque foi incluída com o hardware de uma edição x64 do Windows. O fabricante do hardware pode ter personalizado a instalação da edição x64 do Windows utilizando componentes exclusivos. Estes componentes exclusivos podem incluir controladores de dispositivo específicos ou definições opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se necessitar de ajuda técnica para uma edição x64 do Windows. No entanto, poderá ter de contactar o fabricante directamente. O fabricante está melhor qualificado para suportar o software que instalou no hardware. Se tiver adquirido uma edição x64 do Windows, tais como uma edição x64 do Windows Server 2003, separadamente, contacte a Microsoft para obter suporte técnico.

Para obter informações sobre o Windows XP Professional x64 Edition, visite o seguinte Web site da Microsoft:

http://www.microsoft.com/windowsxp/64bit/default.mspxPara obter informações sobre versões baseadas em x64 do Windows Server 2003, visite o seguinte Web site da Microsoft:

http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×