Příznaky
Jde o takovouto situaci:
-
Máte webovou aplikaci, která běží v Internetová informační služba (IIS) 7.0 v počítači se systémem Windows Vista nebo v počítači se systémem Windows Server 2008.
-
Máte povoleno ověřování systému Windows ověřování a režimu jádra.
Poznámka: Toto je ve výchozím nastavení. -
Máte useAppPoolCredentials atribut sada na hodnotu true v části ověřování v souboru Applicationhost.config. Pravděpodobně jste přidali tento atribut povolit použití ověřování Kerberos při použití účtu domény pro identitu fondu aplikací. Například tento atribut musí být přidán při spuštění serveru Microsoft Office SharePoint Server. V části ověřování následujícímu.
<windowsAuthentication enabled="true" useKernelMode="true" useAppPoolCredentials="true"/>
Poznámka: V souboru Applicationhost.config umístěn v Drive: složku \Windows\System32\inetsrv\config.
V tomto scénáři může dojít k selhání operačního systému. Dále se zobrazí 0x0000007e chybová zpráva Stop na modré obrazovce.
Poznámka: K tomuto problému obvykle dochází na webových serverech hostitelského serveru Office SharePoint Server 2007. Tento problém nastává z důvodu konfigurační požadavky Office SharePoint Server 2007 při použití ověřování pomocí protokolu Kerberos. Problém však může nastat pro jakoukoli webovou stránku, která používá ověřování režimu jádra ověřování pomocí protokolu Kerberos a účet domény jako identita fondu aplikací vlastní.
Příčina
K tomuto problému dochází z důvodu chyby v ovladač režimu jádra HTTP (HTTP.sys).
Řešení
Informace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.
Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu naleznete na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Důležité opravy hotfix systému Windows Vista a Windows Server 2008 jsou součástí stejné balíčků. Pouze jeden z těchto produktů však může být uvedena na stránce "Hotfix požadavek". Chcete-li požádat o balíčku oprav hotfix vztahující se k systému Windows Vista a Windows Server 2008, stačí pouze vyberte produkt, který je uveden na stránce.
Předpoklady
Musíte mít Windows Vista Service Pack 1 (SP1) nebo Windows Server 2008 nainstalován použitím této opravy hotfix.
Požadavek na restartování
Po instalaci této opravy hotfix musíte restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Služba IIS 7.0, x86
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Http.sys |
6.0.600 1.22375 |
401,408 |
12-Feb-2009 |
03:33 |
x86 |
Služba IIS 7.0, x64
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Http.sys |
6.0.600 1.22375 |
596,480 |
12-Feb-2009 |
04:10 |
x64 |
SLUŽBA IIS 7.0, IA-64
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Http.sys |
6.0.600 1.22375 |
1,143,808 |
12-Feb-2009 |
02:54 |
IA-64 |
Jak potíže obejít
Chcete-li tento problém vyřešit, zakažte pomocí jedné z následujících metod ověřování v režimu jádra.
Metoda 1
Hodnota elementu useKernelMode nastavena na hodnotu false v části odpovídající windowsauthentication v souboru ApplicationHost.config.
<windowsAuthentication enabled="true" useKernelMode="false"/>
Metoda 2
Zakážete ověřování v režimu jádra pomocí Správce služby IIS. Chcete-li to provést, postupujte takto:
-
Klepněte na tlačítko Start, klepněte na tlačítko Spustit, typ
inetmgr.exea potom klepněte na tlačítko OK. -
Ve Správci služby IIS rozbalte položku
název serveru, rozbalte položku webové serverya potom klepněte na webový server, který chcete změnit. -
Poklepejte na položku ověřování, klepněte na tlačítko Ověřování systému Windows , zvýrazněte jej a v podokně akcí klepněte na tlačítko Upřesnit nastavení .
-
Klepnutím zrušte zaškrtnutí políčka Povolit ověřování režimu jádra .
Po zakázání ověřování režimu jádra, je nutné restartovat službu HTTP. To bude zastavení služby IIS. Spusťte následující příkazy na příkazovém řádku se zvýšenými oprávněními.
-
NET STOP HTTP
-
NET START HTTP
-
PŘÍKAZ IISRESET/START
Poznámka: Tyto příkazy se zastaví služba HTTP. Při zastavení služby HTTP, obdržíte zprávu s upozorněním, že budou také zastaveny služby závislé na službu HTTP. Poznamenejte si pečlivě tyto závislé služby, takže můžete určit, zda chcete pokračovat, a tak, aby po restartování služby protokolu HTTP, může jejich restartování. Služby závislé na službu HTTP bude záviset na role Windows a aplikací, které jsou aktuálně nainstalovány v počítači.
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Další informace
Výstup zásobníku volání
Používáte-li zkoumat souboru výpisu paměti, která je vytvořena poté, co dojde k chybě Debugging Tools for Windows a Microsoft symbol server, zjistíte, zásobník volání, která se podobá následující:
Child-SP RetAddr Call Sitefffffa60`02ff5b58 fffff800`01ba3644 nt!KeBugCheckEx
fffffa60`02ff5b60 fffff800`01b60f71 nt!PspUnhandledExceptionInSystemThread+0x24
fffffa60`02ff5ba0 fffff800`018c87d8 nt!PspSystemThreadStartup+0x9e
fffffa60`02ff5bd0 fffff800`018c86bd nt!_C_specific_handler+0x8c
fffffa60`02ff5c40 fffff800`018cfcff nt!RtlpExecuteHandlerForException+0xd
fffffa60`02ff5c70 fffff800`0188cd83 nt!RtlDispatchException+0x22f
fffffa60`02ff6360 fffff800`018b51a9 nt!KiDispatchException+0xc3
fffffa60`02ff6960 fffff800`018b3fa5 nt!KiExceptionDispatch+0xa9
fffffa60`02ff6b40 00000000`00010005 nt!KiPageFault+0x1e5
fffffa60`02ff6cd8 fffffa60`0805129e 0x10005
fffffa60`02ff6ce0 fffff800`01ad7ff3 HTTP!UlpThreadPoolWorker+0x28e
fffffa60`02ff6d50 fffff800`018ef546 nt!PspSystemThreadStartup+0x57
fffffa60`02ff6d80 00000000`00000000 nt!KxStartSystemThread+0x16
Poznámka: Součástí zásobníku volání, který označuje probíhající tento určitý systém crash je HTTP! UlpThreadPoolWorker.
Odkazy
Další informace o používání ověřování pomocí protokolu Kerberos a serveru Office SharePoint Server naleznete na následujících webech:
http://www.harbar.net/archive/2008/05/18/Using-Kerberos-with-SharePoint-on-Windows-Server-2008.aspx