ID do artigo: 969083 - Última revisão: segunda-feira, 24 de agosto de 2009 - Revisão: 2.0

Uma autenticação Kerberos falha juntamente com o código de erro 0X80090302 ou 0x8009030f em um computador que está executando o Windows Server 2008 ou Windows Vista quando o algoritmo AES é usado

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Você tem dois computadores que estejam executando o Windows Server 2008 ou Windows Vista. Um computador envia uma mensagem de autenticação Kerberos para o outro computador.
  • A autenticação Kerberos usa o algoritmo AES (Advanced Encryption Standard) para criptografar e descriptografar os dados de autenticação.
Nesse cenário, A autenticação Kerberos falha juntamente com o código de erro 0X80090302 ou 0x8009030f e você receber uma mensagem de erro. No entanto, a mensagem de erro que você recebeu pode variar para aplicativos diferentes. Por exemplo, se você tentar se conectar ao SQL Server 2005 ou SQL Server 2008 Analysis Services usando o Excel, você recebe uma das seguintes mensagens de erro:

mensagem 1
A função solicitada não tem suporte
mensagem 2
A mensagem ou assinatura fornecida para verificação foi alterada

Causa

A função SpSealMessage e a função SpUnsealMessage não criptografar e descriptografar as mensagens de autenticação corretamente quando o tamanho da mensagem não é divisível pelo tamanho do bloco esperado.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.


Hotfixes do Windows Vista e Windows Server 2008 importantes estão incluídos nos pacotes de mesmos. No entanto, somente um desses produtos pode ser listado na página ? Hotfix solicitação ?. Para solicitar o pacote de hotfix que se aplica ao Windows Vista e Windows Server 2008, basta selecione o produto que está listado na página.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando um dos seguintes sistemas operacionais:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Escopo da instalação de correção

A correção deve ser instalado no lado do cliente e no lado do servidor da conexão. Se muitos clientes estiverem afetados, ele talvez faça sentido para distribuir a correção para todos os sistemas Server 2008 e Windows Vista na empresa.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Para todas as versões com base em 86 do Windows Vista e do Windows Server 2008 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Kerberos.dll6.0.6001.22435500,73618-Mai-200913: 49x 86
Kerberos.dll6.0.6002.22138500,73618-Mai-200913: 44x 86
Para todas as versões com base em 64 do Windows Vista e do Windows Server 2008 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRequisito de SPRamificação do serviço
Kerberos.dll6.0.6001.22435657,92018-Mai-200914: 04x 64SP1Não aplicável
Kerberos.dll6.0.6001.22435500,73618-Mai-200913: 49x 86SP1UAU
Kerberos.dll6.0.6002.22138657,92018-Mai-200913: 45x 64SP2Não aplicável
Kerberos.dll6.0.6002.22138500,73618-Mai-200913: 44x 86SP2UAU

Como Contornar

Para contornar o problema, use a autenticação NTLM em vez de a autenticação Kerberos.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a função SpSealMessage , visite o seguinte site:
http://msdn.microsoft.com/en-us/library/aa380181(VS.85).aspx (http://msdn.microsoft.com/en-us/library/aa380181(VS.85).aspx)
Para obter mais informações sobre o SpUnsealMessage funcionar, visite o seguinte site da Microsoft:
http://msdn.microsoft.com/en-us/library/aa380184(VS.85).aspx (http://msdn.microsoft.com/en-us/library/aa380184(VS.85).aspx)
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684   (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão que é usada para descrever as atualizações de software

A informação contida neste artigo aplica-se a:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB969083 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 969083  (http://support.microsoft.com/kb/969083/en-us/ )