Artigo: 969711 - Última revisão: quinta-feira, 21 de Maio de 2009 - Revisão: 1.0

O teclado sem fios e o rato deixar de responder durante algum tempo depois de tentar retomar o funcionamento um computador baseado no Windows Vista Service Pack 2 a partir do modo de suspensão

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Num computador com o Windows Vista Service Pack 2 (SP2), prima qualquer tecla no teclado para retomar o funcionamento do computador a partir do modo de suspensão ou de hibernação. No entanto, o teclado e o rato deixam de responder durante muito tempo depois de apresentado o ecrã de início de sessão. Pode demorar mais de vinte segundos antes de poder utilizar o teclado e o rato.

Este problema ocorre em alguns sistemas que utilizam um teclado sem fios e o rato.

Causa

Este problema ocorre porque os controladores anfitriões USB que controlam o teclado sem fios e o rato não são correctamente entregues ao sistema operativo.

Resolução

Para resolver este problema, adicione a entrada de registo ForceHCResetOnResume para os controladores de anfitrião universal USB. Para o fazer, siga estes passos:

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows

Passo 1: Determinar o controlador de anfitrião universal USB específico

  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    Start button
    , escreva o Gestor de dispositivos na caixa Iniciar procura e, em seguida, clique em Gestor de dispositivos na lista programas .
  2. No menu Ver , clique em dispositivos por ligação .
  3. Expanda o nó de processador, expanda Sistema compatível com ACPI da Microsoft e, em seguida, expanda barramento de PCI .

    Vários controladores de anfitrião universal USB serão listados.
  4. Expandir cada nó do controlador anfitrião universal USB e expanda subnós sucessivas até localizar o nome do dispositivo que está a falhar.
  5. Quando tiver localizado o dispositivo, clique com o botão direito do rato o controlador de anfitrião universal USB associado e, em seguida, clique em Propriedades .
  6. Clique no separador Detalhes .
  7. Na lista de Propriedades , seleccione controlador chave .
  8. A chave do controlador será semelhante o seguinte:
    {36fc9e60-c465-11cf-8056-444553540000} \0002
    . Tenha em atenção os últimos quatro dígitos desta chave do controlador.

Passo 2: Adicionar a entrada de registo ForceHCResetOnResume para o controlador anfitrião universal USB

  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    Start button
    , escreva regedit na caixa Iniciar procura e, em seguida, clique em regedit.exe na lista programas .
  2. Localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {36FC9E60-C465-11CF-8056-444553540000} \ Four-digit_number
    notas
    • Neste passo, Four-digit_number é um marcador de posição para os dispositivos USB no sistema.
    • Neste passo, tem de localizar a subchave do registo utilizando o valor que anotou no passo 1 h. Por exemplo, se a chave do controlador a partir do passo 1 h \0002 {36fc9e60-c465-11cf-8056-444553540000} , em seguida, tem procure HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {36FC9E60-C465-11CF-8056-444553540000} \0002
  3. No menu Editar , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  4. Escreva ForceHCResetOnResume e, em seguida, prima ENTER.
  5. Clique com o botão direito do rato ForceHCResetOnResume para o nome da DWORD e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , escreva 1 e, em seguida, clique em OK .
  7. Saia do Editor de registo.
  8. Reinicie o computador.

Ponto Da Situação

A Microsoft confirmou que este erro ocorre nos produtos do Microsoft listados na secção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Windows Vista Service Pack 2
Palavras-chave: 
kbmt kboem kbinfo kbexpertiseinter kbtshoot kbsurveynew kbprb KB969711 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 969711  (http://support.microsoft.com/kb/969711/en-us/ )