ID do artigo: 969711 - Última revisão: quinta-feira, 21 de maio de 2009 - Revisão: 1.0

O teclado sem fio e o mouse parar de responder por um tempo depois de tentar reiniciar um computador baseado no Windows Vista Service Pack 2 do modo de suspensão

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
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Sintomas

Em um computador que está executando o Windows Vista com Service Pack 2 (SP2), você pressione qualquer tecla no teclado para reiniciar o computador do modo de suspensão ou de hibernação. No entanto, o mouse e o teclado param de responder por um longo tempo depois que a tela de logon for exibida. Pode demorar mais de vinte segundos antes de poder usar o teclado e o mouse.

Esse problema ocorre em alguns sistemas que usam um teclado sem fio e o mouse.

Causa

Esse problema ocorre porque os controladores USB que controlam o teclado sem fio e o mouse não são corretamente entregues para o sistema operacional.

Resolução

Para resolver esse problema, adicione a entrada de registro ForceHCResetOnResume para os controladores de host universal USB. Para fazer isso, execute as seguintes etapas:

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows

Etapa 1: Determinar o controlador de host universal USB específico

  1. Clique em Iniciar com o
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    Start button
    , digite o Gerenciador de dispositivos na caixa Iniciar procura e, em seguida, clique em Gerenciador de dispositivos na lista programas .
  2. No menu Exibir , clique em dispositivos por conexão .
  3. Expanda o nó de processador, expanda Sistema compatível com ACPI da Microsoft e, em seguida, expanda barramento PCI .

    Vários controladores de host universal USB serão listados.
  4. Expanda cada nó do controlador USB universal host e expanda subnós sucessivas até você localizar o nome do dispositivo que está falhando.
  5. Quando localizar o dispositivo, clique o controlador de host universal USB associado com o botão direito do mouse e, em seguida, clique em Propriedades .
  6. Clique na guia detalhes .
  7. Na lista propriedade , selecione chave de driver .
  8. A chave do driver será semelhante ao seguinte:
    {36fc9e60-c465-11cf-8056-444553540000} \0002
    . Observe os últimos quatro dígitos desta chave do driver.

Etapa 2: Adicionar a entrada de registro ForceHCResetOnResume para o controlador de host universal USB

  1. Clique em Iniciar com o
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    Start button
    , digite regedit na caixa Iniciar procura e, em seguida, clique em regedit.exe na lista programas .
  2. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {36FC9E60-C465-11CF-8056-444553540000} \ Four-digit_number
    anotações
    • Nesta etapa, Four-digit_number é um espaço reservado para os dispositivos USB no sistema.
    • Nesta etapa, você deve localizar a subchave do Registro usando o valor que você anotou na etapa 1 h. Por exemplo, se o driver a chave da etapa 1 h é \0002 {36fc9e60-c465-11cf-8056-444553540000} , em seguida, você deve procurar HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {36FC9E60-C465-11CF-8056-444553540000} \0002
  3. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  4. Digite ForceHCResetOnResume e, em seguida, pressione ENTER.
  5. Clique com o botão direito ForceHCResetOnResume para o nome do DWORD e, em seguida, clique em Modificar .
  6. Na caixa dados do valor , digite 1 e, em seguida, clique em OK .
  7. Feche o Editor do Registro.
  8. Reinicie o computador.

Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

A informação contida neste artigo aplica-se a:
  • Windows Vista Service Pack 2
Palavras-chave: 
kbmt kboem kbinfo kbexpertiseinter kbtshoot kbsurveynew kbprb KB969711 KbMtpt
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