The volume GUID may unexpectedly change after a volume is extended on a Windows Server 2008 failover cluster node

Article translations Article translations
Article ID: 970529 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • On a node in a Windows Server 2008 failover cluster, you add a new disk.
  • This new disk contains some highly available resources.
  • You move the disk resource to another node, and then, on this other node, you extend a volume on the disk.
In this scenario, the volume GUID for the disk changes, and then the applications that use the disk cannot access the shared volume data.

For example, if you use Microsoft System Center Virtual Machine Manager (SCVMM) to manage the virtual machines on the disk, you receive the following error message:
Unsupported Cluster Configuration
Warning (13924)
Highly available virtual machine <name> is not supported by VMM because the VM uses non-clustered Storage.
Recommended Action
Ensure that all the files and pass-though disks belonging to the VM reside on highly available storage.
"unsupported cluster"

CAUSE

This issue occurs because the cluster volume GUID is updated when a disk resource is moved to another node, and then, on this other node, a volume on the disk is extended.

RESOLUTION

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required. You can apply this hotfix on a computer that is running Windows Server 2008 or Windows Server 2008 Service Pack 2 (SP2).

Restart requirement

If the computer is already a member of a cluster, you must restart the computer after you apply this hotfix. However, if the computer is not a member of a cluster yet, you do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The Global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista and Windows Server 2008SP1GDR
    6.0.6001.22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.6002.18xxxWindows Vista and Windows Server 2008SP2GDR
    6.0.6002.22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the original release of Windows Server 2008.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6001.22438915,96827-May-200911:49x86
For all supported x86-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6002.22140915,96827-May-200911:44x86
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6001.224381,921,02427-May-200911:50IA-64
For all supported Itanium-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6002.221401,921,02427-May-200911:38IA-64
For all supported x64-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6001.224381,151,48827-May-200912:17x64
For all supported x64-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6002.221401,151,48827-May-200911:42x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

WORKAROUND

To work around this problem, move the disk resource back to the node where the volume was originally added to the cluster, and then extend the volume.

If you do not know which node is the node where the volume was originally added to the cluster, you can determine this by following these steps:
  1. In Failover Manager Microsoft Management Console (MMC) snap-in, click the General tab in the properties of the cluster disk resource, and then find the cluster volume GUID.
  2. From an elevated command prompt on the owning node, run Mounvol.exe, and then check whether the same cluster volume GUID is returned.
  3. If a match is found, then this is the node where the volume was originally added. If no match is found, repeat these steps on the remaining nodes until a match is found.
If before you apply this hotfix, you experience the problem described in this article, the following solutions may help you recover and help you keep the new volume GUID:
  • In any affected application, use the new volume GUID to update the volume GUID in the drive path.
  • If virtual machines are affected, re-create the virtual machines by using the existing virtual hard disks and the new volume GUID.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_for_kb970529_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,40928-May-200910:16Not Applicable
Package_for_kb970529_sc_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,52728-May-200910:16Not Applicable
Package_for_kb970529_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,70128-May-200910:16Not Applicable
Package_for_kb970529_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,41928-May-200910:16Not Applicable
Package_for_kb970529_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53128-May-200910:16Not Applicable
Package_for_kb970529_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71228-May-200910:16Not Applicable
X86_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6001.22438_none_c14bd434b629fed2.manifestNot Applicable10,64127-May-200913:33Not Applicable
X86_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6002.22140_none_c31f73e0b35fa52f.manifestNot Applicable10,64127-May-200913:13Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6001.22438_none_1d6a6fb86e877008.manifestNot Applicable10,69327-May-200913:58Not Applicable
Amd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6002.22140_none_1f3e0f646bbd1665.manifestNot Applicable10,69327-May-200913:06Not Applicable
Package_for_kb970529_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,41728-May-200910:16Not Applicable
Package_for_kb970529_sc_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,53728-May-200910:16Not Applicable
Package_for_kb970529_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,71128-May-200910:16Not Applicable
Package_for_kb970529_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,42728-May-200910:16Not Applicable
Package_for_kb970529_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54128-May-200910:16Not Applicable
Package_for_kb970529_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72228-May-200910:16Not Applicable

Additional files for all supported Itanium-based versions of Windows Server 2008

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6001.22438_none_c14d782ab62807ce.manifestNot Applicable10,66727-May-200913:18Not Applicable
Ia64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6002.22140_none_c32117d6b35dae2b.manifestNot Applicable10,66727-May-200912:49Not Applicable
Package_for_kb970529_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42328-May-200910:16Not Applicable
Package_for_kb970529_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,37028-May-200910:16Not Applicable
Package_for_kb970529_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,71628-May-200910:16Not Applicable
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 970529 - Last Review: September 11, 2010 - Revision: 1.1
APPLIES TO
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
Keywords: 
kbclustering kbautohotfix kbexpertiseinter kbsurveynew kbbug kbfix kbqfe KB970529

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com