Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • È possibile usare una sequenza di attività del Deployment Feature Pack (OSD) di System Center Configuration Manager 2007 per distribuire un file wim (OSD) Windows Windows del sistema operativo.

  • Il file ha dimensioni maggiori di 4 GB.

  • Si usa il metodo multicase per distribuire il file WIM del sistema operativo.

In questo scenario, la sequenza di attività e la distribuzione non riescono immediatamente dopo il download del file WIM.

Nota Lo stesso Windows file WIM del sistema operativo viene distribuito correttamente usando unicast. Inoltre, questo problema non si verificherà se si usa il metodo multicast per distribuire Windows file WIM del sistema operativo di dimensioni inferiori a 4 GB.

Causa

Questo problema è causato da un problema noto di System Center Configuration Manager 2007 Service Pack 1 (SP1) R2. In questo problema, i calcoli hash non vengono eseguiti correttamente quando le dimensioni del file WIM sono maggiori di 4 GB.

Risoluzione

Informazioni sui Service Pack

Per risolvere il problema, ottenere il Service Pack più recente per Microsoft System Center Configuration Manager 2007, disponibile in questo sito Web Microsoft: http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Per un elenco dei problemi risolti in questo Service Pack, fare clic sul numero dell'articolo seguente in Microsoft Knowledgebase:

971348 Elenco di aggiornamenti rapidi e aggiornamenti contenuti in System Center Configuration Manager 2007 Service Pack 2

Informazioni sull'aggiornamento rapido

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix ha lo scopo di correggere solo il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi che presentano il problema descritto in questo articolo. Questo hotfix potrebbe ricevere ulteriori test. Pertanto, se non si è gravemente colpiti da questo problema, è consigliabile attendere il prossimo aggiornamento software che contiene questo hotfix.

Se l'hotfix è disponibile per il download, nella parte superiore di questo articolo della Knowledge Base è presente la sezione "Download di hotfix disponibile". Se questa sezione non viene visualizzata, contattare il supporto tecnico Microsoft per ottenere l'hotfix.

Nota Se si verificano altri problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di servizio separata. I soliti costi di supporto si applicano a ulteriori domande e problemi di supporto che non sono idonei per questo hotfix specifico. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota Il modulo "Download di hotfix disponibile" mostra le lingue per cui l'hotfix è disponibile. Se non vedi la tua lingua, è perché non è disponibile un hotfix per tale lingua.

Requisiti

Per applicare questo hotfix, è necessario avere installato System Center Configuration Manager Service Pack 1 2007.

Requisito per il riavvio

Non è necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione di aggiornamenti rapidi

Questo hotfix non sostituisce altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix include gli attributi di file (o versioni successive) elencati nella tabella seguente. Le date e le ore di questi file sono elencate in formato UTC (Coordinated Universal Time). Quando esaminate le informazioni del file, viene convertito in orario locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.

Nome file

Versione file

Dimensione file

Date

Ora

Piattaforma

Mcs.msi

Non applicabile

7,138,304

01-dic-2008

01:15

Non applicabile

Smswdstp.dll

4.0.6221.1176

119,128

01-dic-2008

01:15

x86

Smswdstp.dll

4.0.6221.1176

286,040

01-dic-2008

01:15

x64


Soluzione alternativa

Per risolvere questo problema, usare il metodo unicast per distribuire o usare file WIM del sistema operativo di dimensioni inferiori a 4 GB.

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Ulteriori informazioni

Dopo aver installato l'hotfix descritto nell'articolo Microsoft Knowledge Base (KB) 971413, le distribuzioni del sistema operativo multicast potrebbero non funzionare più. Ciò include Windows file WIM del sistema operativo di dimensioni inferiori a 4 GB.

Dopo aver installato l'hotfix descritto nell'articolo della Knowledge Base 971413, viene avviata una reimpostazione del sito. La reimpostazione di un sito comporta la reinstallazione di tutti i componenti del sito. Tuttavia, la sessione di multicasting ha esito negativo se si verificano le condizioni seguenti:

  • Una sessione di multicast viene avviata troppo presto dopo la procedura di reimpostazione del sito.

  • La procedura di reimpostazione del sito non è stata completata.

  • Non tutti i componenti hanno completato il processo di reinstalazione, in particolare i componenti associati al multicasting.

Il modo più semplice per risolvere il problema consiste nell'attendere qualche minuto prima di eseguire una distribuzione del sistema operativo multicast. Tuttavia, se la distribuzione multicast non funziona ancora, seguire i metodi descritti di seguito:

Metodo 1

  1. Nelle proprietà dell'immagine del sistema operativo disabilitare e quindi abilitare nuovamente l'opzione Consenti il trasferimento di questo pacchetto tramite multicast (solo WinPE).

  2. Disabilita e riabilitare l'opzione Multicastnelle proprietà del punto di distribuzione multicast (DP).

  3. Reinstalla WDS.

Nota: se la distribuzione multicast su file di dimensioni superiori a 4 GB non funziona ancora, seguire il metodo successivo.

Metodo 2

  1. Nella console di System Center Configuration Manager 2007, in Immagini del sistema operativo, fare clic con il pulsante destro del mouse sull'immagine del sistema operativo in multicast e quindi scegliere Proprietà.

  2. Fare clic sulla scheda Impostazioni Distribuzione.

  3. Deselezionare l'opzione Consenti il trasferimento del pacchetto tramite multicast (solo WinPE) e quindi fare clic su
    Applica.

  4. Selezionare l'opzione Consenti il trasferimento del pacchetto tramite multicast (solo WinPE) e quindi fare clic su
    OK.

  5. Ripetere i passaggi da 1 a 4 per ogni immagine del sistema operativo impostata per il multicast.

Nota: se la distribuzione multicast su file di dimensioni superiori a 4 GB non funziona ancora, seguire il metodo successivo.

Metodo 3

  1. Nella console di System Center Configuration Manager 2007, in Immagini del sistema operativo, fare clic con il pulsante destro del mouse sull'immagine del sistema operativo in multicast e quindi scegliere Proprietà.

  2. Fare clic sulla scheda Impostazioni Distribuzione.

  3. Deselezionare l'opzione Consenti il trasferimento del pacchetto tramite multicast (solo WinPE), quindi fare clic su OK.

  4. Ripetere i passaggi da 1 a 3 di questo metodo per ogni immagine del sistema operativo impostata per il multicast.

  5. Disabilitare la DP multicast nelle proprietà del ruolo DP. A questo scopo, fare clic sulla scheda Multicast , deselezionare l'opzione Abilita multicast e quindi fare clic su OK.

  6. Monitorare il file MCSSetup.log e il file MCSMSI.log. Attendi che i file vengano disinstallati correttamente.

  7. Reinstallare il multicast nelle proprietà del ruolo DP. A questo scopo, fare clic sulla scheda Multicast , selezionare Abilita Multicast e quindi fare clic su OK.

  8. Monitorare il file MCSSetup.log e il file MCSMSI.log. Attendi la corretta installazione dei file.

  9. Nella console di System Center Configuration Manager 2007, in Immagini del sistema operativo, fare clic con il pulsante destro del mouse sull'immagine del sistema operativo in multicast e quindi scegliere Proprietà.

  10. Fare clic sulla scheda Impostazioni Distribuzione.

  11. Selezionare l'opzione Consenti il trasferimento del pacchetto tramite multicast (solo WinPE) e quindi fare clic su
    OK.

  12. Ripetere i passaggi da 9 al passaggio 11 di questo metodo per ogni immagine del sistema operativo che è statasetata su multicast.

Nota: se la distribuzione multicast su file di dimensioni superiori a 4 GB non funziona ancora, seguire il metodo successivo.

Metodo 4

  1. Seguire i passaggi da 1 a 6 del metodo 3.

  2. Se il server non è un punto di servizio PXE, andare al passaggio 5 di questo metodo.

  3. Se il server è anche un punto di servizio PXE, eliminare le immagini di avvio da PXEBOOTIMAGES$ DP e disinstallare il ruolo del punto di servizio ConfigMgr PXE.

  4. Monitorare il file PXESetup.log e verificare che il punto di servizio PXE sia stato disinstallato correttamente.

  5. Disinstalla WDS.

  6. Se richiesto, riavviare il server.

  7. Reinstalla Servizi di distribuzione per assicurarti di selezionare sia il server di distribuzione che il server di trasporto.

  8. Se il server non è un punto di servizio PXE, andare al passaggio 12 di questo metodo.

  9. Se il server è anche un punto di servizio PXE, reinstallare il ruolo del punto di servizio ConfigMgr PXE.

  10. Monitorare il file PXESetup.log e verificare che il punto di servizio PXE sia installato correttamente. Se viene richiesto di riavviare il server, riavviare il server.

  11. Aggiungi di nuovo le immagini di avvio al PXEBOOTIMAGES$ DP.

  12. Seguire i passaggi da 7 al passaggio 13 del metodo 3.


Per altre informazioni, fare clic sul numero dell'articolo seguente per visualizzare l'articolo nella Microsoft Knowledge Base:

824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×