Hyper-V differencing disku, které vytvoříte v systému Windows Server 2008 R2 nelze použít v systému Windows Server 2008

Překlady článku Překlady článku
ID článku: 971677 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Problém 1

Předpokládejme následující situaci:
  • Vytvořit virtuální stroj Hyper-V počítači se systémem Windows Server 2008.
  • Vyberte připojit differencing disku, který byl vytvořen v počítači se systémem Windows Server 2008 R2.
V tomto scénáři může zobrazit následující chybové zprávy:
Server zjistil chybu při konfiguraci pevného disku na VMName.
Přidání zařízení se nezdařilo ' Microsoft Virtual disku '.
Nelze otevřít přílohu ' <DirectoryName> \Filename.vhd '. Chyba: 'soubor nebo adresář je poškozený a nečitelný.'
Nelze získat informace o přílohu ' <DirectoryName> \Filename.vhd '.

Problém 2

Předpokládejme následující situaci:
  • System Center Virtual Machine Manager 2008 R2 je Správa serveru Windows Server 2008, který má roli komponenty Hyper nainstalována a serveru Windows Server 2008 R2, který má nainstalovanou roli Hyper-V
  • Virtuální stroj Hyper-V z Windows Server 2008 R2 přenést do systému Windows Server 2008.
V tomto případě se může zobrazit následující chybová zpráva::
Chyba (1730)
Vybranou akci nelze dokončit, protože virtuálního počítače není ve stavu, ve které je akce platná.

Příčina

K tomuto problému dochází, protože ovladač Vhdparser.sys v systému Windows Server 2008 nezpracovává správně hodnotu metadata. Tato metadata hodnota se používá v differencing disky, které jsou vytvořeny na serveru se systémem Windows Server 2008 R2.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/? ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Důležité Windows Vista a Windows Server 2008 opravy hotfix jsou součástí stejné balíčků. Pouze jeden z těchto produktů, však může být uvedeno na stránce text Hotfix Request ”. Vyžádat balíček opravy hotfix se vztahuje na Windows Vista a Windows Server 2008, vyberte produkt, který je uveden na stránce.

Požadavky

Tuto opravu hotfix, počítač musí používat jeden z následujících operačních systémů:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
Navíc musíte mít roli Hyper-V počítači nainstalována.

Požadavek na restartování

Po instalaci této opravy hotfix bude třeba restartovat počítač.

Informace o registru

Nemáte změnu registru.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v položce datum a čas v ovládacím.
Pro všechny podporované 64bitové verze systému Windows Server 2008 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Isoparser.sys6.0.6001.2244519,96808 VI 200917: 43X64SP1
Passthruparser.sys6.0.6001.2244528,67208 VI 200917: 43X64SP1
Storvsp.sys6.0.6001.22445133,12008 VI 200917: 43X64SP1
Vhdparser.sys6.0.6001.2244594,20808 VI 200917: 43X64SP1
Wstorvsp.infNelze použít6,46208 VI 200914: 59Nelze použítSP1

Pro všechny podporované verze 64 Windows Server 2008 SP2 x
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaPožadavek na aktualizaci SP
Isoparser.sys6.0.6002.2214819,96808 VI 200917: 27X64SP2
Passthruparser.sys6.0.6002.2214828,67208 VI 200917: 27X64SP2
Storvsp.sys6.0.6002.22148122,88008 VI 200917: 27X64SP2
Vhdparser.sys6.0.6002.2214887,55208 VI 200917: 27X64SP2
Wstorvsp.infNelze použít6,46208 VI 200914: 59Nelze použítSP2

Další informace

Další informace naleznete následujícím článku znalostní databáze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Vlastnosti

ID článku: 971677 - Poslední aktualizace: 5. srpna 2009 - Revize: 1.1
Informace v tomto článku jsou určeny pro produkt:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
Klíčová slova: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB971677 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:971677

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com