Artigo: 973479 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Ao tentar imprimir ou pré-visualizar uma página Web no Internet Explorer, a página Web poderá não ser impressa ou pré-visualizada corretamente e poderá ocorrer um erro de script.

Causa

Este problema pode ocorrer devido a um ou mais dos seguintes cenários:
Cenário 1: A sua placa gráfica ou o controlador de vídeo estão desatualizados ou corrompidos. Nota Controladores da impressora desatualizados ou corrompidos poderão também causar erros de script ao imprimir a partir do Internet Explorer

Cenário 2: Poderá não ter permissões de impressão atribuídas

Cenário 3: O Modo Protegido está ativado para a zona de segurança da Internet da página Web

Cenário 4: Existe um problema com as pastas temporárias na sua conta de utilizador e a pasta Low na localização %TEMP% foi eliminada

Resolução

Para resolver este problema, utilize os seguintes métodos pela ordem em que são apresentados. Se o método 1 não resolver o seu problema, passe ao método seguinte.

Método 1: Resolver problemas com a sua impressora e atualizar os seus controladores para a versão mais recente

Siga o seguinte tutorial para saber como identificar e corrigir problemas comuns de impressoras no Windows:

Problemas de impressoras no Windows

Controladores de impressora desatualizados podem causar problemas ao imprimir a partir do Internet Explorer, pelo que tente atualizar a sua impressora para o controlador mais recente; para tal, clique na hiperligação específica para a sua versão do Windows e siga os passos nesse artigo:

Localizar e instalar controladores de impressora no Windows 7

Localizar e instalar controladores de impressora no Windows Vista



Importante:
Em alguns casos, poderá não estar disponível uma versão atualizada do controlador através do Windows Update. Poderá ser necessário aceder ao Web site do fabricante e localizar, transferir e instalar o mais recente controlador para a sua impressora.

Se a atualização do seu controlador de impressora não resolver o problema, passe ao método 2.

Método 2: Tentar imprimir uma página Web executando o Internet Explorer como Administrador

Tente imprimir uma página Web executando o Internet Explorer como Administrador; isto pode ajudar a determinar se existe um problema com as permissões.

Para verificar se iniciou sessão como administrador, siga estes passos
Reduzir esta imagemExpandir esta imagem
assets folding start collapsed


  1. Abra a caixa de diálogo Data e Hora.
    1. Clique em Iniciar.
    2. Escreva o seguinte comando na caixa Iniciar Procura ou na caixa Procurar programas e ficheiros e, em seguida, prima ENTER:
      timedate.cpl
      A caixa de diálogo Data e Hora é aberta.
      Reduzir esta imagemExpandir esta imagem
      2418433
  2. Clique em Alterar data e hora na caixa de diálogo Data e Hora. Quando a caixa de diálogo Controlo de Conta de Utilizador for aberta, clique em Continuar.
    Reduzir esta imagemExpandir esta imagem
    2418434
  3. Agora, execute uma das seguintes ações, dependendo do que acontecer quando clicar em Continuar:
    • Se o computador não solicitar uma palavra-passe
      Já tem sessão iniciada com uma conta de administrador. Clique duas vezes em Cancelar para fechar a caixa de diálogo Data e Hora e estará pronto para prosseguir com esta tarefa.
    • Se o computador solicitar uma palavra-passe
      Não tem sessão iniciada com uma conta de administrador.
Reduzir esta imagemExpandir esta imagem
assets folding end collapsed

Nota Deve utilizar uma conta que tenha permissão de administrador para alterar o tipo de conta de Padrão para Administrador.

Para iniciar o Internet Explorer como Administrador, siga estes passos:
  1. Feche todas as janelas do Internet Explorer.
  2. Clique em Iniciar, clique em Todos os Programas, clique com o botão direito em Internet Explorer e selecione Executar Como Administrador.
  3. Navegue até um Web site e tente imprimir uma página aquando da execução como Administrador.
Se imprimir uma página Web executando o Internet Explorer como Administrador não resolver o problema, passe ao método 3.

Método 3: Tentar imprimir depois de desativar o Modo Protegido

Tente imprimir uma página Web depois de desativar o Modo Protegido; para tal, siga estes passos:

  1. Clique no ícone Ferramentas no Internet Explorer
  2. Clique no separador Segurança e desmarque a caixa de verificação junto a Ativar o Modo Protegido (requer o reinício do Internet Explorer)
  3. Clique em Aplicar e, em seguida, clique em OK.
  4. Feche todas as janelas abertas do Internet Explorer e, em seguida, reinicie o Internet Explorer.
  5. Navegue até um Web site e tente imprimir uma página aquando da execução como Administrador.
Se a desativação do Modo Protegido não resolver o problema, passe ao método 4.

Método 4: Recriar a pasta em falta


Para nos solicitar a recriação da pasta em falta, consulte a secção "Corrigir por mim". Se preferir corrigir o problema sozinho, consulte a secção "Deixar-me corrigir o problema".

Corrigir por mim


Para corrigir este problema automaticamente, clique no botão ou hiperligação Correção. Clique em Executar na caixa de diálogo Transferência de Ficheiros e, em seguida, siga os passos indicados no assistente de Correção.
Reduzir esta imagemExpandir esta imagem
assets fixit1
Corrigir este problema
Correção da Microsoft 50676
Reduzir esta imagemExpandir esta imagem
assets fixit2


Notas
  • Se a pasta "Low" já existir no seu computador, poderá ocorrer o erro "Esta solução de Correção da Microsoft não se aplica ao seu sistema operativo ou versão da aplicação". Pode ignorar este erro com segurança e passar ao método seguinte.
  • Este assistente pode estar apenas em inglês. Contudo, a correção automática também funciona para versões do Windows noutros idiomas.
  • Se não estiver a trabalhar no computador que tem o problema, pode guardar a solução de correção numa pen USB ou num CD e, em seguida, executá-la no computador que tem o problema.

Em seguida, consulte a secção "O problema está corrigido?".



Deixar-me corrigir o problema

Reduzir esta imagemExpandir esta imagem
assets folding start collapsed
  1. Feche todas as instâncias do Internet Explorer.
  2. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
     botão Iniciar
    , escreva %Temp% na caixa Iniciar procura e clique na pasta Temp na lista.
  3. Se estiver a utilizar o Windows Vista, clique em Nova pasta no menu Organizar.

    Se estiver a utilizar o Windows 7, clique em Nova pasta no menu principal.
  4. Escreva Low para o nome da pasta e prima ENTER.
  5. Feche a janela do Explorador do Windows, inicie o Internet Explorer e imprima ou pré-visualize uma página Web.
Reduzir esta imagemExpandir esta imagem
assets folding end collapsed

Se este método não resolver o problema, avance para o método seguinte.

Método 5: Repor o nível de integridade baixo na pasta "Low"

Para nos solicitar a reposição do nível de integridade baixo na pasta Low, consulte a secção "Corrigir por mim". Se preferir corrigir o problema sozinho, consulte a secção "Deixar-me corrigir o problema".

Corrigir por mim



Para corrigir este problema automaticamente, clique no botão ou hiperligação Correção. Clique em Executar na caixa de diálogo Transferência de Ficheiros e, em seguida, siga os passos indicados no assistente de Correção.
Reduzir esta imagemExpandir esta imagem
assets fixit1
Corrigir este problema
Correção da Microsoft 50677
Reduzir esta imagemExpandir esta imagem
assets fixit2


Notas
  • Este assistente pode estar apenas em inglês. Contudo, a correção automática também funciona para versões do Windows noutros idiomas.
  • Se não estiver a trabalhar no computador que tem o problema, pode guardar a solução de correção numa pen USB ou num CD e, em seguida, executá-la no computador que tem o problema.

Em seguida, consulte a secção "O problema está corrigido?".



Deixar-me corrigir o problema

Reduzir esta imagemExpandir esta imagem
assets folding start collapsed
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
     botão Iniciar
    , clique em Todos os Programas e, em seguida, clique em Acessórios.
  2. Clique com o botão direito do rato em Linha de Comandos e de seguida clique em Executar como administrador.
  3. Escreva o seguinte comando e prima ENTER:
    ICACLS "%userprofile%\AppData\Local\Temp\Low" /setintegritylevel (OI)(CI)low
  4. Reinicie o computador.
  5. Imprima ou pré-visualize uma página Web no Internet Explorer.
Reduzir esta imagemExpandir esta imagem
assets folding end collapsed

O problema está corrigido?

  • Verifique se o problema está corrigido. Se o problema estiver corrigido, terminou esta secção. Se o problema não estiver corrigido, pode contactar o suporte.
  • Agradecemos os seus comentários. Para enviar comentários ou comunicar quaisquer problemas com esta solução, deixe um comentário no blogue "Corrigir por mim" ou envie-nos uma mensagem de correio eletrónico.

Mais Informações

Para problemas de impressão específicos de um fabricante de impressoras em particular, clique na hiperligação associada ao seu fabricante:

Este problema pode ocorrer em determinadas impressoras Canon se tiver um determinado controlador de impressora Canon instalado. Para mais informações, visite o Web site da Microsoft:Para obter ajuda com as impressoras Canon, visite o seguinte Web site da Canon:
Serviço de apoio ao cliente da Canon
Tutorial de Resolução de Problemas de Impressoras:
Para um tutorial passo-a-passo para obter ajuda a identificar e corrigir problemas comuns de impressoras, visite o seguinte Web site da Microsoft:
Problemas de impressoras no Windows
Para resolver erros de script ao tentar imprimir uma página Web no Internet Explorer, visite o seguinte Web site da Microsoft:Para detetar e corrigir automaticamente problemas e erros de impressão, visite o seguinte Web site da Microsoft:
Problemas de impressão e erros de impressão

Propriedades

Artigo: 973479 - Última revisão: 10 de junho de 2014 - Revisão: 11.0
A informação contida neste artigo aplica-se a:
  • Windows Internet Explorer 7 nas seguintes plataformas
    • Windows 7 Enterprise
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Basic Beta
    • Windows Vista Home Premium
    • Windows Vista Starter
    • Windows Vista Ultimate
  • Windows Internet Explorer 8 nas seguintes plataformas
    • Windows 7 Enterprise
    • Windows Vista Business
    • Windows Vista Business 64-bit edition
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Starter
    • Windows Vista Ultimate
  • Windows Internet Explorer 9
Palavras-chave: 
kbtshoot kbexpertisebeginner kbfixme kbmsifixme kbcip KB973479

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com