Windows Server 2003 서비스 팩 2 큰 Windows Installer 패키지 또는 큰 Windows Installer 패치 패키지를 설치하려고 하면 오류 메시지: "1718 오류 파일이 디지털 서명 정책에 의해 거부되었습니다."

기술 자료 번역 기술 자료 번역
기술 자료: 973825 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Windows Server 2003 서비스 팩 2를 실행하는 컴퓨터에서 큰 Microsoft Windows Installer (.msi) 패키지 또는 큰 Microsoft Windows Installer 패치 (.msp) 패키지를 설치하려고 하면 다음 오류 메시지가 나타날 수 있습니다.
오류 1718입니다. File FileName 디지털 서명 정책에 의해 거부되었습니다.
또한 응용 프로그램 로그에 다음 이벤트가 기록될 수 있습니다.

형식: 오류
원본: MsiInstaller
범주: 없음
이벤트 ID: 1008
Date 날짜:
시간: Time
사용자: N/A
컴퓨터: ComputerName

설명:
소프트웨어 제한 정책 처리 오류 FileName 설치가 허용되지 않습니다. 개체를 신뢰할 수 없습니다.

원인

Windows Installer 프로세스를 확인하려면 연속 가상 메모리 부족 .msi 패키지 또는 .msp 패키지가 올바르게 서명되지 경우 이 문제가 발생합니다.

해결 방법

업데이트 다운로드 정보

다음 파일은 Microsoft 다운로드 센터에서 사용할 수 있습니다.

그림 축소그림 확대
Download
Download the Update for Windows Server 2003 (973825) package now.

그림 축소그림 확대
Download
Download the Update for Windows Server 2003, x64 Edition (973825) package now.

그림 축소그림 확대
Download
Download the Update for Windows Server 2003 for Itanium-based Systems (973825) package now.

Microsoft 지원 파일을 다운로드하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
119591온라인 서비스로부터 Microsoft 지원 파일을 구하는 방법
Microsoft는 이 파일에 대한 바이러스를 검색합니다. Microsoft는 파일을 게시한 날짜에 사용할 수 있었던 최신 바이러스 검색 소프트웨어가 사용됩니다. 해당 파일을 무단으로 변경할 수 없는 보안이 향상된 서버에 보관됩니다.

전제 조건

이 업데이트를 적용하려면 설치된 Windows Server 2003 서비스 팩 2 있어야 합니다.

재시작 요구 사항

업데이트를 적용한 후에는 컴퓨터를 다시 시작해야 합니다.

업데이트 대체 정보

이 업데이트는 다른 업데이트를 대체하지 않습니다.

파일 정보

이 업데이트의 영어 버전은 다음 표에 나와 있는 파일 특성 (또는 그 이후의 파일 특성)을 갖습니다. 이러한 파일의 시간과 날짜는 UTC (협정 세계시) 로 나열됩니다. 파일 정보에서는 현지 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 알려면 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용하십시오.

Windows Server 2003 (KB973825) 업데이트

표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼SP 요구 사항서비스 분기
Advapi32.dll5.2.3790.4555619,0082009-7월-1815: 58x 86sp2sp2gdr
Advapi32.dll5.2.3790.4555619,0082009-7월-1816: 19x 86sp2sp2qfe

Windows Server 2003, x 64 Edition (KB973825) 업데이트

표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼SP 요구 사항서비스 분기
Advapi32.dll5.2.3790.45551,052,1602009-7월-18Prefixx 64sp2sp2gdr
Wadvapi32.dll5.2.3790.4555619,0082009-7월-18Prefixx 86sp2우와
Advapi32.dll5.2.3790.45551,065,9842009-7월-1816: 32x 64sp2sp2qfe
Wadvapi32.dll5.2.3790.4555619,0082009-7월-1816: 32x 86sp2우와

Windows Server 2003 업데이트 (KB973825) Itanium 기반 시스템에 대한

표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼SP 요구 사항서비스 분기
Advapi32.dll5.2.3790.45551,482,7522009-7월-1821: 44IA-64sp2sp2gdr
Wadvapi32.dll5.2.3790.4555619,0082009-7월-1821: 44x 86sp2우와
Advapi32.dll5.2.3790.45551,483,7762009-7월-1816: 32IA-64sp2sp2qfe
Wadvapi32.dll5.2.3790.4555619,0082009-7월-1816: 32x 86sp2우와

해결 과정

중요한 이 섹션에서는, 메서드 또는 작업이 레지스트리 수정 방법을 알려 주는 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 따라서 다음 이 단계를 주의 깊게 따라야 합니다. 추가 보호 기능을 수정하기 전에 레지스트리를 백업해야. 그런 다음 문제가 발생할 경우 레지스트리를 복원할 수 있습니다. 백업 및 복원하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322756백업 및 Windows 에서 레지스트리를 복원하는 방법
이 문제를 해결하려면 패키지를 설치하기 전에 PolicyScope 레지스트리 값을 1로 변경하십시오. 이렇게 하려면 다음과 같이 하십시오.

참고 컴퓨터가 도메인에 가입되어 있는 경우 도메인 정책 업데이트 레지스트리 변경 내용을 무시할 수도 있습니다. 다음 이 단계를 수행하기 전에 도메인에서 컴퓨터의 연결을 좋습니다.
  1. 시작 을 누르고 실행regedit 를 입력한 다음 확인 을 누릅니다.
  2. 레지스트리 편집기에서 찾은 후 다음 레지스트리 키를 누릅니다.
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Safer\CodeIdentifiers
    참고 이 키를 수정하기 전에 이 키를 백업하는 것이 좋습니다. 이렇게 하려면 CodeIdentifiers, 마우스 오른쪽 단추로 클릭한 다음 내보내기 를 클릭하십시오. 이 컴퓨터에서 찾을 수 있는 위치에 파일을 저장하십시오.
  3. PolicyScope 레지스트리 값을 변경하십시오. 이렇게 하려면 PolicyScope, 두 번 클릭한 다음 설정이 0에서 1로 변경하십시오.
  4. 레지스트리 편집기를 닫습니다.
  5. 시작 을, 실행 을, cmd 를 입력한 다음 명령 프롬프트 창을 열려면 확인 누릅니다.
  6. 명령 프롬프트에서 다음 명령을 입력한 다음 Enter 키를 누릅니다.
    net stop msiserver
    서비스가 백그라운드에서 현재 실행 중인 경우 이 명령은 Windows Installer 서비스를 중지합니다. 서비스가 중지되면 명령 프롬프트 창을 닫은 다음 7단계로 이동하십시오.

    참고 명령 프롬프트에서 다음 메시지가 나타나면 명령 프롬프트 창을 닫고 7단계로 이동하십시오.
    Windows Installer 서비스를 시작합니다
  7. "현상" 절에서 설명한 오류 메시지가 나타났을 때 설치하려고 한 패키지를 설치하십시오.
  8. 패키지를 설치한 후 1-2단계를 반복하십시오. 그런 다음 PolicyScope 레지스트리 값을 다시 0으로 변경하십시오.
  9. 컴퓨터가 도메인에서 연결이 끊어진 경우 해당 도메인에 다시 가입해야 누른 다음 컴퓨터를 다시 시작하십시오.

    참고 도메인에서 컴퓨터의 연결을 경우 컴퓨터를 다시 시작할 필요가 없습니다.
이전 단계에서 문제가 해결되지 않으면 다음과 같이 하십시오.
  1. 시작 을 누르고, 실행 을, 제어 admintools 를 입력한 다음 확인을 누릅니다.
  2. 로컬 보안 정책 을 두 번 클릭하십시오.
  3. 소프트웨어 제한 정책 을 클릭하십시오.

    참고 소프트웨어 제한 목록에 있는 경우 소프트웨어 제한 정책 을 마우스 오른쪽 단추로 클릭한 다음 새 정책 만들기 를 클릭하십시오.
  4. 개체 형식적용 을 두 번 클릭하십시오.
  5. 로컬 관리자 제외한 모든 사용자 를 누른 다음 확인 을 누릅니다.
  6. 컴퓨터를 다시 시작하십시오.
중요한 이전 단계를 수행한 후에는 .msi 패키지나 .msp 패키지가 로컬 관리자는 설치할 수 있습니다. 패키지를 설치한 후에 이전 단계를 수행하여 강요 수준을 다시 설정하십시오. 단계 5에서 로컬 관리자 제외한 모든 사용자 대신 모든 사용자 를 클릭하십시오.

슬라이드 노트
  • 해결 방법은 Active Directory 도메인 환경에서 작동하지 않을 수 있습니다. Active Directory 도메인 환경에서 도메인 정책 새로 고침 작업이 로컬 소프트웨어 제한 정책을 덮어씁니다.
  • 컴퓨터에 RAM을 추가하면 문제가 해결되지 않습니다.

추가 정보

Windows XP에서 시작하여 알려진 안전한 소프트웨어 제한 정책 명명된 보안 정책은 안전하지 않은 파일 실행 방지하기 위해 도입되었습니다. Windows Installer는 소프트웨어 제한 정책이 서명된 .msi 패키지 파일 및 서명된 .msp 패키지 파일의 서명을 확인하는 데 사용합니다. Windows Installer는 컴퓨터에 설치하기 전에 파일을 사용하여 무단 있던 않도록 하려면 이 작업을 수행합니다. Windows XP 및 Windows Server 2003 전체 .msi 패키지 파일 또는 설치 주소 공간에서 메모리 인접한 한 부분을 데이터를 로드할 전체 .msp 패키지 파일을 처리하도록 합니다.

.msi 패키지 파일 또는 .msp 패키지 파일을 너무 큰 연속 가상 메모리 부분을 에 맞게 경우, Windows Installer 패키지를 올바른지 확인할 수 없습니다. 이 시나리오에서는 “ 현상 ” 절에서 설명하는 현상이 발생합니다. 이 문서에서 설명하는 수정 프로그램은 소프트웨어 제한 정책을 더 적은 가상 메모리를 사용하여 서명 확인을 수행할 수 있습니다. 따라서 Windows Installer 모든 크기의 파일을 확인할 수 있습니다.

속성

기술 자료: 973825 - 마지막 검토: 2009년 8월 3일 월요일 - 수정: 2.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Server 2003 Service Pack 2?을(를) 다음과 함께 사용했을 때
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
키워드:?
kbmt kbexpertisebeginner kbexpertiseinter atdownload kbsurveynew kbqfe KB973825 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com