การปรับรุ่นหยุดตอบสนอง (แฮง) ที่ 62% เมื่อคุณปรับรุ่นเป็น Windows 7

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 975253 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามปรับรุ่นคอมพิวเตอร์ของคุณจาก Windows Vista เป็น Windows 7 หยุดกระบวนการอัพเกรดการตอบสนองที่ 62% โดยไม่จำกัดเวลา

นอกจากนี้ Windows สร้างแฟ้มที่ชื่อ system_drive: \$WINDOWS.~BT\Sources\Panther\setupact.log ถ้าคุณตรวจสอบเนื้อหาของแฟ้ม คุณสังเกตเห็นรายละเอียดต่อไปนี้:

<date> <time>, Info                  MIG    IPostApply::ApplySuccess for Plugin={ServerPath="%windir%\system32\migration\IphlpsvcMigPlugin.dll", CLSID={ade10465-2a43-454e-b0a7-3f220a61bd03}, ThreadingModel=Apartment} - Working directory: C:\$UPGRADE.~OS\OnlineUpgradeApplyWork\srcworking\agentmgr\CCSIAgent\005AE0CB
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: Performing upgrade actions for all protocols
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, InterfaceCount = 0
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.Incrementing interface count
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, New value of *InterfaceCount = 1
<date> <time>, Info       [0x0808fe] MIG    Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: RegEnumKeyEx return 259. key name: {AC049C3C-9B90-41A7-9385-DC5AD3E656F0}.new index: 2
Warning [0x080b50] MIG AsyncCallback_ApplyStatus: Progress appears to be stuck. Current progress: 62
หมายเหตุ โดยทั่วไป ไดรฟ์ คือไดรฟ์ C บนคอมพิวเตอร์

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากบริการ Iphlpsvc หยุดการตอบสนองระหว่างการปรับรุ่น

หมายเหตุ บริการอื่น ๆ อาจทำให้เกิดปัญหาในกระบวนการปรับรุ่นหยุดการตอบสนองที่ 62%

การแก้ไข

สิ่งสำคัญไม่ใช้วิธีนี้ ถ้าการปรับรุ่นหยุดการตอบสนองที่เปอร์เซ็นต์นอกเหนือจาก 62% หรือ ถ้าไม่มีรายการล็อกการบันทึกสิ่งที่ปฏิบัติ สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเปิดแฟ้ม Seupact.log ให้ดู ข้อมูลเพิ่มเติม ส่วน

ต้องการให้เราแก้ไขปัญหานี้ให้คุณ ไป "แก้ไขให้ฉัน"ส่วน ถ้าคุณต้องการแก้ไขปัญหานี้ด้วยตัวคุณเอง ไป "ให้ฉันแก้ไขด้วยตนเอง"ส่วน

แก้ไขปัญหาให้กับฉัน

เมื่อต้องการแก้ไขปัญหานี้โดยอัตโนมัติ รีสตาร์ทเครื่องคอมพิวเตอร์ที่มีการปรับรุ่นเป็น Windows 7 ล้มเหลวที่ 62% คอมพิวเตอร์ของคุณจะย้อนกลับไปยัง Windows Vista ดาวน์โหลดโปรแกรมแก้ไขต่อไปนี้ ไปยังแฟลชไดรฟ์ หรือซีดี หรือกลับไปยังบทความนี้บนเครื่องที่การปรับรุ่นล้มเหลว ถ้าคุณกลับไปยังบทความนี้บนเครื่องที่คุณพบปัญหานี้ คลิก แก้ไขปัญหานี้ การเชื่อมโยง คลิก เรียกใช้ในการ การดาวน์โหลดแฟ้มกล่องโต้ตอบกล่อง และทำตามขั้นตอนในการแก้ไข จะช่วยสร้าง


แก้ไขปัญหานี้
Microsoft Fix it 50319


หมายเหตุตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังสามารถใช้ได้กับ Windows รุ่นภาษาอื่น

หมายเหตุ ถ้าคุณไม่ได้อยู่บนคอมพิวเตอร์ที่มีปัญหา คุณสามารถบันทึกการแก้ไขอัตโนมัติ ไปยังแฟลชไดรฟ์ หรือซีดี และจากนั้น คุณสามารถเรียกใช้ได้บนคอมพิวเตอร์ที่มีปัญหา

ถัดไป ไป "วิธีนี้แก้ไขปัญหาหรือไม่"ส่วน

ให้ฉันแก้ไขด้วยตนเอง

เมื่อต้องการแก้ไขปัญหานี้ด้วยตัวคุณเอง ให้ทำตามขั้นตอนเหล่านี้:
  1. รีสตาร์ทคอมพิวเตอร์ แล้ว คอมพิวเตอร์ของคุณจะย้อนกลับเป็น Windows Vista
  2. คลิก เริ่มคลิกขวา คอมพิวเตอร์แล้ว คลิก คุณสมบัติ.
  3. ในการ ขั้นสูง แท็บ คลิก ตัวแปรสภาพแวดล้อม.
  4. ภายใต้ ตัวแปรของระบบคลิก ใหม่.
  5. ชนิด MIG_UPGRADE_IGNORE_PLUGINS ในการ ชื่อตัวแปร เขตข้อมูล
  6. ชนิด IphlpsvcMigPlugin.dll ในการ ค่าตัวแปร เขตข้อมูล
  7. คลิก ตกลง สามครั้งเพื่อปิดกล่องโต้ตอบ
  8. เริ่มการติดตั้งการปรับรุ่นอีกครั้ง

ข้อมูลเพิ่มเติม

วิธีการเปิดแฟ้ม seupact.log

เมื่อต้องการเปิดแฟ้ม setupact.log ระหว่างกระบวนการอัพเกรด กด SHIFT + F10 เพื่อเปิดพร้อมท์คำสั่ง พิมพ์ C:\$WINDOWS.~BT\Sources\Panther\setupact.logแล้ว กด ENTER

เมื่อต้องเปิดแฟ้ม setupact.log หลังจากที่ต้องการรวบคอมพิวเตอร์รวมกลับไปเป็น Windows Vista เริ่มชนิด C:\$WINDOWS.~BT\Sources\Panther\setupact.log ในการ เริ่มต้นค้นหา กล่อง และจากนั้น กด ENTER

แฟ้ม seupact.log จะถูกเปิดขึ้นใน notepad เมื่อต้องการดูรายการแฟ้มบันทึกล่าสุด เลื่อนไปด้านล่างของแฟ้ม

วิธีนี้แก้ไขปัญหาหรือไม่

ตรวจสอบว่า ปัญหาได้รับการแก้ไข โดยการปรับรุ่นคอมพิวเตอร์ของคุณจาก Windows Vista เป็น Windows 7 หรือไม่ ถ้ากระบวนการอัพเกรด progresses เกินกว่า 62% คุณจะเสร็จสิ้น ด้วยบทความนี้ ถ้าไม่มีแก้ไขปัญหา คุณสามารถ ติดต่อฝ่ายสนับสนุน.

ยัง ต้องการความช่วยเหลือหรือไม่

ถ้าบทความนี้ไม่ช่วยตอบคำถามของคุณ คลิกปุ่มนี้เพื่อถามคำถามของคุณให้กับสมาชิกอื่นในชุมชนที่ Microsoft Community:
ถามคำถาม



ถ้าคุณต้องการดูคำตอบของปัญหาที่คล้ายกัน คลิกที่ลิงค์ต่อไปนี้เพื่อดูหัวข้อในการ Communityforum ของ Microsoft:

คุณสมบัติ

หมายเลขบทความ (Article ID): 975253 - รีวิวครั้งสุดท้าย: 30 พฤษภาคม 2556 - Revision: 11.0
ใช้กับ
  • Windows 7 Service Pack 1
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Home Basic
Keywords: 
kbfixme kbmsifixme kbexpertisebeginner kbsurveynew kbprb kbmt KB975253 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:975253

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com