Soluções HP Multifunction impressoras e HP completa de recurso de Software ou Driver básico da HP não funcionam como esperado após um computador atualizações do Windows Vista para o Windows 7

Artigo: 975891 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Para impressoras locais

Atualizar do Windows Vista para o Windows 7 em um computador que tem a solução completa de Software de recurso da HP ou a solução de Driver básico da HP instalado. Em seguida, você percebe que sua impressora de Multifunções HP (MFP) não funciona conforme o esperado. Em particular, botões físicos no painel frontal da impressora multifuncional parar de responder. O dispositivo é reconhecido corretamente e é exibido como instalado. No entanto, o software da HP não é iniciado e não relata que ele não pode se conectar ao dispositivo. Portanto, você não conseguir imprimir, digitalizar ou copiar.

Observação Se a solução de HP completa de recurso de Software ou Driver básico da HP não está instalado antes das atualizações de computador para o Windows 7, impressão e digitalização funcionalidade básica devem estar presentes. Para obter a funcionalidade avançada de seu MFP, os usuários podem instalar a solução de HP completa de recurso de Software ou Driver básico da HP após as atualizações de computador para o Windows 7.

Em computadores com o Windows 7 de 64 bits, o HP Digital Imaging monitor não é possível iniciar e o ícone não aparece na área de notificação. Além disso, quando você tenta iniciar o HP Solution Center, você recebe a seguinte mensagem de erro:
Solution Center não pode ser iniciado

Não há nenhum dispositivo encontrado

Para corrigir esses problemas, aplique a atualização descrita neste artigo.

Para impressoras em rede

Impressoras compartilhadas e impressoras de rede detectar os problemas descritos para impressoras locais. Os problemas ocorrem quando você se conectar a impressoras em um computador local que tenha HP Solution Center instalado e, em seguida, atualizar o computador para o Windows 7.
  • Se MFP HP está fisicamente conectado ao e compartilhado a partir de um computador que não está executando o Windows 7 e outros computadores estão conectados à impressora, somente o Windows 7 computadores atualizar do Vista e que tem a solução HP completa de recurso de Software ou Driver básico da HP instalado antes de atualizar para o Windows 7 são afetados.
  • Se MFP HP está fisicamente conectado ao e compartilhado a partir de um computador com Windows 7 que atualizações do Windows Vista e que tem a solução HP completa de recurso de Software ou Driver básico da HP instalado antes de atualizar para o Windows 7, todos os computadores que estão conectados à impressora compartilhada são afetados.
Impressoras em rede podem enfrentar os seguintes sintomas adicionais:
  • Impressão funciona de aplicativos, mas nenhuma funcionalidade HP Solution Center (por exemplo, verificando o status de tinta) pode se comunicar com a impressora.
  • A varredura não funciona em todos os porque ele usa os serviços da HP especiais para a digitalização.
Para corrigir esses problemas, aplique a atualização descrita neste artigo. Além disso, baixe e instale o software do dispositivo HP apropriado para o Windows 7 do http://www.HP.com.

Causa

Esse problema ocorre porque necessário bibliotecas não são migradas do Windows Vista para Windows 7. Sem as bibliotecas necessárias, o software não pode se comunicar com o dispositivo multifuncional. Tentativas de desinstalar ou reinstalar o software HP não resolverem o problema.

Resolução

Windows Update

Uma atualização está disponível no site Windows Update. Esta atualização substitui alguns arquivos ausentes e registros no computador do usuário para corrigir um cenário de impressora quebrado para HP. Para obter a atualização, siga estas etapas:
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    Iniciar btton
    , clique em Painel de controlee, em seguida, clique em Sistema e segurança.
  2. Em Windows Update, clique em Verificar se há atualizações.

Observação Durante a instalação, a atualização não cria uma entrada no Atualizações instaladas seção. Isso é para evitar desinstala não intencionais.

Importante Esta é uma versão somente de atualização do Microsoft Windows. O autônomo está disponível da HP.

Atualização da HP

HP também fez essa atualização disponível no site de suporte da HP no seguinte link:
http://h10025.www1.HP.com/ewfrf/wc/softwareDownloadIndex?softwareitem=MP-77751-1&CC=US&DLC=en&LC=en
Siga as instruções nesse site para baixar e instalar a atualização.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informação

Desinstalar a atualização

Para desinstalar a atualização, você precisa executar um comando de desinstalação no prompt de comando. Para desinstalar a atualização, siga estas etapas:
Observação Esta atualização de desinstalação ou a restauração do sistema para uma data anterior reverte para o problema descrito na seção "Sintomas". Para resolver o problema, a atualização deve ser reinstalado.
  1. Inicie um prompt de comando elevado. Para fazer isso, siga estes passos:
    1. Clique em Iniciar
      Reduzir esta imagemExpandir esta imagem
      Iniciar btton
      , tipo cmd no Iniciar pesquisa caixa, com o botão direito cmd.exe no Programas e, em seguida, clique Executar como administrador.
      Observação Se você for solicitado uma senha de administrador ou confirmação, digite a senha ou forneça a confirmação.
  2. Digite o comando que está associado com seu sistema operacional e, em seguida, pressione ENTER.
    • Para sistemas de operacionais do Windows de 32 bits, digite o seguinte e pressione ENTER:
      msiexec /Uninstall {859D40CF-8491-44AD-8FA8-7389CB418C64}
    • Para sistemas de operacionais do Windows de 64 bits, digite o seguinte e pressione ENTER:
      msiexec /Uninstall {9301985B-D116-4A93-A93D-94580084FF86}
  3. Saia do prompt de comando quando a desinstalação for concluída.
Observação Para ver se seu computador está executando uma versão de 32 bits ou 64 bits do Windows, execute estas etapas:
  1. Clique em Iniciar
    Reduzir esta imagemExpandir esta imagem
    Iniciar btton
    , clique em Painel de controlee, em seguida, clique em Sistema e segurança.
  2. Em Sistema, você pode exibir o tipo de sistema.

AINDA PRECISA DE AJUDA?

Se este artigo não responder sua pergunta, clique neste botão para representar sua pergunta para outros membros da comunidade no Microsoft Community:
Faça uma pergunta



Se você gostaria de ver respostas para questões relacionadas, clique nos seguintes links para exibir tópicos no Communityforum da Microsoft:
As informações e a solução contidas neste documento representam a visão atual da Microsoft Corporation sobre essas questões na data da publicação. Essa solução está disponível através da Microsoft ou por meio de um provedor de terceiros. A Microsoft não recomenda especificamente qualquer outro fornecedor ou solução de terceiros que possam ser descritos neste artigo. Também pode haver outros provedores de terceiros ou soluções de terceiros que este artigo não descrever. Como a Microsoft deve reagir às mudanças nas condições do mercado, essas informações não devem ser interpretadas como um compromisso pela Microsoft. A Microsoft não garante ou endossa a precisão de qualquer informação ou solução apresentada pela Microsoft ou por qualquer fornecedor de terceiros mencionado.

A Microsoft não oferece garantias e exclui todas as representações, garantias e condições expressas, implícitas ou ESTATUTÁRIAS. Esses incluem mas não estão limitados a representações, garantias ou condições de título, não infração, condições satisfatórias, comercialização e adequação a uma finalidade específica, relacionados a qualquer serviço, solução, produto, ou outros materiais ou informações. Em nenhuma hipótese Microsoft poderão ser responsabilizado por qualquer solução de terceiros mencionadas neste artigo.

Propriedades

Artigo: 975891 - Última revisão: quinta-feira, 31 de Janeiro de 2013 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Windows 7 Service Pack 1
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
Palavras-chave: 
kbgraphxlink kbexpertiseinter atdownload kbtshoot kbsurveynew kbprb kbmt KB975891 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 975891

Submeter comentários