Article ID: 977867 - Last Review: May 16, 2010 - Revision: 2.0

The Import Organization Wizard takes a long time to import an organization in Microsoft Dynamics CRM 4.0

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SYMPTOMS

You try to use Deployment Manager to import an organization to Microsoft Dynamics CRM 4.0. However, the Import Organization Wizard takes a long time to import the organization.

CAUSE

This problem occurs because there are many system user references that must be updated.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
This problem is fixed in the latest cumulative update rollup for Microsoft Dynamics CRM 4.0.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
949256  (http://support.microsoft.com/kb/949256/ ) Microsoft Dynamics CRM 4.0 updates and hotfixes

After you install this hotfix, you must add the OptimizeOrgImport REG_DWORD registry entry on the Microsoft Dynamics CRM 4.0 server. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
  3. Right-click MSCRM, point to New, and then click DWORD Value.
  4. Name this DWORD value as "OptimizeOrgImport."
  5. Right-click OptimizeOrgImport, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. On the File menu, click Exit.
Note If you want to disable this hotfix, set the value of the OptimizeOrgImport registry entry to 0.

MORE INFORMATION

When you use the registry entry
OptimizeOrgImport
and have the value of this entry set to 1, you cannot import the same organization database more than one time. If you want to import the same organization database more than one time, you must do one of the following things:
  • Set OptimizeOrgImport = 0 and use the normal import process.
  • Delete the organization, and then import the organization again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

APPLIES TO
  • Microsoft Dynamics CRM 4.0
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