Applies ToWindows Vista Windows 7 Windows Server 2008 R2 Windows Server 2008

Symptoms

Consider the following scenario:

  • You start TS Licensing Manager (Licmgr.exe) on a computer that is running Windows Server 2008. Or, you start Remote Desktop License Manager (Licmgr.exe) on a computer that is running Windows Server 2008 R2.

  • You try to install a volume license for one of the following licenses:

    • Select License

    • Enterprise Agreement

    • Campus Agreement

    • School Agreement

    • Service Provider License Agreement

    • Other Agreement

In this scenario, you cannot enter an agreement number that is more than seven digits.Note The issue also occurs if you install terminal licenses by the commands that are provided by Windows Management Instrument (WMI) or by Windows PowerShell.

Cause

This issue occurs because Remote Desktop Licensing Manager, Terminal Services Licensing Manager, WMI, and Windows PowerShell incorrectly restrict the agreement numbers for volume licenses to only seven digits.

Resolution

This hotfix also removes the check on authorization numbers and license numbers for open licenses.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.0.600 1. 22xxx

    Windows Server 2008

    SP1

    LDR

    6.0.600 2. 22xxx

    Windows Server 2008

    SP2

    LDR

  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Licmgr.exe

6.0.6001.22608

357,888

19-Jan-2010

19:57

x86

Lrwizdll.dll

6.0.6001.22608

509,440

19-Jan-2010

22:01

x86

Licmgr.exe

6.0.6002.22314

357,888

19-Jan-2010

19:51

x86

Lrwizdll.dll

6.0.6002.22314

509,440

19-Jan-2010

21:59

x86

For all supported x64-based versions of Windows Server 2008

File name

File version

File size

Date

Time

Platform

Licmgr.exe

6.0.6001.22608

405,504

19-Jan-2010

20:23

x64

Lrwizdll.dll

6.0.6001.22608

577,536

19-Jan-2010

22:24

x64

Licmgr.exe

6.0.6002.22314

405,504

19-Jan-2010

20:15

x64

Lrwizdll.dll

6.0.6002.22314

577,536

19-Jan-2010

22:03

x64

Windows Server 2008 R2 file information note
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Licmgr.exe

6.1.7600.16385

410,624

14-Jul-2009

01:39

x64

Lrwizdll.dll

6.1.7600.20621

585,728

19-Jan-2010

10:28

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Licmgr.exe.mui

6.1.7600.16385

66,560

14-Jul-2009

02:26

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

150,528

19-Jan-2010

08:54

Not applicable

Licmgr.exe.mui

6.1.7600.16385

56,320

14-Jul-2009

01:38

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

134,656

19-Jan-2010

08:53

Not applicable

Licmgr.exe.mui

6.1.7600.16385

72,192

14-Jul-2009

02:25

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

162,304

19-Jan-2010

08:46

Not applicable

Licmgr.exe.mui

6.1.7600.16385

40,448

14-Jul-2009

04:37

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

97,280

19-Jan-2010

09:28

Not applicable

Licmgr.exe.mui

6.1.7600.16385

37,888

14-Jul-2009

04:36

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

90,112

19-Jan-2010

09:28

Not applicable

Licmgr.exe.mui

6.1.7600.16385

29,696

14-Jul-2009

04:12

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

74,240

19-Jan-2010

09:21

Not applicable

Licmgr.exe.mui

6.1.7600.16385

30,720

14-Jul-2009

04:35

Not applicable

Lrwizdll.dll.mui

6.1.7600.20621

75,776

19-Jan-2010

09:28

Not applicable

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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