Stop error message when there is a request to allocate a large amount of contiguous physical memory in Windows Server 2008 R2 or Windows 7: "Stop error code 0x000000A (IRQL_NOT_LESS_OR_EQUAL)"

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Article ID: 979903 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows Server 2008 R2 or Windows 7, you receive a Stop error message that resembles the following:
Stop 0x0000000A (parameter1, parameter2, parameter3, parameter4)
IRQL_NOT_LESS_OR_EQUAL


Notes
  • The parameters in the Stop error message vary, depending on the configuration of the computer and on the issue type.
  • Not all "0x0000000A" Stop errors are caused by this problem.
This issue may occur when there is a request to the system to allocate a large amount of contiguous physical memory.

For example, the issue occurs when there is a request to the system to allocate several gigabytes of contiguous physical memory to a virtual machine.

CAUSE

Memory Manager scans the Page Frame Number (PFN) database to find contiguous memory. Memory Manager scans the database by moving from a higher PFN to a lower PFN. If Memory Manager does not find a suitable piece of contiguous memory while it is moving from the higher PFN to the lower PFN, it reaches the lower PFN. However, Memory Manager does not handle the lower PFN boundary correctly. This causes the system to access an invalid memory address. Therefore, you receive this Stop error message.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2 on the computer.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntkrnlpa.exe6.1.7600.206423,954,06412-Feb-201020:19Not applicable
Ntoskrnl.exe6.1.7600.206423,899,78412-Feb-201020:19Not applicable
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.206425,485,45612-Feb-201009:55x64
Ntkrnlpa.exe6.1.7600.206423,954,06412-Feb-201020:19Not applicable
Ntoskrnl.exe6.1.7600.206423,899,78412-Feb-201020:19Not applicable
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe6.1.7600.2064211,118,98412-Feb-201008:31IA-64
Ntkrnlpa.exe6.1.7600.206423,954,06412-Feb-201020:19Not applicable
Ntoskrnl.exe6.1.7600.206423,899,78412-Feb-201020:19Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size1,674
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameX86_61dd20b02bd397e747cfbfc7f57b823f_31bf3856ad364e35_6.1.7600.20642_none_4500d9acf02b57a2.manifest
File versionNot applicable
File size697
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20642_none_6cb8972d2e768628.manifest
File versionNot applicable
File size16,151
Date (UTC)12-Feb-2010
Time (UTC)20:50
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_61dd20b02bd397e747cfbfc7f57b823f_31bf3856ad364e35_6.1.7600.20642_none_a11f7530a888c8d8.manifest
File versionNot applicable
File size699
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameAmd64_efd366d7f31ef42cf166d0ce824818f0_31bf3856ad364e35_6.1.7600.20642_none_e4ac2bd4c3ea0608.manifest
File versionNot applicable
File size701
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameAmd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20642_none_c8d732b0e6d3f75e.manifest
File versionNot applicable
File size15,291
Date (UTC)12-Feb-2010
Time (UTC)21:17
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,906
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20642_none_6cb8972d2e768628.manifest
File versionNot applicable
File size16,151
Date (UTC)12-Feb-2010
Time (UTC)20:50
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_61dd20b02bd397e747cfbfc7f57b823f_31bf3856ad364e35_6.1.7600.20642_none_45027da2f029609e.manifest
File versionNot applicable
File size698
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameIa64_aaa08ed3f0f28934256c3180a4cb1fa2_31bf3856ad364e35_6.1.7600.20642_none_f3801388a4f726aa.manifest
File versionNot applicable
File size699
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameIa64_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20642_none_6cba3b232e748f24.manifest
File versionNot applicable
File size15,289
Date (UTC)12-Feb-2010
Time (UTC)21:17
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,684
Date (UTC)12-Feb-2010
Time (UTC)22:30
PlatformNot applicable
File nameX86_microsoft-windows-os-kernel_31bf3856ad364e35_6.1.7600.20642_none_6cb8972d2e768628.manifest
File versionNot applicable
File size16,151
Date (UTC)12-Feb-2010
Time (UTC)20:50
PlatformNot applicable

Properties

Article ID: 979903 - Last Review: January 9, 2012 - Revision: 1.0
APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows HPC Server 2008 R2
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Keywords: 
kbexpertiseadvanced kbexpertiseinter kbsurveynew kbqfe kbautohotfix kbhotfixserver kbfix KB979903

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