Applies ToExchange Server 2010

Symptoms

Consider the following scenario. In a Microsoft Exchange Server 2010 environment, a Database Availability Group (DAG) is created in third-party replication mode. You run the Add-MailboxDatabaseCopy command to add a mailbox database copy to one of the mailbox servers that are in the DAG. However, the command fails when the LogFolderPath parameter of this mailbox database does not point to a fixed drive. Additionally, you receive the following error message:

C:\Windows\system32>Add-MailboxDatabaseCopy -Identity <mailbox database name> -MailboxServer <mailbox server name>

The location for LogFolderPath isn't on a fixed drive. + CategoryInfo : InvalidArgument: (<mailbox database name>) [Add-MailboxDatabaseCopy], ArgumentException + FullyQualifiedErrorId : <ID>,Microsoft.Exchange.Management.SystemConfigurationTasks.AddMailboxDatabaseCopy

Cause

This problem occurs because Exchange Server 2010 performs verification to make sure that the location of the log path is on a fixed drive. However, it is not necessary because a third-party provider sets up the log path in the third-party replication mode scenario.

Resolution

To resolve this problem, install the following update rollup:

982639 Description of Update Rollup 4 for Exchange Server 2010

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

To create a DAG in third-party replication mode, use the New-DatabaseAvailabilityGroup command together with the ThirdPartyReplication parameter. For more information about the New-DatabaseAvailabilityGroup command, visit the following Microsoft Website:

General information about the New-DatabaseAvailabilityGroup command For more information about the Add-MailboxDatabaseCopy command, visit the following Microsoft Website:

General information about the Add-MailboxDatabaseCopy command

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.