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Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

Consider the following scenario:

  • You have a Windows Server 2008 R2-based computer that has the Hyper-V role installed.

  • You store a virtual hard disk (VHD) file on a non-PNP disk. For example, you store a VHD file on a RAM disk.

  • You perform one of the following operations:

    • You mount or unmount this VHD file.

    • You back up the whole computer.

In this scenario, you receive the following Stop error message:

0x000000CA (parameter1, parameter2, parameter3, parameter4) PNP_DETECTED_FATAL_ERROR

Note

  • The parameters in this error message vary, depending on the configuration of the computer.

  • Not all "0x000000CA" errors are caused by this problem.

Cause

When the PNP manager sends a power relation query to the miniport driver of the VHD, the VHD miniport driver returns an incorrect physical device object (PDO). When the invalid PDO is accessed, you receive the Stop error message that is mentioned in the "Symptoms" section.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 on your computer. Additionally, you must have the Hyper-V role installed on your computer.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Vhdmp.inf

Not Applicable

3,212

12-Mar-2010

00:41

Not Applicable

Vhdmp.sys

6.1.7600.20666

217,480

12-Mar-2010

08:43

x64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_vhdmp.inf_31bf3856ad364e35_6.1.7600.20666_none_032590c7fc5acf8e.manifest

File version

Not applicable

File size

2,079

Date (UTC)

12-Mar-2010

Time (UTC)

09:44

Platform

Not applicable

File name

Update.mum

File version

Not applicable

File size

1,449

Date (UTC)

12-Mar-2010

Time (UTC)

18:28

Platform

Not applicable

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