V systéme Windows 7 alebo Windows Server 2008 R2 dôjde k zlyhaniu funkcie GetTempFileName a vyskytne sa chyba o odmietnutí prístupu

Preklady článku Preklady článku
ID článku: 982613 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Aplikácia v počítači so systémom Windows 7 alebo Windows Server 2008 R2 volá funkciu GetTempFileName, ktorá slúži na vytvorenie dočasného súboru. Funkcia GetTempFileName však zlyhá a načítajú sa prechodné chyby podobné nasledujúcej:
Prístup k ceste bol odmietnutý.
Nemáte prístup k ceste <cesta k súboru>.

PRICINA

Tento problém sa vyskytne vtedy, keď funkcia GetTempFileName nesprávne spracuje duplicitný názov súboru.

Pri pokuse o vytvorenie názvu dočasného súboru funkcia GetTempFileName skontroluje, či neexistuje duplicitný názov súboru. Ak funkcia GetTempFileName nájde duplicitný názov súboru a tento súbor čaká na odstránenie, funkcia GetTempFileName nesprávne spracuje duplicitný názov súboru a dôjde k jej zlyhaniu, pričom sa vyskytne chyba s kódom ERROR_ACCESS_DENIED.

Funkcia sa zvyčajne pokúsi vytvoriť dočasný súbor s iným názvom.

RIESENIE

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená len na opravu problémov, ktoré sú popísané v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Je možné, že táto rýchla oprava bude ďalej testovaná. Ak vám teda tento problém nespôsobuje výrazné problémy, odporúčame, aby ste počkali na ďalšiu aktualizáciu softvéru, ktorá obsahuje túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na prevzatie, na začiatku tohto článku databázy Knowledge Base sa nachádza sekcia, kde ju môžete prevziať. Ak sa táto sekcia nezobrazuje, obráťte sa na služby podpory zákazníkov spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť určité problémy, vytvorte samostatnú servisnú požiadavku. Ďalšie otázky a žiadosti o technickú podporu, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, podliehajú bežným poplatkom za poskytovanie technickej podpory. Úplný zoznam telefónnych čísiel služby podpory zákazníkov spoločnosti Microsoft a informácie o vytvorení samostatnej servisnej požiadavky nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka Vo formulári na prevzatie dostupnej rýchlej opravy sa zobrazujú jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Predpoklady

Neexistujú žiadne požiadavky na predpoklady.

Požiadavka na reštartovanie

Po použití tejto rýchlej opravy je nutné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza žiadnu doteraz vydanú rýchlu opravu.

Informácie o súboroch

Globálna verzia tejto rýchlej opravy inštaluje súbory, ktorých atribúty sú uvedené v nasledujúcich tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené vo formáte UTC (Coordinated Universal Time). Dátumy a časy pre tieto súbory v lokálnom počítači sú zobrazené v miestnom čase a podľa aktuálneho nastavenia funkcie prechodu na letný čas. Dátumy a časy sa okrem toho môžu zmeniť aj pri vykonávaní určitých operácií so súbormi.
Poznámky k informáciám o súboroch v systémoch Windows 7 a Windows Server 2008 R2
Dôležité Rýchle opravy systémov Windows 7 a Windows Server 2008 R2 sa nachádzajú v rovnakých balíkoch. Rýchle opravy na stránke požiadaviek na rýchle opravy sú však uvedené pre oba operačné systémy. Ak chcete požiadať o balík rýchlej opravy, ktorý je určený pre jeden alebo oba operačné systémy, vyberte rýchlu opravu, ktorá sa na stránke nachádza v zozname Windows 7 alebo Windows Server 2008 R2. V jednotlivých článkoch si vždy prečítajte informácie v sekcii „Vzťahuje sa na“, aby ste zistili, pre ktoré operačné systémy je daná rýchla oprava určená.
  • Súbory typu MANIFEST (.manifest) a súbory typu MUM (.mum), ktoré sa inštalujú pre jednotlivé prostredia, sú uvedené samostatne v časti Ďalšie informácie o súboroch pre systémy Windows Server 2008 R2 a Windows 7. Súbory MUM a MANIFEST a priradené súbory katalógu zabezpečenia (.cat) sú mimoriadne dôležité na zachovanie stavu aktualizovanej súčasti. Súbory katalógov zabezpečenia, pre ktoré nie sú uvedené atribúty, sú podpísané digitálnym podpisom spoločnosti Microsoft.
Pre všetky podporované verzie systému Windows 7 s procesorom typu x86
Zbaliť túto tabuľkuRozbaliť túto tabuľku
File nameFile versionFile sizeDateTimePlatform
Kernelbase.dll6.1.7600.20693288,25616-Apr-201007:20x86
Pre všetky podporované verzie systému Windows 7 a systému Windows Server 2008 R2 s procesorom typu x64
Zbaliť túto tabuľkuRozbaliť túto tabuľku
File nameFile versionFile sizeDateTimePlatform
Kernelbase.dll6.1.7600.20693420,35216-Apr-201007:29x64
Kernelbase.dll6.1.7600.20693269,82416-Apr-201007:18x86
Pre všetky podporované verzie systému Windows Server 2008 R2 s procesorom typu IA-64
Zbaliť túto tabuľkuRozbaliť túto tabuľku
File nameFile versionFile sizeDateTimePlatform
Kernelbase.dll6.1.7600.20693717,82416-Apr-201005:59IA-64
Kernelbase.dll6.1.7600.20693269,82416-Apr-201007:18x86

STAV

Spoločnosť Microsoft potvrdila, že ide o problém, ktorý sa týka produktov spoločnosti Microsoft uvedených v časti „Vzťahuje sa na“.

DALSIE INFORMACIE

Ďalšie informácie o funkcii GetTempFileName nájdete na nasledujúcej webovej lokalite MSDN (Microsoft Developer Network):
Všeobecné informácie o funkcii GetTempFileName
Ďalšie informácie o hodnotách NTSTATUS nájdete na nasledujúcej webovej lokalite MSDN:
Všeobecné informácie o hodnotách NTSTATUS
Ďalšie informácie o terminológii z oblasti softvérových aktualizácií nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledujúce číslo:
824684 Popis štandardnej terminológie používanej v popisoch aktualizácií softvéru od spoločnosti Microsoft

Ďalšie informácie o súboroch

Ďalšie informácie o súboroch pre systémy Windows 7 a Windows Server 2008 R2

Ďalšie súbory pre všetky podporované verzie systému Windows 7 s procesorom typu x86
Zbaliť túto tabuľkuRozbaliť túto tabuľku
File nameUpdate.mum
File versionNot applicable
File size1,674
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameX86_566758896d090f85fc8cb5f95c849a86_31bf3856ad364e35_6.1.7600.20693_none_211a4e5218931dcf.manifest
File versionNot applicable
File size698
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameX86_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_27559e8e2f0f2966.manifest
File versionNot applicable
File size2,734
Date (UTC)16-Apr-2010
Time (UTC)07:56
PlatformNot applicable
Ďalšie súbory pre všetky podporované verzie systému Windows 7 a systému Windows Server 2008 R2 s procesorom typu x64
Zbaliť túto tabuľkuRozbaliť túto tabuľku
File nameAmd64_2194916ab24431d6bfd9fcb71de794de_31bf3856ad364e35_6.1.7600.20693_none_f1446242783acb06.manifest
File versionNot applicable
File size702
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameAmd64_e30a797d077054280de565e75a8a3ce6_31bf3856ad364e35_6.1.7600.20693_none_c448767cdfc8c3cb.manifest
File versionNot applicable
File size702
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameAmd64_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_83743a11e76c9a9c.manifest
File versionNot applicable
File size2,738
Date (UTC)16-Apr-2010
Time (UTC)08:50
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,328
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameWow64_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_8dc8e4641bcd5c97.manifest
File versionNot applicable
File size2,746
Date (UTC)16-Apr-2010
Time (UTC)07:50
PlatformNot applicable
Ďalšie súbory pre všetky podporované verzie systému Windows Server 2008 R2 s procesorom typu IA-64
Zbaliť túto tabuľkuRozbaliť túto tabuľku
File nameIa64_aa7e5d6fa743c1b1b31a1f9acbe9f961_31bf3856ad364e35_6.1.7600.20693_none_237f9d709bce10d3.manifest
File versionNot applicable
File size700
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameIa64_e30a797d077054280de565e75a8a3ce6_31bf3856ad364e35_6.1.7600.20693_none_682b7eef27695b91.manifest
File versionNot applicable
File size701
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameIa64_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_275742842f0d3262.manifest
File versionNot applicable
File size2,736
Date (UTC)16-Apr-2010
Time (UTC)08:50
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,684
Date (UTC)16-Apr-2010
Time (UTC)10:25
PlatformNot applicable
File nameWow64_microsoft-windows-kernelbase_31bf3856ad364e35_6.1.7600.20693_none_8dc8e4641bcd5c97.manifest
File versionNot applicable
File size2,746
Date (UTC)16-Apr-2010
Time (UTC)07:50
PlatformNot applicable

Vlastnosti

ID článku: 982613 - Posledná kontrola: 10. októbra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Kľúčové slová: 
kbexpertiseinter kbexpertiseadvanced kbqfe kbhotfixserver kbfix kbsurveynew kbautohotfix KB982613

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com