증상
다음 시나리오를 고려하세요.
- 컴퓨터에서 Windows 7 또는 Windows Server 2008 R2를 실행하고 있습니다.
- 컴퓨터가 WCF(Windows Communication Foundation) 서비스를 실행하고 있고 이 서비스가 IIS(인터넷 정보 서비스)에서 호스팅됩니다. 이 서비스는 HTTP 또는 HTTPS 프로토콜을 사용하고 Windows 인증을 사용합니다.
- WCF용 Microsoft .NET Framework 3.0 서비스 팩 2 또는 .NET Framework 3.5 서비스 팩 1 업데이트를 설치합니다. 예를 들어 보안 업데이트 2756920를 설치합니다.
이 시나리오에서는 요청된 페이지에 다음과 유사한 예외 오류 메시지가 표시될 수 있습니다.
참고
'/SecurtyTokenServiceApplication' 응용 프로그램의 서버 오류
메서드를 찾을 수 없음: 'System.String
System.ServiceModel.Ativation.iis7helper.extendedprotectiondotlessspnnotenabledthrowhelper(system.object)'
예를 들어 Microsoft SharePoint 2010 웹 사이트로 이동할 때 오류 메시지가 표시될 수 있습니다.
이 문제가 발생하면 서버의 이벤트 로그에 다음과 같은 오류 메시지가 나타날 수도 있습니다.
참고
WebHost에서 요청을 처리하지 못했습니다.
보낸 사람 정보: System.ServiceModel.ServiceHostingEnvironment+HostingManager/17653682
예외: System.ServiceModel.ServiceActivationException: 컴파일 중 예외로 인해 '/SecurityTokenServiceApplication/securitytoken.svc' 서비스를 활성화할 수 없습니다.
예외 메시지는 다음과 같습니다. 메서드를 찾을 수 없음: 'System.String System.ServiceModel.Activation.Iis7Helper.ExtendedProtectionDotlessSpnNotEnabledThrowHelper(System.Object)'.. --->
System.MissingMethodException: 메서드를 찾을 수 없음: 'System.String System.ServiceModel.Activation.Iis7Helper.ExtendedProtectionDotlessSpnNotEnabledThrowHelper(System.Object)'.
위치: System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.WebConfigurationManagerWrapper.BuildExtendedProtectionPolicy(ExtendedProtectionTokenChecking tokenChecking, ExtendedProtectionFlags flags, List'1 spnList)
위치: System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.WebConfigurationManagerWrapper.GetExtendedProtectionPolicy(ConfigurationElement 요소)
위치: System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.ProcessWindowsAuthentication(String siteName, String virtualPath, HostedServiceTransportSettings& transportSettings)
원인
이 문제는 컴퓨터에 System.ServiceModel.dll만 포함하고 System.ServiceModel.WasHosting.dll는 포함하지 않는 일부 핫픽스가 설치되어 있을 수 있기 때문에 발생합니다. 이러한 파일만 포함하는 것으로 알려진 핫픽스 목록은 "추가 정보" 절을 참조하십시오.
이 문제로 인해 최신 업데이트는 두 파일의 동일한 버전을 설치할 수 없습니다. 이렇게 하면 두 파일 간의 종속성이 노출됩니다. 그러면 앞서 언급한 예외가 발생합니다. 이 문제는 이전에 릴리스된 핫픽스의 문제로 인해 발생하며 특별히 새 업데이트로 인해 발생한 것이 아닙니다. 새 업데이트는 문제를 표면화시키는 것일 뿐입니다.
해결 방법
이 문제를 해결하려면 System.ServiceModel.dll과 System.ServiceModel.WasHosting.dll 버전이 동기화되어 있는지 확인합니다.
이 문제를 resolve하려면 업데이트 [2637518](/kb/2637518semblies.
[2637518](/kb/2637518o 업데이트는 이 문서에 설명된 문제만 수정하는 것이 좋습니다. 이러한특정문제가발생하는시스템에만이핫픽스를적용하십시오.
Microsoft 다운로드 센터에서 이 핫픽스를 다운로드하려면 다음 Microsoft 다운로드 센터 웹 페이지로 이동하십시오.
http://go.microsoft.com/fwlink/?LinkID=242859 참고 이 문제가 이미 발생 중인 경우 업데이트 [2637518](/kb/2637518issue to surface.
다시 시작 요구 사항
이 업데이트를 적용한 후 컴퓨터를 다시 시작해야 할 수 있습니다.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.
추가 정보
다음 핫픽스가 Windows 7 또는 Windows Server 2008 R2 RTM을 실행하는 컴퓨터에 설치되어 있고 WCF용 새 .NET Framework 3.5 SP1 업데이트가 설치되지 않은 경우 이 문제가 발생할 수 있습니다. 자세한 내용을 확인하려면 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
976462 the.NET Framework 3.5 서비스 팩 1의 핫픽스는 Microsoft Office SharePoint Server 2010의 필수 구성 요소로 Windows 7 및 Windows Server 2008 R2에서 사용할 수 있습니다.
977420 Windows 7 및 Windows Server 2008 R2용 .NET Framework 3.5 SP1의 Windows Communication Foundation에서 문제를 해결하기 위한 핫픽스 롤업 사용 가능
.NET Framework 3.5 SP1 또는 .NET Framework 4에서 NLB와 함께 컴퓨터가 호스팅하는 982867 WCF 서비스가 실패함