O suporte para Windows Vista sem service packs instalados foi encerrado em 13 de abril de 2010. Para continuar recebendo atualizações de segurança do Windows, verifique se o Windows Vista com Service Pack 2 (SP2) está sendo executado. Para obter mais informações, consulte esta página da Microsoft na Web: Não haverá mais suporte para algumas versões do Windows
Sintomas
Após a instalação de um dispositivo ou a atualização de um driver do dispositivo em um computador que esteja executando o Windows Vista ou Windows 7, o sistema operacional poderá não ser iniciado.
Motivo
Esse problema poderá ocorrer se uma das seguintes condições for verdadeira:
-
O novo dispositivo ou o driver causa conflitos com outros dispositivos instalados no computador.
-
Ocorre um problema específico de hardware.
-
O driver instalado está danificado.
Resolução
Para solucionar esse problema, use as seguintes etapas de solução de problemas para determinar a causa exata e tomar as medidas necessárias.
Inicie o Windows Vista ou o Windows 7
-
Se você instalou o novo dispositivo, remova o dispositivo e tente iniciar o computador. Se o sistema operacional não for iniciado, vá para a etapa 2. Se o sistema operacional iniciar, vá para a seção "Resolver a causa do problema de inicialização" deste artigo.
-
Inicie o computador e pressione a tecla F8. No menu
Na tela Opções de Inicialização Avançadas, selecione Última Configuração Válida e pressione ENTER. Se o sistema operacional não for iniciado, vá para a etapa 3. Se o sistema operacional iniciar, vá para a seção "Resolver a causa do problema de inicialização" deste artigo. -
Inicie o computador e pressione a tecla F8. No menu
Na tela Opções de Inicialização Avançadas, selecione Modo de Segurança e pressione ENTER. Se o sistema operacional iniciar em modo de segurança, vá para a seção "Resolver a causa do problema de inicialização" deste artigo. Se você não conseguir iniciar o sistema operacional em modo de segurança, vá para a seção "Usar o Ambiente de Recuperação do Windows para reparar o Windows Vista ou Windows 7" deste artigo.
Usar o Ambiente de Recuperação do Windows para reparar o Windows Vista ou Windows 7
Importante Este método, seção ou tarefa contém etapas que informam como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para ter mais proteção, faça um backup do Registro antes de modificá-lo. Dessa forma, se ocorrer algum problema, você poderá restaurar o Registro. Para obter mais informações sobre como fazer backup e restaurar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:
322756 Como fazer o backup e a restauração do Registro no Windows
Para usar o Ambiente de Recuperação do Windows, é necessário ter o disco de instalação do Windows Vista ou do Windows 7. Para iniciar o Ambiente de Recuperação do Windows, siga estas etapas:
-
Coloque o disco de instalação na unidade de disco e inicie o computador.
-
Pressione uma tecla quando solicitado.
-
Selecione um idioma, uma hora, uma moeda e um teclado ou outro método de entrada e clique em Avançar.
-
Clique em Reparar o computador.
-
Na caixa de diálogo Opções de Recuperação do Sistema, clique no sistema operacional que você deseja reparar e clique em
Avançar.
Use as ferramentas no Ambiente de Recuperação do Windows para reparar o Windows Vista ou Windows 7. Para fazer isto, execute as seguintes etapas:
-
Se o computador não iniciar em modo de segurança, clique em
Reparo de Inicialização na caixa de diálogo Opções de Recuperação do Sistema para corrigir alguns problemas que podem impedir a inicialização correta do sistema operacional. Se a ferramenta Reparo do Sistema não diagnosticar ou reparar o problema, vá para a etapa 2. Se o Windows Vista ou Windows 7 iniciar, vá para a seção "Resolver a causa do problema de inicialização".
Para obter mais informações sobre como usar a ferramenta Reparo de Inicialização, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:925810 Ocorre um erro STOP ou o computador para de responder ao tentar iniciar o Windows Vista ou Windows 7
-
Na caixa de diálogo Opções de Recuperação do Sistema, clique em Restauração do Sistema até o ponto de restauração criado ao instalar o programa ou driver. Se você não conseguir usar a ferramenta Restauração do Sistema para iniciar o computador, vá para a etapa 3.
-
Use a opção Prompt de Comando no Ambiente de Recuperação do Windows para desabilitar o driver que impede a inicialização do sistema operacional. Para fazer isto, execute as seguintes etapas:
-
Na caixa de diálogo Opções de Recuperação do Sistema, clique em Prompt de Comando.
-
Digite os seguintes comandos. Pressione ENTER após digitar cada comando.
cd \Windows\INF
notepad setupapi.app.log -
Observe a data no início de cada seção de instalação do novo dispositivo ou driver. Use essas datas para identificar o último driver instalado.
-
Depois de identificar o último driver instalado, verifique se ele é necessário para iniciar o computador. Para fazer isso, leia as informações na seção do arquivo Setupapi.app.log que descreve esse driver. Se o driver estiver associado ao controlador de disco ou chipset, ou se ele for fornecido pelo sistema operacional, procure o nome do driver e o sintoma do problema no seguinte site da Microsoft:
http://www.microsoft.com Verifique se o driver pode ser desabilitado antes de continuar. Se o último driver instalado não for necessário para iniciar o computador, vá para a etapa E.
-
No prompt de comando, digite
regedit e clique em OK. -
Clique em HKEY_LOCAL_MACHINE e em Carregar Hive no menu Arquivo.
-
Localize e clique no arquivo
C:\Windows\System32\Config\System e depois em
Abrir. -
Na caixa de diálogo Carregar Hive, digite
Offline e, em seguida, clique em OK. -
Expanda Sistema e clique em
Selecionar. -
No painel à direita, localize Atual e anote o valor da coluna Dados.
-
Expanda
ControlSet00x e depois expanda
Serviços. x é o valor da coluna
Dados que você observou na etapa J. -
Localize a subchave que corresponde ao último driver instalado. Se não conseguir encontrar uma equivalência, clique em
Serviços, clique em Encontrar no menu
Editar, digite o nome do driver na caixa Encontrar qual e, em seguida, clique em Encontrar próximo. -
Clique na subchave que possui o nome do driver.
-
No painel à direita, clique com o botão direito do mouse em Iniciar e clique em Modificar.
-
Na caixa Dados do valor, digite
4 e clique em OK. Essa etapa impede a inicialização do driver. -
Localize e clique na seguinte subchave do Registro:
HKEY_LOCAL_MACHINE\Offline
-
No menu Arquivo, clique em Descarregar Hive e, em seguida, clique em Sim na caixa de diálogo Confirmar Descarregamento de Hive.
-
Saia do Editor de Registro.
-
Reinicie o computador.
-
Se o sistema operacional não iniciar, inicie o Ambiente de Recuperação do Windows e repita a etapa A até S. Pode ser necessário repetir essas etapas até que todos os drivers instalados desde a última inicialização bem sucedida sejam desabilitados.
-
-
Quando você conseguir iniciar o sistema operacional, entre em contato com o fabricante do dispositivo ou do driver para obter informações sobre problemas de compatibilidade ou atualizações que podem estar disponíveis.
Resolver a causa do problema de inicialização
-
Abra o Gerenciador de Dispositivos. Para fazer isso, clique no botão
Iniciar , digite
Gerenciador de Dispositivos na caixa Iniciar Pesquisa e clique em Gerenciador de Dispositivos na lista Programas. -
Se você atualizou o driver de um dispositivo, clique com o botão direito do mouse sobre o dispositivo no Gerenciador de Dispositivos, clique em Propriedades e em
Reverter Driver na guia Driver. -
Se você instalou um novo dispositivo, clique com o botão direito do mouse sobre o dispositivo no Gerenciador de Dispositivos e, em seguida, clique em Desinstalar.
-
Se você instalou um programa que inclui o novo driver, siga estas etapas:
-
Clique em Iniciar , digite
appwiz.cpl na caixa Iniciar Pesquisa e clique em appwiz.cpl na lista Programas. -
Clique no nome do programa instalado e clique em Desinstalar/Alterar.
Se sua permissão for solicitada para continuar, clique em
Continuar. -
Quando você receber uma mensagem "Deseja continuar", clique em Sim.
-
-
Reinicie o Windows Vista ou o Windows 7.