فيما يلي بعض مهام قاعدة البيانات الأساسية التي يمكنك القيام بها لمساعدتك على تعلم كيفية استخدام Microsoft Access 2010.

 

في هذه المقالة

ما هو Access؟

Access 2010 هو أداة تصميم تطبيق قاعدة بيانات ونشرها يمكنك استخدامها لتعقب المعلومات المهمة. يمكنك الاحتفاظ بالبيانات على الكمبيوتر، أو يمكنك النشر إلى ويب— بحيث يمكن للآخرين استخدام قاعدة البيانات مع مستعرض ويب.

يبدأ العديد من الأشخاص باستخدام Access عندما يصبح البرنامج الذي يستخدمونه لتعقب شيء ما تدريجيا أقل ملاءمة للمهمة. على سبيل المثال، افترض أنك أحد مخططي الأحداث، وتريد تعقب كل التفاصيل التي تحتاج إلى إدارتها لجعل الأحداث الخاصة بك ناجحة. إذا كنت تستخدم برنامج معالج كلمات أو جدول بيانات للقيام بذلك، يمكنك بسهولة أن تواجه مشكلة مع البيانات المكررة وغير المتناسقة. يمكنك استخدام برنامج التقويم، ولكن تعقب المعلومات المالية في التقويم ليس مناسبا.

قواعد البيانات العلائقية في Access

قد تحتاج في بعض الأحيان إلى قاعدة بيانات علائقية لتعقب هذه المعلومات، وهي مخزن للبيانات تم فصله إلى مجموعات أصغر من البيانات (تسمى جداول) لإزالة التكرار، ثم إنشاء صلة ببعضها بالاستناد إلى كميات شائعة من المعلومات (تسمى حقول). على سبيل المثال، قد تحتوي قاعدة البيانات العلائقية لتخطيط الأحداث على جدول يتضمن معلومات العميل، جدولا يتضمن معلومات المورد، جدولا يتضمن معلومات الحدث. قد يكون الجدول الذي به معلومات الحدث حقلا للربط بينه جدول العملاء، كما قد يكون هناك حقل للربط بين الجدول المورد. بهذه الطريقة، على سبيل المثال، إذا تم تغيير رقم هاتف المورد، يمكن تغيير المعلومات مرة واحدة في جدول المورد، بدلا من تغييرها في كل حدث يشارك فيه المورد.

Access هو أداة يمكنك استخدامها لتطوير تطبيقات قاعدة البيانات العلائقية التي تساعدك على إدارة المعلومات بسرعة وسهولة. يمكنك إنشاء قاعدة بيانات لمساعدتك على تعقب أي نوع من المعلومات، مثل المخزون أو جهات الاتصال المهنية أو عمليات الأعمال. في الواقع، يتضمن Access قوالب يمكنك استخدامها مباشرة لتعقب مجموعة متنوعة من المعلومات، مما يجعل الأمور سهلة حتى بالنسبة للمبتدئين.

عند فتح Access

عند بدء Access 2010 ، سترى طريقة عرض Microsoft Office Backstage، حيث يمكنك الحصول على معلومات حول قاعدة البيانات الحالية، وإنشاء قاعدة بيانات جديدة، وفتح قاعدة بيانات موجودة، وعرض المحتوى المميز من Office.com.

طريقة عرض Backstage في Access 2010

تحتوي طريقة عرض Backstage أيضا على العديد من الأوامر الأخرى التي يمكنك استخدامها لضبط قواعد البيانات أو الحفاظ عليها أو مشاركتها. تنطبق الأوامر الموجودة في طريقة عرض Backstage بشكل عام على قواعد البيانات بأكملها، وليس على الكائنات الموجودة داخل قاعدة البيانات.

ملاحظة: يمكنك الوصول إلى طريقة عرض Backstage في أي وقت بالنقر فوق علامة التبويب "ملف".

أعلى الصفحة

البحث عن قالب وتطبيقه

يوفر لك Access مجموعة واسعة من القوالب التي يمكنك استخدامها لتسريع عملية إنشاء قاعدة البيانات. القالب هو قاعدة بيانات جاهزة للاستخدام تحتوي على كل الجداول والاستعلامات والنماذج والتقارير اللازمة لأداء مهمة معينة. على سبيل المثال، هناك قوالب يمكن استخدامها لتعقب المشاكل أو إدارة جهات الاتصال أو الاحتفاظ بسجل للمصاريف. وتحتوي بعض القوالب على بضع نماذج سجلات للمساعدة على توضيح كيفية استخدامها. يمكن استخدام قواعد بيانات القوالب كما هي، أو يمكنك تخصيصها لتلائم احتياجاتك بشكل أفضل.

للبحث عن قالب وتطبيقه على قاعدة البيانات، قم بما يلي:

  1. في علامة تبويب ملف، انقر فوق جديد.

  2. ضمن القوالب المتاحة، قم بأحد الإجراءات التالية:

    • لإعادة استخدام قالب استخدمته مؤخرا، انقر فوق "القوالب الأخيرة"، ثم حدد القالب الذي تريده.

    • لاستخدام قالب قمت بتثبيته مسبقا، انقر فوق "القوالب"، ثم حدد القالب الذي تريده.

    • للعثور على قالب على Office.com ، ضمن Office.comقوالب، انقر فوق فئة قالب، وحدد القالب الذي تريده، ثم انقر فوق "تنزيل" لتنزيل القالب من Office .com إلى الكمبيوتر.

      يمكنك أيضا البحث عن قوالب على Office.com من داخل Access. في المربع البحث عن قوالب في Office.com، اكتب مصطلح بحث واحد أو أكثر، ثم انقر فوق زر السهم لبدء البحث.

  3. بشكل اختياري، انقر فوق أيقونة المجلد بجانب المربع "اسم الملف" للاستعراض إلى موقع حيث تريد إنشاء قاعدة البيانات. إذا لم تشير إلى موقع معين، ينشئ Access قاعدة البيانات في الموقع الافتراضي الذي يتم عرضه أسفل المربع "اسم الملف".

  4. انقر فوق إنشاء.

ينشئ Access قاعدة البيانات ويفتحها للاستخدام.

أعلى الصفحة

إنشاء قاعدة بيانات من البداية

إذا كنت تريد مقدمة أكثر عمقا حول المفاهيم المتعلقة باستخدام Access لإنشاء قاعدة بيانات، راجع أساسيات تصميم قاعدة البيانات.

إذا لم يتلاءم أي واحد من القوالب مع احتياجاتك، أو إذا كانت لديك بيانات في برنامج آخر تريد استخدامها في Access، فقد تقرر أنه من الأفضل إنشاء قاعدة بيانات من البداية. في Access 2010، لديك خيار: قاعدة بيانات سطح مكتب قياسية أو قاعدة بيانات ويب.

لمزيد من المعلومات حول قواعد بيانات الويب، راجع المقالة "إنشاء قاعدة بيانات" لمشاركتها على الويب.

لإنشاء قاعدة بيانات جديدة، قم بما يلي:

  1. ابدأ تشغيل Access.

  2. على علامة التبويب "جديد" في طريقة عرض Backstage، انقر فوق قاعدة بيانات فارغة أو قاعدة بيانات ويب فارغة.

    هام: سيحدد الاختيار الذي تحدده هنا الميزات المتوفرة في قاعدة البيانات. لا يمكن نشر قواعد بيانات سطح المكتب على الويب، ولا تدعم قواعد بيانات الويب بعض ميزات سطح المكتب، مثل استعلامات الإجماليات.

  3. على الجانب الأيمن، اكتب اسما لقاعدة البيانات في المربع "اسم الملف".

    لتغيير الموقع الذي تقوم بإنشاء الملف فيه، انقر فوق "استعراض النص البديل" بجانب المربع "اسم الملف"، واستعرض بحثا عن الموقع الجديد وحدده، ثم انقر فوق "موافق".

  4. انقر فوق إنشاء.

    ينشئ Access قاعدة البيانات، ثم يفتح جدولا فارغا (يسمى الجدول1) في طريقة عرض ورقة البيانات.

  5. يضع Access المؤشر في الخلية الفارغة الأولى في العمود "انقر لإضافة" في الجدول الجديد.

    لإضافة بيانات، ابدأ بالكتابة، أو يمكنك لصق البيانات من مصدر آخر، كما هو موضح في المقطع "لصق البيانات من مصدر آخر" في جدول Access،لاحقا في هذه المقالة.

    ملاحظات: 

    • تم تصميم إدخال البيانات في طريقة عرض ورقة البيانات بحيث يتشابه إلى حد كبير مع إدخال البيانات في ورقة عمل Excel. القيد الرئيسي هو أنه يجب إدخال البيانات في صفوف وأعمدة متجاورة، بدءا من الزاوية العلوية اليمنى من ورقة البيانات. يجب ألا تحاول تنسيق البيانات عن طريق بما في ذلك الصفوف أو الأعمدة الفارغة كما تفعل في ورقة عمل Excel، لأن القيام بذلك سيهدر المساحة في الجدول. يحتوي الجدول فقط على بياناتك. سيتم عرض كل العروض التقديمية المرئية في النماذج والتقارير التي تقوم بتصميمها في وقت لاحق.

    • يتم إنشاء بنية الجدول أثناء إدخال البيانات. في أي وقت تضيف فيه عمودا جديدا إلى ورقة البيانات، يتم تعريف حقل جديد في الجدول. يقوم Access نوع البيانات الحقل استنادا إلى نوع البيانات التي تقوم بإدخالها. على سبيل المثال، إذا كان لديك عمود قمت فيه بإدخال قيم التاريخ فقط، سيعمد Access إلى تعيين نوع بيانات هذا الحقل إلى "التاريخ/الوقت". إذا حاولت لاحقا إدخال قيمة غير تاريخ (مثل اسم أو رقم هاتف) في ذلك الحقل، يعرض Access رسالة تعلمك بأن القيمة لا تتطابق مع نوع بيانات العمود. عندما يكون ذلك ممكنا، يجب تخطيط الجدول بحيث يحتوي كل عمود على نوع البيانات نفسه، سواء كان نصا أو تواريخ أو أرقاما أو نوعا آخر. هذا يسهل إنشاء الاستعلامات والنماذج والتقارير التي تحدد البيانات التي تريدها فقط.

إذا كنت لا تريد إدخال البيانات بعد، انقر فوق "إغلاق" صورة الزر.

ملاحظة: سيحذف Access الجدول1 إذا قمت بغلقه دون حفظه.

أعلى الصفحة

فتح قاعدة بيانات Access موجودة

تلميح: لفتح إحدى قواعد البيانات العديدة الأخيرة التي فتحتها بسرعة، على علامة التبويب "ملف"، انقر فوق "الأخيرة"، ثم انقر فوق اسم الملف.

  1. على علامة التبويب ملف، انقر فوق فتح.

  2. انقر فوق اختصار في مربع الحوار "فتح"، أو في المربع "بحث في"، انقر فوق محرك الأقراص أو المجلد الذي يحتوي على قاعدة البيانات التي تريدها.

  3. في قائمة المجلدات، انقر نقرا مزدوجا فوق المجلدات حتى تفتح المجلد الذي يحتوي على قاعدة البيانات.

  4. عندما تعثر على قاعدة البيانات، يمكنك القيام بوا أحد الخطوات التالية:

    • لفتح قاعدة البيانات في الوضع الافتراضي المفتوح، انقر نقرا مزدوجا فوقها.

    • لفتح قاعدة البيانات للوصول المشترك في بيئة متعددة المستخدمين، بحيث يمكنك أنت والمستخدمون الآخرين قراءة قاعدة البيانات والكتابة عليها في الوقت نفسه، انقر فوق "فتح".

    • لفتح قاعدة البيانات للوصول إليها للقراءة فقط، حتى تتمكن من عرضها ولكن لا يمكنك تحريرها، انقر فوق السهم الموجود بجانب الزر "فتح"، ثم انقر فوق "فتح للقراءة فقط".

    • لفتح قاعدة البيانات للوصول الخاص، بحيث لا يمكن لأي شخص آخر فتحها أثناء فتحها، انقر فوق السهم الموجود بجانب الزر "فتح"، ثم انقر فوق "فتح خاص".

    • لفتح قاعدة البيانات للوصول إليها للقراءة فقط، انقر فوق السهم الموجود بجانب الزر "فتح"، ثم انقر فوق "فتح خاص للقراءة فقط" ولا يزال بإمكان المستخدمين الآخرين فتح قاعدة البيانات، ولكن لديهم حق الوصول للقراءة فقط فقط.

في حالة تعذر العثور على قاعدة البيانات المطلوب فتحها    

  1. في مربع الحوار "فتح"، انقر فوق اختصار "جهاز الكمبيوتر" — أو في المربع "البحث في"، انقر فوق "جهاز الكمبيوتر".

  2. في قائمة محركات الأقراص، انقر بزر الماوس الأيمن فوق محرك الأقراص الذي قد يحتوي على قاعدة البيانات ثم انقر فوق البحث.

  3. أدخل معايير البحث، ثم اضغط على ENTER للبحث عن قاعدة البيانات.

  4. إذا تم العثور على قاعدة البيانات، فافتحها بالنقر نقرا مزدوجا فوقها في مربع الحوار "نتائج البحث".

    نظرا لأنه تم بدء البحث من مربع الحوار "فتح"، يجب النقر فوق "إلغاء الأمر" في مربع الحوار هذا قبل فتح قاعدة البيانات.

يمكنك فتح ملف بيانات مباشرة بتنسيق ملف خارجي (مثل dBASE أو Paradox أو Microsoft Exchange أو Excel). يمكنك أيضاً فتح أي مصدر بيانات ODBC مباشرة، مثل Microsoft SQL Server أو Microsoft FoxPro. يتم إنشاء قاعدة بيانات تلقائياً في Access في نفس مجلد ملف البيانات وتتم إضافة ارتباطات لكل جدول في قاعدة البيانات الخارجية.

أعلى الصفحة

بدء استخدام قاعدة البيانات الجديدة

استنادا إلى القالب الذي استخدمته، قد تحتاج إلى القيام بوا واحد أو أكثر مما يلي للبدء في استخدام قاعدة البيانات الجديدة:

  • إذا عرض Access مربع حوار تسجيل الدخول مع قائمة فارغة من المستخدمين، فاستخدم الإجراء التالي للبدء:

    1. انقر فوق مستخدم جديد.

    2. قم بتعبئة نموذج تفاصيل المستخدم.

    3. انقر فوق حفظ وإغلاق.

    4. حدد اسم المستخدم الذي أدخلته للتو، ثم انقر فوق "تسجيل الدخول".

  • إذا عرض Access ورقة بيانات فارغة، يمكنك بدء كتابة البيانات مباشرة في ورقة البيانات هذه، أو النقر فوق أزرار أو علامات تبويب أخرى لاستكشاف قاعدة البيانات.

  • إذا عرض Access صفحة "بدء استخدام"، يمكنك النقر فوق الارتباطات على تلك الصفحة لمعرفة المزيد حول قاعدة البيانات، أو النقر فوق أزرار أو علامات تبويب أخرى لاستكشاف قاعدة البيانات.

  • إذا عرض Access رسالة تحذير أمان في شريط الرسائل، ووثقت بمصدر القالب، انقر فوق "تمكين المحتوى". إذا كانت قاعدة البيانات تتطلب تسجيل الدخول، ستحتاج إلى تسجيل الدخول مرة أخرى.

بالنسبة لقواعد بيانات سطح المكتب والويب، تحتاج أيضا إلى البدء بوا واحدة من هذه الخطوات:

أعلى الصفحة

إضافة جدول

يمكنك إضافة جدول جديد إلى قاعدة بيانات موجودة باستخدام الأدوات الموجودة في المجموعة "جداول" ضمن علامة التبويب "إنشاء".

المجموعة "جداول" ضمن علامة التبويب "إنشاء"

ملاحظة: في قاعدة بيانات ويب، يتوفر الأمر "جدول" فقط في المجموعة "جداول".

بغض النظر عن طريقة العرض التي تبدأ بها، يمكنك دائما التبديل إلى طريقة العرض الأخرى باستخدام أزرار العرض على شريط المعلومات في نافذة Access.

إنشاء جدول فارغ في طريقة عرض ورقة البيانات    في طريقة عرض ورقة البيانات، يمكنك إدخال البيانات على الفور، مع السماح ل Access ببناء بنية الجدول في الكواليس. يتم تعيين أسماء الحقول رقميا (الحقل 1، الحقل 2، وهكذا)، ويعين Access نوع بيانات الحقل، استنادا إلى نوع البيانات التي تقوم بإدخالها.

  1. على علامة التبويب "إنشاء"، في المجموعة "جداول"، انقر فوق "جدول صورة الزر".

  2. ينشئ Access الجدول، ثم يضع المؤشر في الخلية الفارغة الأولى في العمود "انقر للإضافة".

  3. لإضافة بيانات، ابدأ الكتابة في الخلية الفارغة الأولى، أو يمكنك لصق بيانات من مصدر آخر، كما هو موضح لاحقا في هذه المقالة.

    • لإعادة تسمية عمود (حقل)، انقر نقراً مزدوجاً فوق رأس العمود، ثم اكتب الاسم الجديد.

      تلميح: امنح اسما ذا معنى لكل حقل، بحيث يمكنك معرفة ما يحتويه دون الحاجة إلى النظر إلى البيانات.

    • لنقل عمود، حدده بالنقر فوق عنوان العمود الخاص به، ثم اسحبه إلى المكان الذي تريده. يمكنك أيضا تحديد عدة أعمدة متجاورة وسحبها كلها إلى موقع جديد معا.

      لإضافة المزيد من الحقول إلى الجدول، يمكنك بدء الكتابة في العمود "انقر لإضافة" في طريقة عرض "ورقة البيانات"، أو يمكنك إضافة حقول جديدة باستخدام الأوامر الموجودة في المجموعة "إضافة & حذف" ضمن علامة التبويب "حقول".

إنشاء جدول بدءا من طريقة عرض التصميم    في عرض "التصميم"، يجب عليك أولاً إنشاء بنية الجدول الجديد. بعد ذلك، يمكنك إما التبديل إلى طريقة عرض "ورقة البيانات" لإدخال البيانات، أو إدخال البيانات باستخدام طريقة أخرى، مثل نموذج.

لا تتوفر طريقة عرض التصميم للجداول في قاعدة بيانات ويب.

  1. في علامة التبويب إنشاء، في المجموعة جداول، انقر فوق تصميم جدول. صورة الزر

  2. اكتب اسماً لكل حقل في الجدول في العمود اسم الحقل، ثم حدد نوع بيانات من القائمة أنواع البيانات.

  3. يمكنك إدخال معلومات إضافية لكل حقل في عمود الوصف. يتم عرض الوصف الذي تدخله في شريط المعلومات عندما تكون نقطة الإدراج في ذلك الحقل، وتستخدم كنص شريط المعلومات لأي عناصر تحكم تقوم بإدخالها عن طريق سحب الحقل من جزء "قائمة الحقول" إلى نموذج أو تقرير، وبالنسبة لأي عناصر تحكم تم إنشاؤها لذلك الحقل بواسطة معالج النموذج أو معالج التقارير.

  4. وبعد إضافة جميع الحقول، احفظ الجدول:

    • في علامة التبويب ملف، انقر فوق حفظ.

  5. يمكنك بدء إدخال البيانات في الجدول في أي وقت بالتبديل إلى طريقة عرض "ورقة البيانات"، والنقر في الخلية الفارغة الأولى، والكتابة. يمكنك أيضا لصق بيانات من مصدر آخر، كما هو موضح في القسم التالي.

إنشاء جدول استنادا إلى قائمة SharePoint    باستخدام قائمة SharePoint، يمكن استخدام بياناتك من قبل أشخاص ليس لديهم Access. بالإضافة إلى ذلك، يتم تخزين بيانات القائمة على خادم، مما يوفر حماية أفضل بوجه عام من فقدان البيانات مقارنة بالملفات المخزنة على كمبيوتر سطح المكتب. يمكنك إما البدء باستخدام قائمة جديدة، أو يمكنك إنشاء ارتباط إلى قائمة موجودة. يجب أن يكون لديك أذونات كافية على موقع SharePoint حيث تريد إنشاء القائمة؛ قد يختلف ذلك باختلاف الموقع، لذا اتصل بمسؤول SharePoint للحصول على تفاصيل حول خياراتك.

هذه الميزة غير متوفرة في قاعدة بيانات ويب.

  1. على علامة التبويب إنشاء، في المجموعة جداول، انقر فوق قوائم SharePoint.

  2. يمكنك استخدام أحد قوالب القائمة لإنشاء قائمة SharePoint قياسية، مثل جهات الاتصال أو الأحداث.

    يمكنك أيضا اختيار إنشاء قائمة مخصصة أو إنشاء ارتباط إلى قائمة موجودة أو استيرادها. انقر فوق الخيار الذي تريده.

  3. إذا اخترت أي قالب من قوالب القائمة أو أنشأت قائمة مخصصة، يفتح مربع الحوار "إنشاء قائمة جديدة" لإرشادك خلال العملية. إذا اخترت استخدام قائمة موجودة، يفتح مربع الحوار "الحصول على بيانات خارجية" لمساعدتك.

للحصول على مزيد من المعلومات حول الجداول، راجع المقالة مقدمة حول الجداول.

أعلى الصفحة

لصق بيانات من مصدر آخر في جدول Access

إذا كانت بياناتك مخزنة حاليا في برنامج آخر، مثل Excel، يمكنك نسخ البيانات ولصقها في جدول Access. بشكل عام، تعد هذه هي الطريقة الأفضل خاصة وإذا كانت البيانات مقسومة بالفعل إلى أعمدة، كما هو الحال في ورقة عمل Excel. إذا كانت بياناتك في برنامج لمعالجة الكلمات، يجب أولا فصل أعمدة البيانات باستخدام علامات التبويب، أو تحويل البيانات إلى جدول في برنامج معالجة الكلمات، ثم نسخ البيانات. إذا كانت بياناتك تحتاج إلى أي تحرير أو معالجة (على سبيل المثال، فصل الأسماء الكاملة إلى أسماء أولى وأسماء عائلتك)، فقد تحتاج إلى القيام بذلك قبل نسخ البيانات، لا سيما إذا لم تكن ملما باستخدام Access.

عند لصق البيانات في جدول فارغ، يتم تعيين نوع بيانات كل حقل في Access وفقاً لنوع البيانات التي يتم العثور عليه. على سبيل المثال، إذا كان أحد حقول الملصقة لا يحتوي إلا على قيم تواريخ، فسيتم تطبيق نوع البيانات التاريخ/الوقت على ذلك الحقل في Access. وإذا لم يتضمن الحقل الملصق سوى كلمتي "نعم" و"لا"، فسيتم تطبيق نوع البيانات "نعم/لا" على الحقل في Access.

تتم تسمية الحقول في Access بناءً على ما يتم العثور عليه في الصف الأول من البيانات الملصقة. إذا كان الصف الأول من البيانات الملصقة مماثلا لنوع الصفوف التالية، يحدد Access أن الصف الأول هو جزء من البيانات ويعين الحقول أسماء عامة (Field1 و Field2 وما إلى ذلك). إذا لم يكن الصف الأول من البيانات الملصقة مماثلا للصفوف التالية، يستخدم Access الصف الأول لأسماء الحقول، ويستبعد الصف الأول في البيانات الفعلية.

وفي حالة تم تعيين أسماء عامة للحقول في Access، يجب إعادة تسمية الحقول في أسرع وقت ممكن لتجنب حدوث أي إرباك. استخدم الإجراء التالي:

  1. على علامة التبويب "ملف"، انقر فوق "حفظ" لحفظ الجدول.

  2. في طريقة عرض ورقة البيانات، انقر نقرا مزدوجا فوق كل عنوان عمود، ثم اكتب اسما العمود.

  3. احفظ الجدول مرة أخرى.

أعلى الصفحة

الخطوات التالية

يختلف باقي عملية التصميم استنادا إلى أهدافك، ولكنك قد ترغب على الأرجح في إنشاء الاستعلامات والنماذج والتقارير وحدات الماكرو. لا توفر هذه المقالة معلومات حول إنشاء كائنات قاعدة بيانات إضافية.

لمزيد من المعلومات، راجع المقالات التالية:

أعلى الصفحة

استيراد بيانات من جدول بيانات أو برنامج آخر

إذا كنت على دراية ببرامج قاعدة البيانات أو جداول البيانات الأخرى، ربما تكون على دراية بأساسيات كيفية عمل هذه التطبيقات وقواعد البيانات المستخدمة لها. يختلف Access عن العديد من تطبيقات قواعد البيانات الأخرى من خلال السماح لك بإنشاء قواعد بيانات علائقية، كما أنه يختلف أيضا عن معظم برامج جداول البيانات من خلال توفير أدوات لتطوير استعلامات ونماذج والتقارير المعقدة. يوفر Access أيضا العديد من الخيارات للعمل باستخدام برامج قواعد البيانات الأخرى، مثل SQL Server.

استيراد ورقة عمل Excel إلى Access

يبدأ العديد من الأشخاص في استكشاف Access بعد إنشاء قائمة أولا في Excel. Excel هو مكان رائع لبدء قائمة، ولكن مع نمو القائمة، يصبح من الصعب تنظيمها وتحديثها باستمرار. عادة ما يكون نقل القائمة إلى Access الخطوة المنطقية التالية.

يشبه جدول قاعدة البيانات في البنية ورقة العمل، حيث يتم تخزين البيانات في صفوف وأعمدة. ونتيجة لذلك، من السهل عادة استيراد ورقة عمل إلى جدول قاعدة بيانات. يكمن الاختلاف الرئيسي بين تخزين البيانات في ورقة عمل وتخزينها في قاعدة بيانات في كيفية تنظيم البيانات. إن استيراد ورقة العمل بالكامل ك جدول جديد في قاعدة بيانات لن يحل المشاكل المقترنة بتنظيم البيانات وتحديثها، لا سيما إذا كانت ورقة العمل تحتوي على بيانات زائدة. لحل هذه المشاكل، يجب تقسيم بيانات جدول البيانات إلى جداول منفصلة، يحتوي كل جدول منها على بيانات ذات صلة. لمزيد من المعلومات حول كيفية ترتيب البيانات في الجداول، راجع المقالة "أساسيات تصميم قاعدة البيانات".

يتميز Access بمعالج محلل ال جدول، الذي يمكنه مساعدتك لإكمال هذه العملية. بعد استيراد البيانات إلى جدول، يساعدك المعالج على تقسيم الجدول إلى جداول منفصلة، يحتوي كل واحد منها على بيانات غير مكررة في أي من الجداول الأخرى. ينشئ المعالج أيضا العلاقات الضرورية بين الجداول.

أعلى الصفحة

استيراد ورقة عمل Excel ك جدول في قاعدة بيانات جديدة

  1. في علامة التبويب ملف، انقر فوق جديد، ثم انقر فوق قاعدة بيانات فارغة.

  2. اكتب اسما لقاعدة البيانات الجديدة في المربع "اسم الملف"، ثم انقر فوق "إنشاء".

    يتم فتح قاعدة البيانات الجديدة، وينشئ Access جدولا فارغا جديدا، جدول1.

  3. إغلاق الجدول1.

    عند سؤالك عما إذا كنت تريد حفظ التغييرات في تصميم الجدول 1، انقر فوق "لا".

  4. على علامة التبويب "بيانات خارجية"، في المجموعة "استيراد & الارتباط"، انقر فوق Excel. صورة الزر

  5. في مربع الحوار "الحصول على بيانات خارجية"، انقر فوق "استعراض".

  6. استخدم مربع الحوار "فتح ملف" لتحديد موقع الملف.

  7. حدد الملف، ثم انقر فوق فتح.

  8. في مربع الحوار "الحصول على بيانات خارجية"، تأكد من تحديد الخيار "استيراد البيانات المصدر إلى جدول جديد في خيار قاعدة البيانات الحالية".

  9. انقر فوق موافق.

    يبدأ تشغيل "معالج استيراد جدول البيانات"، ويطرح عليك بعض الأسئلة حول بياناتك.

  10. اتبع الإرشادات، بالنقر فوق"التالي" أو "الخلف" للتنقل عبر الصفحات. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

    ملاحظة: يسألك Access عما إذا كنت تريد حفظ تفاصيل عملية الاستيراد التي أكملتها للتو. إذا كنت تعتقد أنك كرر عملية الاستيراد هذه مرة أخرى، انقر فوق "نعم"، ثم أدخل التفاصيل. يمكنك بعد ذلك إعادة إنتاج العملية بسهولة في المستقبل بالنقر فوق "عمليات الاستيراد المحفوظة" في المجموعة "استيراد" ضمن علامة التبويب "بيانات خارجية". إذا كنت لا ترغب في حفظ تفاصيل العملية، فانقر فوق إغلاق.

يستورد Access البيانات إلى جدول جديد، ثم يعرضها ضمن "كافة الجداول" في "جزء التنقل".

أعلى الصفحة

استخدام معالج محلل ال جدول لتنظيم البيانات

بعد استيراد البيانات إلى جدول Access، يمكنك استخدام "معالج محلل ال جدول" لتحديد البيانات المتكرارة بسرعة. بعد ذلك، يوفر المعالج طريقة بسيطة لتنظيم البيانات في جداول منفصلة، بحيث يتم تخزينها بالطريقة الأكثر فعالية. يحافظ Access على الجدول الأصلي كنسخة احتياطية، ثم ينشئ جداول جديدة يمكنك استخدامها كأساس لتطبيق قاعدة البيانات.

  1. افتح قاعدة بيانات Access التي تحتوي على الجدول الذي تريد تحليله.

  2. على علامة التبويب "أدوات قاعدة البيانات"، في المجموعة "تحليل"، انقر فوق "تحليل جدول".

    يبدأ تشغيل "معالج محلل ال جدول".

    تحتوي أول صفحتين من المعالج على برنامج تعليمي قصير ، مكتمل بالأزرار التي يمكنك النقر فوقها للاطلاع على الأمثلة. إذا لم تظهر الصفحات التمهيدية، ولكنك بدلا من ذلك ترى خانة اختيار تسمى إظهار الصفحات التمهيدية؟حدد خانة الاختيار، ثم انقر فوق "الخلف" مرتين للاطلاع على المقدمة. إذا كنت لا تريد الاطلاع على الصفحات التمهيدية مرة أخرى بعد قراءة المقدمة، يمكنك مسح خانة الاختيار "إظهار الصفحات التمهيدية"؟

  3. في الجدول "أي جدول" يحتوي على حقول ذات قيم مكررة في عدة سجلات؟ صفحة، حدد الجدول الذي تريد تحليله، ثم انقر فوق "التالي".

  4. يمكنك السماح المعالج لتقرير الحقول التي يتم الانتقال فيها في الجداول، أو يمكنك اتخاذ هذا القرار بنفسك. إذا كنت تتبع اقتراحات المعالج، لا يزال بإمكانك إجراء تغييرات على تخطيط الجدول في الصفحة التالية من المعالج.

    ملاحظة: إذا سمحت للمعالج باختيار الحقول التي يجب وضعها في الجداول، فقد لا تكون خياراته مناسبة للبيانات دائما، خاصة إذا لم يكن هناك الكثير من البيانات التي يجب العمل عليها. يجب عليك التحقق من نتائج المعالج بعناية. وعلى الجانب الآخر، قد يقترح المعالج مؤسسة أكثر فعالية من تلك التي تفكر فيها، لذا من الجيد على الأقل تجربة قرارات المعالج مرة واحدة. إذا لم عجبك الاقتراحات، فلا يزال بإمكانك إعادة ترتيب الحقول يدويا، كما يمكنك دائما النقر فوق "الخلف" وترتيب كل الحقول بنفسك.

  5. انقر فوق التالي. في هذه الصفحة، يمكنك تحديد الجداول التي تحتوي على الحقول. إذا اخترت السماح للمعالج باختياره، يجب أن ترى جداول متعددة متصلة بواسطة خطوط العلاقات. بخلاف ذلك، ينشئ Access جدولا واحدا فقط يحتوي على كل الحقول. في كلتا الحالتين، يمكنك إجراء تغييرات على هذه الصفحة.

    • يمكنك سحب الحقول من جدول إلى منطقة فارغة من الصفحة لإنشاء جدول جديد يحتوي على تلك الحقول. يطالبك Access باسم جدول.

    • يمكنك سحب الحقول من جدول إلى جدول آخر إذا كنت تعتقد أنه سيتم تخزينها هناك بفعالية أكبر.

    • سيتم منح معظم الجداول حقل "الم ID" أو "الم ID فريد تم إنشاؤه". لمعرفة المزيد حول حقول المعرف، انقر فوق "تلميحات" في الزاوية العلوية اليسرى من المعالج.

    • للتراجع عن تغيير، انقر فوق الزر "تراجع".

    • لإعادة تسمية جدول، انقر نقرا مزدوجا فوق شريط عنوانه، وا اكتب الاسم الجديد، ثم انقر فوق موافق.

  6. بعد ترتيب الحقول بالطريقة التي تريدها، انقر فوق "التالي".

  7. إذا عثر المعالج على سجلات لها قيم متشابهة إلى حد كبير، سيحدد هذه القيم على أنها أخطاء كتابية محتملة وسيقدم شاشة يمكنك فيها تأكيد ما يجب فعله حيالها. قم بالتمرير عبر القائمة للعثور على أي قيم في عمود التصحيح، ثم انقر فوق العنصر المناسب في القائمة المنسدل. حدد (اترك كما هو) حتى لا يقوم المعالج بإجراء أي تغييرات على القيمة. عند الانتهاء، انقر فوق "التالي".

  8. يسألك المعالج ما إذا كنت تريد إنشاء استعلام يشبه جدولك الأصلي. إذا سبق لك إنشاء نماذج والتقارير المستندة إلى الجدول الأصلي، فإن إنشاء استعلام من هذا النوع هو فكرة جيدة. إذا اخترت "نعم"، فنشئ الاستعلام، ويعيد المعالج تسمية الجدول الأصلي عن طريق تعليق "_OLD" لاسم الجدول، ثم تسمية الاستعلام الجديد باستخدام اسم الجدول الأصلي. تستخدم النماذج والتقارير التي كانت تستند إلى الجدول الآن الاستعلام لبياناتها، وهي تستمر في العمل كما كانت من قبل.

  9. انقر فوق إنهاء.

    ينشئ المعالج الجداول الجديدة كما هو محدد، ثم يفتحها. أغلقها عند الانتهاء من فحص النتائج.

أعلى الصفحة

استخدام البيانات من برامج أخرى

يوفر Access 2010 ميزات للعمل باستخدام البيانات المخزنة في برامج أخرى.

إنشاء قاعدة بيانات Access جديدة تربط البيانات بتنسيق ملف آخر    يمكنك استخدام Access لفتح ملف بتنسيق ملف آخر مثل نص أو dBASE أو جدول بيانات. ينشئ Access تلقائيا قاعدة بيانات Access ويربط الملف لك.

  1. ابدأ تشغيل Access.

  2. على علامة التبويب ملف، انقر فوق فتح.

  3. في مربع الحوار "فتح"، انقر فوق نوع الملف الذي تريد فتحه في القائمة. إذا لم تكن متأكدا من نوع الملف، انقر فوق "كافة الملفات" (*.*).

  4. إذا لزم الأمر، استعرض بحثا عن المجلد الذي يحتوي على الملف الذي تريد فتحه. عندما تعثر على الملف، انقر نقرا مزدوجا فوقه لفتحه.

  5. اتبع التعليمات الواردة في المعالج. في صفحة المعالج الأخيرة، انقر فوق إنهاء.

استيراد البيانات أو ربطها بقاعدة بيانات Access موجودة    يمكنك إما استيراد بيانات من مصادر وبرامج أخرى إلى جداول Access بحيث يتم احتواء البيانات في ملف Access، أو يمكنك إنشاء ارتباط إلى البيانات من Access بحيث تبقى البيانات في الملف الأصلي (خارج ملف Access).

  1. على علامة التبويب "بيانات خارجية"، في المجموعة "استيراد & ارتباط"، انقر فوق التنسيق الذي يتم تخزين البيانات به.

    يمكنك استيراد بيانات من المصادر التالية أو إنشاء ارتباط بها:

    • Excel    يمكنك إحضار بيانات من ورقة عمل أو نطاق مسمى في مصنف Excel. يجب استيراد كل ورقة عمل أو نطاق مسمى أو ربطهما بشكل منفصل.

    • Access    هذا مفيد جدا لفصل العملية عن البيانات وإنشاء قاعدة بيانات منقسمة. أي أنه يمكنك استخدام قاعدة بيانات واحدة لتحتوي على كل النماذج والتقارير و وحدات الماكرو، مع الاحتفاظ بالبيانات في قاعدة بيانات أخرى. يمكنك بعد ذلك تطوير التحسينات دون مقاطعة عمل أي شخص. يمكنك أيضا دمج البيانات من العديد من قواعد بيانات Access المختلفة في واحدة، مما يسهل تلخيص البيانات عبر الأقسام أو بين شركاء العمل.

    • قاعدة بيانات ODBC    تدعم العديد من البرامج هذا التنسيق، بما في ذلك العديد من منتجات خوادم قواعد البيانات. يساعدك ذلك على إنشاء قواعد بيانات "لوحة منضمة"، حيث تقوم بدمج البيانات من أنظمة مختلفة.

    • ملف نصي    يمكنك الاتصال بملف نصي بسيط، وحتى استخدام Access لتغيير محتويات هذا الملف. يمكن أن يساعد هذا في جعل بيانات Access سهلة الاستخدام بواسطة مجموعة واسعة من البرامج.

    • ملف XML    يوفر هذا التنسيق أيضا التوافق مع مجموعة متنوعة من البرامج الأخرى، بما في ذلك بعض خوادم الويب.

    • قائمة SharePoint    يجعل هذا البيانات قابلة للاستخدام باستخدام مستعرض ويب، وهو الطريقة القياسية لاستخدام قائمة SharePoint.

    • Data Services    يمكنك الاتصال بالخدمات الخاصة بالبيانات على الويب داخل المؤسسة.

    • مستند HTML    

    • مجلد Outlook    يمكنك الاتصال بمجلدات Outlook، بحيث يمكنك دمج معلومات جهات الاتصال مع باقي البيانات بسهولة أكبر.

    • dBase file    dBase هو نظام شائع لقاعدة البيانات البديلة يدعمه Access

      يظهر مربع الحوار "الحصول على بيانات خارجية".

  2. اتبع الإرشادات الموجودة في مربع الحوار.

    سيستورد Access البيانات أو يربطها بقاعدة البيانات. بالنسبة لمعظم التنسيقات، يجب تحديد موقع البيانات، ثم اختيار الطريقة التي تريد تخزين البيانات بها في قاعدة البيانات.

أعلى الصفحة

استخدام قاعدة بيانات من إصدار سابق في إصدارات متعددة من Access

إذا تم إنشاء قاعدة بيانات Access أو مشروع Access في Access 2000 أو إصدار لاحق، يمكنك استخدام قاعدة البيانات أو المشروع في إصدار Access الذي تم إنشاؤه فيه أو في أي إصدار أحدث — حتى لو تم تمكين الملف أمان. على سبيل المثال، يمكن استخدام ملفات Access 2000 في Access 2000 و Access 2002 و Access 2003 و Access 2007 و Access 2010.

قد تحتاج في بعض الحالات إلى الاحتفاظ بالبيانات في إصدار سابق من Access، ولكن لديك مستخدمون لديهم إصدار أحدث من Access يرغبون في الارتباط بهذه البيانات ولكن مع ذلك يستفيدون من بعض ميزات الإصدار الأحدث. الحل هو إنشاء قاعدة بيانات "واجهة أمامية" جديدة في الإصدار الأحدث (تحتوي على نماذج، تقارير، استعلامات، وحدات ماكرو، ولكن بدون جداول)، وربطها بالجداول في ملف الإصدار السابق. استخدم أحد الإجراءات التالية، استنادا إلى ما إذا كانت قاعدة البيانات موجودة في ملف واحد، أو تم تقسيمها بالفعل إلى التطبيق الموجود على الكمبيوتر العميل/الخادم.

استخدام ملف قاعدة بيانات Access في إصدارات متعددة من Access

إذا كانت كافة الجداول والنماذج والأشياء الأخرى في قاعدة بيانات Access من إصدار سابق موجودة في ملف واحد، وتريد استخدام قاعدة البيانات في إصدارات متعددة من Access، يمكنك إنشاء قاعدة بيانات أمامية جديدة في إصدار لاحق وربطها بالملف الأصلي. لا يزال بإمكان المستخدمين الذين لديهم الإصدار السابق من Access استخدام قاعدة البيانات الأصلية. يمكن للمستخدمين الذين لديهم الإصدار الأحدث استخدام قاعدة البيانات الأمامية الجديدة للارتباط بنفس البيانات. يمكنك إنشاء العديد من الإصدارات الأمامية إذا كنت بحاجة إلى استيعاب إصدارات متعددة من Access.

أعلى الصفحة

الخطوة 1: إنشاء نسخة من قاعدة البيانات الموجودة وحفظها بتنسيق جديد

استخدم الإجراء التالي لتحويل قاعدة البيانات إلى أي من التنسيقات الثلاثة الأخيرة: Access 2000 أو Access 2002-2003 أو Access 2007. يحافظ هذا الأمر على قاعدة البيانات الأصلية بتنسيقها الأصلي، وينشئ نسخة بتنسيق تحدده.

  1. أغلق ملف Access. إذا كان الملف قاعدة بيانات Access متعددة المستخدمين موجودة على خادم أو في مجلد مشترك، فتأكد من عدم فتحها من قبل أي شخص آخر.

  2. ابدأ تشغيل Access 2010.

  3. على علامة التبويب ملف، انقر فوق فتح.

  4. استعرض إلى موقع الملف الذي تريد تحويله، ثم انقر نقرا مزدوجا فوقه لفتحه.

    إذا ظهر مربع الحوار "تحسين قاعدة البيانات"، مسألا عما إذا كنت تريد تحسين قاعدة البيانات، انقر فوق "لا".

  5. إذا تم فتح نموذج عند بدء تشغيل قاعدة البيانات، أغلق النموذج.

  6. على علامة التبويب "ملف"، انقر فوق "حفظ قاعدة البيانات باسم".

  7. في مربع الحوار "حفظ باسم"، اكتب اسما لقاعدة البيانات الجديدة.

    ملاحظة: يجب أن يكون اسم قاعدة البيانات الجديدة مختلفا عن اسم قاعدة البيانات الأصلية، إلا إذا قمت بحفظها في موقع آخر. في كلتا الحالتين، من الأفضل عادة استخدام اسم مختلف، بحيث يمكنك بسهولة التمييز بين قاعدة البيانات الأمامية وقاعدة البيانات على الإنترنت. ومع ذلك، إذا كنت تقوم بالتحوير إلى تنسيق Access 2007، يتغير ملحق اسم الملف من .mdb إلى accdb.، بحيث يمكنك استخدام نفس اسم الملف.

  8. انقر فوق حفظ.

أعلى الصفحة

الخطوة 2: تقسيم قاعدة بيانات النسخ واستخدام الملف الأصلي لقاعدة البيانات على ظهره

تقسيم قاعدة البيانات التي تم تحويلها باستخدام الإجراء التالي:

  • على علامة التبويب "أدوات قاعدة البيانات"، في المجموعة "نقل البيانات"، انقر فوق قاعدة بيانات Access. صورة الزر

  • في مربع الحوار "تقسيم قاعدة البيانات"، انقر فوق "تقسيم قاعدة البيانات".

    يمكنك إنشاء نسخة احتياطية إذا أردت ذلك، ولكن يمكنك أيضا إعادة إنشاء النسخة باستخدام قاعدة البيانات الأصلية.

  • اكتب اسما لقاعدة البيانات على ظهرها، ثم انقر فوق Split.

أعلى الصفحة

الخطوة 3: توصيل الواجهة الأمامية الجديدة بقاعدة البيانات الأصلية

  1. احذف قاعدة البيانات التي أنشأتها أداة "تقسيم قاعدة البيانات" — مع توخي الحذر حتى لا تحذف قاعدة البيانات الأصلية.

  2. ربط قاعدة البيانات الجديدة الموجودة على الواجهة الأمامية بالجداول الموجودة في قاعدة البيانات الأصلية: على علامة التبويب "بيانات خارجية"، في المجموعة "استيراد ارتباط" & انقر فوق "إدارةالجداول المرتبطة". صورة الزر

  3. انقر فوق "تحديد الكل"،ثم حدد خانة الاختيار المطالبة دوما بموقع جديد.

  4. انقر فوق "موافق"،واستعرض بحثا عن قاعدة بيانات الإصدارات السابقة، ثم انقر نقرا مزدوجا فوقها.

    إذا نجح كل شيء، يعرض Access رسالة تفيد بأنه تم تحديث جميع الجداول المرتبطة المحددة بنجاح.

يمكنك الآن تحسين قاعدة البيانات الأمامية الجديدة لدعم الميزات الجديدة للمستخدمين الذين لديهم إصدارات أحدث من Access. يمكن للمستخدمين الذين لديهم إصدارات سابقة الاستمرار في استخدام قاعدة بيانات الإصدارات السابقة.

أعلى الصفحة

استخدام تطبيق أمامي/خلفي في إصدارات متعددة من Access

إذا كانت قاعدة بيانات Access موجودة بالفعل التطبيق الموجود على الكمبيوتر العميل/الخادم ، يمكنك تحويل الواجهة الأمامية إلى تنسيق الملف الجديد. لا يلزم إجراء أي تغييرات لقاعدة البيانات على ظهرها.

يوضح لك الإجراء التالي كيفية استخدام الأمر "حفظ قاعدة البيانات باسم" لتحويل قاعدة البيانات الأمامية إلى أي من التنسيقات الثلاثة الأخيرة: Access 2000 أو Access 2002-2003 أو Access 2007. يحافظ هذا الأمر على قاعدة البيانات الأصلية بتنسيقها الأصلي وينشئ نسخة بتنسيق تحدده.

  1. أغلق قاعدة البيانات الأمامية. إذا كان الملف قاعدة بيانات Access متعددة المستخدمين موجودة على خادم أو في مجلد مشترك، فتأكد من عدم فتحها من قبل أي شخص آخر.

  2. ابدأ تشغيل Access 2010.

  3. على علامة التبويب ملف، انقر فوق فتح.

  4. استعرض بحثا عن موقع قاعدة البيانات الأمامية، ثم انقر نقرا مزدوجا فوقها لفتحها.

    إذا ظهر مربع الحوار "تحسين قاعدة البيانات"، مسألا عما إذا كنت تريد تحسين قاعدة البيانات، انقر فوق "لا".

  5. إذا ظهر نموذج عند فتح قاعدة البيانات، فغلق النموذج.

  6. على علامة التبويب "ملف"، انقر فوق "حفظ قاعدة البيانات باسم".

  7. في مربع الحوار "حفظ باسم"، اكتب اسما لقاعدة البيانات الجديدة.

  8. انقر فوق حفظ.

يمكنك الآن تحسين قاعدة البيانات الجديدة على الواجهة الأمامية لدعم الميزات الجديدة.

أعلى الصفحة

هل تحتاج إلى مزيد من المساعدة؟

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى المشاركين في برنامج Microsoft Office Insider

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟

نشكرك على ملاحظاتك!

×