يمكنك نشر مصنف إلى مكتبة Microsoft SharePoint لتمكين الأشخاص الآخرين من عرضه أو تحريره في مستعرض ويب من دون تثبيت Excel على أجهزة الكمبيوتر لديهم. تُعد عملية النشر مماثلة لعملية الحفظ بشكل أساسي، ولكن مع بعض الخيارات المضمّنة التي تسمح لك بالتحكم في العناصر التي تريد تمكين الأشخاص من رؤيتها عندما يفتحون المصنف في المستعرض.

قد يؤدي اعتماد ممارسة حفظ المصنف أو نشره إلى موقع SharePoint مركزي على مستوى المؤسسة بكاملها إلى مساعدتك على ضمان عدم ظهور إصدارات مختلفة قليلاً من المصنف نفسه في كل مؤسستك عند إرساله بالبريد الإلكتروني.

من خلال تعيين بعض خيارات النشر، يمكنك التشديد على أجزاء معينة في مصنفك، مثل المخططات، أو استثناء أجزاء أخرى ومنع ظهورها في المستعرض. على سبيل المثال، يمكنك إظهار مخطط دون إظهار بياناته الأساسية. أو، يمكنك إظهار بعض أوراق العمل فقط لأولئك الأشخاص الذين يحتاجون لرؤيتها، وإخفاء أوراق العمل الأخرى.

توضح لك هذه المقالة كيفية نشر مصنف من Excel for Windows ولا تغطي توصيل مصنف أو بيانات مصنف بجزء ويب Excel Web Access على صفحة SharePoint.

عندما تنشر مصنفاً إلى موقع SharePoint، يُحفظ المصنف بكامله في SharePoint. بإمكان المستخدم الذي لديه أذونات SharePoint المطلوبة عرض المصنف بكامله واستخدامه سواء في المستعرض أو في برنامج Excel لسطح المكتب.

إذا تم نشر Office للويب على SharePoint، فإن عرض البيانات والعمل عليها في المستعرض يمكن أن يشبه إلى حدٍ بعيدٍ العمل على البيانات في برنامج Excel لسطح المكتب. وفي الواقع، بخلاف برنامج Excel لسطح المكتب، بإمكان مستخدمين متعددين تحرير مصنف بشكلٍ متزامن في شبكة المستعرض. عندما تعرض مصنفاً في المستعرض، إذا كان الزر تحرير في Excel Online مرئياً، فهذا سيشير إلى أن Office للويب بات جاهزاً للاستخدام.

تحضير المصنف

قبل نشر مصنف، يمكنك اختيار تحديد فقط أوراق العمل أو العناصر التي تريد ظهورها في المستعرض. تذكر فقط أنه على الرغم من إمكانية تحديد ما يمكن عرضه في هذا الوضع، إلا أن محتويات المصنف تبقى محفوظة بالكامل على خادم SharePoint.

إذا أردت تضمين أوراق عمل كاملة كعنصر بالإضافة إلى عناصر أخرى، مثل المخططات أو جداول PivotTable، فقم بتعريف ورقة العمل بالكامل كنطاق مسمى. حدد ورقة العمل بالكامل، ثم قم بتعريف نطاق مسمى. وسيظهر هذا النطاق المسمى بعد ذلك كعنصر متوفر في مربع الحوار خيارات النشر عندما تكون جاهزًا للنشر.

للسماح للمستخدمين بإدخال قيمة في خلية للعمل مع صيغة في خلية أخرى، عيّن تلك الخلية كاسم معرّف في Excel قبل نشر المصنف. ويمكنك بعد ذلك إضافة هذا الاسم المعرّف كمعلمة ضمن علامة التبويب معلماتفي الجزء خيارات عرض المستعرض.

على سبيل المثال، يعرض المثال التالي الخلية D2، التي تتضمّن الاسم المعرّف "السعر". في المستعرض، يدخل المستخدم القيمة 5.625 في المربع السعر في الجزء معلومات، ثم ينقر فوق تطبيق. فتظهر هذه القيمة في الخلية D2، وتستخدم الصيغة في A2 القيمة الموجودة في D2. تتم إعادة حساب نتيجة الصيغة، وتظهر في الخلية A2: ‏ 1,151.31 ر.س.

يؤدي إدخال معلمة في الجزء إلى استخدامها في الخلية D2

ملاحظة: إذا أنشأت مقسمات طرق عرض لجدول Excel، وقمت بتعريف اسم لنطاق الخلايا التي تحتوي على الجدول ومقسمات طرق العرض، فلن تتمكّن من استخدام مقسمات طرق العرض لتصفية الجدول في المستعرض إذا نشرت النطاق المعرّف. إذا نشرت الجدول أو ورقة العمل بكاملها أو مصنفها، فستعمل مقسمات طرق العرض كما هو متوقع لها أن تعمل في المستعرض.

نشر المصنف

  1. انقر فوق علامة التبويب ملف، وفوق حفظ باسم، ثم فوق SharePoint.

  2. إذا رأيت مجلد SharePoint ضمن "الحالي" أو " الأخير" أو "الأقدم"، فانقر فوق المجلد الذي تريده.

    يظهر مربع الحوار حفظ باسم.


    وإلا، فانقر فوق "استعراض"، وأدخل عنوان ويب لموقع SharePoint، ثم استعرض وصولا إلى المجلد حيث تريد نشر المصنف.

    انقر فوق مجلد SharePoint أو انقر فوق «استعراض»
  3. لتحديد أوراق عمل أو عناصر فردية لنشرها من المصنف، انقر فوق خيارات عرض المستعرض.

    في مربع الحوار "حفظ باسم"، انقر فوق "خيارات عرض المستعرض"

    سترى علامة التبويب إظهار وعلامة التبويب معلمات.

  4. إذا أردت نشر المصنف بكامله، فانقر فوق حفظ. وإلا، فقم بواحد مما يلي:

    • لإظهار المصنف بالكامل في المستعرض، على علامة التبويب إظهار، حدد المصنف بأكمله في مربع القائمة.

    • لإظهار أوراق عمل معينة فقط في المستعرض، على علامة التبويب إظهار، حدد الأوراق في مربع القائمة، ثم قم بإلغاء تحديد المربعات الخاصة بالأوراق التي تريد إظهارها في المستعرض.

      بشكل افتراضي، تكون جميع الأوراق محددة. لجعل كافة الأوراق قابلة للعرض مرة أخرى سريعاً بعد إلغاء تحديد بعض المربعات، حدد خانة الاختيار كافة الأوراق.

    • لإظهار عناصر معينة فقط في المستعرض (كالنطاقات المسماة، أو المخططات، أو الجداول أو جداول PivotTable)، على علامة التبويب إظهار، حدد العناصر الموجودة في المصنف في مربع القائمة، ثم حدد المربعات الخاصة بالعناصر التي تريد إظهارها.

    • على علامة التبويب معلمات، أضف أي أسماء معرّفة تريد استخدامها لتعيين الخلايا التي يمكن تحريرها عندما يعرض المستخدمون المصنف في المستعرض. ثم انقر فوق موافق.

  5. احفظ المصنف.

ملاحظات: 

  • إذا حددت عناصر لها الاسم نفسه (كمخطط وجدول البيانات الأساسي فيه)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لعرض جميع العناصر، يجب التأكد من إعطاء اسم فريد لكل عنصر في المصنف.

  • يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. عاود تسمية العناصر المكررة الأخرى، مثل النطاقات المسماة، على علامة التبويب صيغ في المجموعة اسم معرّف.

إذا تم نشر Office للويب على SharePoint، فإن عرض البيانات والعمل عليها في المستعرض يمكن أن يشبه إلى حدٍ بعيدٍ العمل على البيانات في برنامج Excel لسطح المكتب. وفي الواقع، بخلاف برنامج Excel لسطح المكتب، بإمكان مستخدمين متعددين تحرير مصنف بشكلٍ متزامن في شبكة المستعرض. عندما تعرض مصنفاً في المستعرض، إذا كان الزر تحرير في Excel Online مرئياً، فهذا سيشير إلى أن Office للويب بات جاهزاً للاستخدام.

"تحرير في Excel Online" على القائمة "تحرير مصنف"

لمزيد من المعلومات، راجع المقالة "الاختلافات بين استخدام مصنف في Excel" و"Excel Services".

تحضير المصنف

قبل نشر مصنف، يمكنك اختيار تحديد فقط أوراق العمل أو العناصر التي تريد ظهورها في المستعرض. تذكر فقط أنه على الرغم من إمكانية تحديد ما يمكن عرضه في هذا الوضع، إلا أن محتويات المصنف تبقى محفوظة بالكامل على خادم SharePoint.

إذا أردت تضمين أوراق عمل كاملة كعنصر بالإضافة إلى عناصر أخرى، مثل المخططات أو جداول PivotTable، فقم بتعريف ورقة العمل بالكامل كنطاق مسمى. حدد ورقة العمل بالكامل، ثم قم بتعريف نطاق مسمى. وسيظهر هذا النطاق المسمى بعد ذلك كعنصر متوفر في مربع الحوار خيارات النشر عندما تكون جاهزًا للنشر.

للسماح للمستخدمين بإدخال قيمة في خلية للعمل مع صيغة في خلية أخرى، عيّن تلك الخلية كاسم معرّف في Excel قبل نشر المصنف. ويمكنك بعد ذلك إضافة هذا الاسم المعرّف كمعلمة ضمن علامة التبويب معلماتفي الجزء خيارات عرض المستعرض.

على سبيل المثال، يعرض المثال التالي الخلية D2، التي تتضمّن الاسم المعرّف "السعر". في المستعرض، يدخل المستخدم قيمة، 5.625، في المربع الموجود في جزء المعلمات وينقر فوق "تطبيق". فتظهر هذه القيمة في الخلية D2، وتستخدم الصيغة في A2 القيمة الموجودة في D2. تتم إعادة حساب نتيجة الصيغة، وتظهر في الخلية A2: ‏ 1,151.31 ر.س.

راجع تعليمات Excel للحصول على معلومات حول كيفية تعريف النطاقات.

يؤدي إدخال معلمة في الجزء إلى استخدامها في الخلية D2

ملاحظة: إذا أنشأت مقسمات طرق عرض لجدول Excel، وقمت بتعريف اسم لنطاق الخلايا التي تحتوي على الجدول ومقسمات طرق العرض، فلن تتمكّن من استخدام مقسمات طرق العرض لتصفية الجدول في المستعرض إذا نشرت النطاق المعرّف. إذا نشرت الجدول أو ورقة العمل بكاملها أو مصنفها، فستعمل مقسمات طرق العرض كما هو متوقع لها أن تعمل في المستعرض.

نشر المصنف

  1. انقر فوق "ملف " > "حفظ باسم" >SharePoint.

  2. إذا رأيت مجلد SharePoint ضمن"المجلد الحالي" أو "المجلدات الأخيرة"، فانقر فوق المجلد الذي تريده. وإلا، فانقر فوق "استعراض " وأدخل عنوان ويب لموقع SharePoint. ثم استعرض وصولا إلى المجلد حيث تريد نشر المصنف. يظهر مربع الحوار حفظ باسم.

  3. لتحديد أوراق عمل أو عناصر فردية لنشرها من المصنف، انقر فوق خيارات عرض المستعرض. سترى علامة تبويب "إظهار " وعلامة تبويب "معلمات ". إذا أردت نشر المصنف بكامله، فانقر فوق حفظ. وإلا، فقم بواحد مما يلي:

    • لإظهار المصنف بالكامل في المستعرض، على علامة التبويب إظهار، حدد المصنف بأكمله في مربع القائمة.

    • لإظهار أوراق عمل معينة فقط في المستعرض، على علامة التبويب "إظهار "، حدد "أوراق " في مربع القائمة، ثم قم بإلغاء تحديد مربعات الأوراق التي لا تريد إخفاؤها في المستعرض.

      بشكل افتراضي، تكون جميع الأوراق محددة. لجعل كل الأوراق قابلة للعرض مرة أخرى بسرعة بعد إلغاء تحديد بعض المربعات، حدد خانة الاختيار "كافة الأوراق ".

    • لإظهار عناصر محددة فقط في المستعرض (مثل النطاقات المسماة أو المخططات أو الجداول أو جداول PivotTables)، في علامة التبويب "إظهار "، حدد "العناصر" في المصنف في مربع القائمة، ثم حدد المربعات الخاصة بالعناصر التي تريد إظهارها.

    • في علامة التبويب "معلمات "، أضف أي أسماء معرفة تريد استخدامها لتحديد الخلايا القابلة للتحرير عندما يعرض المستخدمون المصنف في المستعرض. ثم انقر فوق "موافق " لإغلاق مربع الحوار.

  4. احفظ المصنف.

ملاحظات: 

  • إذا حددت عناصر لها الاسم نفسه (كمخطط وجدول البيانات الأساسي فيه)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لعرض جميع العناصر، يجب التأكد من إعطاء اسم فريد لكل عنصر في المصنف.

  • إذا حددت عناصر لها الاسم نفسه (كمخطط وجدول البيانات الأساسي فيه)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لعرض جميع العناصر، يجب التأكد من إعطاء اسم فريد لكل عنصر في المصنف.

  • يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. عاود تسمية العناصر المكررة الأخرى، مثل النطاقات المسماة، على علامة التبويب صيغ في المجموعة اسم معرّف.

  • يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. عاود تسمية العناصر المكررة الأخرى، مثل النطاقات المسماة، على علامة التبويب صيغ في المجموعة اسم معرّف.

لمزيد من المعلومات حول أجزاء ويب الخاصة ب Excel Web Access، راجع المقالة "عرض مصنف" في جزء ويب Excel Web Access.

عند نشر مصنف إلى خادم SharePoint، يتم حفظ محتويات المصنف بالكامل إلى الخادم ويمكن عرضها والعمل عليها إذا فتحت المصنف في برنامج Excel لسطح المكتب. إذا تم نشر Office Web Apps على خادم SharePoint، يمكن أن يكون عرض بياناتك واستخدامها في مستعرض الويب أشبه كثيرا بالعمل مع بياناتك في برنامج Excel لسطح المكتب. في الواقع، يمكن التحرير المتزامن لمصنف في شبكة المستعرض عند نشر Office Web Apps. عند عرض مصنف في المستعرض، إذا كان الزر "تحرير في المستعرض " مرئيا، فهذا يعني أن Office Web Apps متوفرة.

الزر "التحرير في المستعرض"

لمزيد من المعلومات، راجع المقالة "الاختلافات بين استخدام مصنف في Excel" و"Excel Services".

تحضير المصنف

قبل نشر المصنف، تتوفر لديك الفرصة (في مربع الحوار "خيارات النشر ") لتحديد أوراق العمل أو العناصر التي تريد ظهورها في المستعرض عند عدم تمكين التحرير بالنقر فوق الزر "تحرير في المستعرض ". تذكر فقط أنه على الرغم من أنه يمكنك تحديد ما يمكن عرضه في هذا الوضع، إلا أن محتويات المصنف بأكملها لا تزال محفوظة في خادم SharePoint.

إذا أردت تضمين أوراق عمل كاملة كعنصر بالإضافة إلى عناصر أخرى، مثل المخططات أو جداول PivotTable، فقم بتعريف ورقة العمل بالكامل كنطاق مسمى. حدد ورقة العمل بالكامل، ثم قم بتعريف نطاق مسمى. وسيظهر هذا النطاق المسمى بعد ذلك كعنصر متوفر في مربع الحوار خيارات النشر عندما تكون جاهزًا للنشر.

إذا كنت تريد السماح للمستخدمين بتوفير معلمة لصيغة عند عرض ورقة عمل في مستعرض، فقم بتعيين خلية كاسم معرف. يمكنك بعد ذلك إضافة هذا الاسم المعرف كمعلمة في علامة التبويب "معلمات " في مربع الحوار " خيارات النشر ".

على سبيل المثال، في الرسم التالي الذي يعرض ورقة عمل في المستعرض، تحتوي الخلية D2 على معدل الاسم المحدد. في المستعرض، أدخل مستخدم قيمة، 5.625، في المربع في جزء المعلمات ثم انقر فوق "تطبيق". فتظهر هذه القيمة في الخلية D2، وتستخدم الصيغة في A2 القيمة الموجودة في D2. تتم إعادة حساب نتيجة الصيغة، وتظهر في الخلية A2: ‏ 1,151.31 ر.س.

استخدام معلمة في المستعرض

راجع تعليمات Excel للحصول على معلومات حول كيفية تعريف النطاقات.

نشر المصنف

  1. انقر فوق علامة التبويب ملف ثم فوق حفظ وإرسال.

  2. انقر فوق "حفظ إلى SharePoint".
    ملاحظة     إذا كان الأمر "حفظ إلى SharePoint" غير متوفر، فلا يزال بإمكانك حفظ المصنف في موقع SharePoint باستخدام الأمر "حفظ باسم ". لن يكون مربع الحوار "خيارات النشر " متوفرا. يمكنك أيضا تحميل المصنف مباشرة من مكتبة SharePoint. يمكن للمستخدمين عرض محتويات المصنف وتحريرها في المستعرض بالانتقال مباشرة إلى الموقع حيث يتم حفظ المصنف.

    الأمر "حفظ باسم"

  3. إذا كنت تريد تحديد أوراق عمل أو عناصر فردية لنشرها في المصنف، فانقر فوق الزر "خيارات النشر ". وإلا، إذا كنت تريد نشر المصنف بأكمله، فانتقل مباشرة إلى الخطوة 4.
    على علامة التبويب "إظهار "، قم بما يلي:

    • لإظهار المصنف بأكمله في المستعرض، حدد "المصنف بأكمله" في مربع القائمة.

    • لإظهار أوراق عمل معينة فقط في المستعرض، حدد "أوراق " في مربع القائمة، ثم قم بإلغاء تحديد خانات الاختيار للأوراق التي لا تريد إظهارها.
      ملاحظة    بشكل افتراضي، يتم تحديد كافة الأوراق. لجعل كل الأوراق قابلة للعرض مرة أخرى بسرعة بعد إلغاء تحديد بعض خانات الاختيار، يمكنك تحديد خانة الاختيار "كافة الأوراق ".

    • لإظهار عناصر محددة فقط في المستعرض (مثل النطاقات المسماة أو المخططات أو الجداول أو جداول PivotTables)، حدد "العناصر" في المصنف في مربع القائمة، ثم حدد خانات الاختيار الخاصة بالعناصر التي تريد إظهارها.
      ملاحظة، إذا قمت بتحديد عناصر لها نفس الاسم (مثل مخطط وجدول البيانات الأساسي الخاص به)، فسيتوفر عنصر واحد فقط من هذه العناصر في المستعرض. لإظهار كافة العناصر، يجب التأكد من أن كل عنصر في المصنف له اسم فريد. يمكنك إعادة تسمية الجداول ضمن علامة التبويب تصميم في المجموعة خصائص، وإعادة تسمية PivotTables ضمن علامة التبويب خيارات في المجموعة PivotTable، وإعادة تسمية المخططات أو PivotCharts في علامة التبويب تخطيط في المجموعة خصائص. يمكن إعادة تسمية العناصر المكررة، مثل النطاقات المسماة، على علامة التبويب "صيغ " في المجموعة " أسماء معرفة ".
      تحديد أوراق عمل أو عناصر

    • في علامة التبويب "معلمات "، أضف أي أسماء معرفة تريد استخدامها لتحديد الخلايا القابلة للتحرير عندما يعرض المستخدمون المصنف في المستعرض. ثم انقر فوق "موافق " لإغلاق مربع الحوار.
      تعيين معلمات

  4. اختر موقعا لنشر المصنف فيه.
    قد يكون هناك بالفعل مواقع خادم محفوظة ضمن "الموقع الحالي" أو "المواقع الأخيرة" أو "المواقع" التي يمكنك الاختيار منها. إذا لم يكن هناك مثل هذه المواقع، أو إذا كنت تريد الحفظ في موقع جديد، ضمن "المواقع"، فانقر نقرا مزدوجا فوق "استعراض" بحثا عن موقع.

  5. في مربع الحوار "حفظ باسم "، أدخل عنوان ويب لموقع SharePoint، ثم استعرض وصولا إلى الموقع أو المكتبة التي تريد حفظ المصنف فيها.

  6. إذا لم تكن قد حددت أوراق عمل أو عناصر فردية أو قمت بتعيين معلمات، فانقر فوق الزر "خيارات النشر ".

  7. في مربع اسم الملف ، اقبل الاسم المقترح للمصنف، أو اكتب اسما جديدا إذا أردت ذلك.

  8. لعرض محتويات المصنف في نافذة مستعرض مباشرة بعد اكتمال عملية النشر، تأكد من تحديد خانة الاختيار "فتح باستخدام Excel" في المستعرض .

  9. انقر فوق حفظ.

هل تحتاج إلى مزيد من المساعدة؟

توسيع المهارات

استكشاف التدريب >

الحصول على الميزات الجديدة أولاً

الانضمام إلى MICROSOFT INSIDERS >

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟

نشكرك على ملاحظاتك!

×