KB2942895 - تصحيح: الخطأ 35377 عند إنشاء فهرس Columnstore متفاوت المسافات أو إعادة إنشائه باستخدام maxdop أكبر من 1 عبر اتصال MARS في SQL Server 2014

ينطبق على
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

الأعراض

لنفترض أنك قمت بإنشاء فهرس columnstore متفاوت المسافات عبر اتصال مجموعات النتائج النشطة المتعددة (MARS) في Microsoft SQL Server 2014. عند تعيين قيمة maxdop أكبر من 1، تفشل عملية إنشاء فهرس مخزن الأعمدة متفاوت المسافات أو إعادة إنشائه. بالإضافة إلى ذلك، ستتلقى الخطأ 35377 يشبه ما يلي:

ملاحظة

رقم الخطأ: 35377
الخطأالخطورة: EX_USER
ErrorOwner: <OwnerName>
rrorFormat: عند تشغيل MARS، لا يسمح بالوصول إلى فهارس مخزن الأعمدة المجمعة.
ErrorCause: وصول غير صالح إلى فهارس columnstore المتفاوتة المسافات على اتصال MARS.
ErrorCorrectiveAction: يجب ألا يكون الاتصال ممكنا لنظام MARS.
خطأالمنتجالأول: SQL14

        
        
ملاحظة لا تحدث هذه المشكلة عندما تقوم بتعيين maxdop يساوي 1.

الدقة

تم إصلاح كلتا المشكلتين لأول مرة في التحديث التراكمي التالي ل SQL Server.

التحديث التراكمي 1 ل SQL Server 2014 /en-us/help/2931693

حول التحديثات التراكمية ل SQL Server

يحتوي كل تحديث تراكمي جديد ل SQL Server على جميع الإصلاحات العاجلة وجميع إصلاحات الأمان التي كانت مضمنة في التحديث التراكمي السابق. تحقق من آخر التحديثات التراكمية ل SQL Server:

      

الحالة

لقد أكدت Microsoft على أن هذه مشكلة في منتجات Microsoft المُدرجة في القسم "ينطبق على".