تخطي إلى المحتوى الرئيسي
الدعم
تسجيل الدخول باستخدام حساب Microsoft
تسجيل الدخول أو إنشاء حساب.
مرحباً،
تحديد استخدام حساب مختلف!
لديك حسابات متعددة
اختر الحساب الذي تريد تسجيل الدخول باستخدامه.

الأعراض

يرجى مراعاة السيناريو التالي:

  • تكوين ملقم لتشغيل Microsoft Exchange Server 2003 أو نظام التشغيل Microsoft Exchange Server 2007 Microsoft Exchange Server 2010.

  • خادم يقوم بتشغيل Microsoft Exchange Server دور خادم وصول عميل (CAS).

  • محاولة مزامنة جهاز محمول.

في هذا السيناريو، قد يعمل ببطء شديد خادم Exchange Server CAS وعدم الاستجابة لطلب Microsoft Exchange ActiveSync. عند حدوث هذه المشكلة، قد استخدم عملية W3wp.exe قيد التشغيل ضمن MSExchangeSyncAppPool 100% وقت وحدة المعالجة المركزية.

ملاحظة: على خادم يقوم بتشغيل Exchange Server 2003، تحدث المعالجة على الملقم الخلفي. لذلك، قد تستخدم عملية W3wp.exe تحته ExchangeApplicationPool تجمع التطبيقات على ملقم الجهة الخلفية وقت وحدة المعالجة المركزية. بالإضافة إلى ذلك، قد تواجه النمو سجل الحركة السريعة.

السبب

قد تحدث هذه المشكلة إذا كان يحاول جهاز محمول لمزامنة العديد من جهات الاتصال في كل طلب.

ملاحظة: شكل طلب المزامنة هذا هو موقع غير متوقع لكافة جهات الاتصال الموجودة على الجهاز المحمول. يحاول ملقم Exchange للتحقق من صحة مخطط XML لكل عقده لكافة جهات الاتصال. قد يتسبب هذا في العديد من عمليات تخصيص الذاكرة والمهملة Microsoft.NET المفرط.

الحالة

هذه المسألة حاليا قيد التحقيق من قبل الشركة المصنعة للجهاز المحمول.

الحل البديل

للتغلب على هذه المشكلة، اتبع الخطوات التالية:

  1. تحديد المستخدمين والأجهزة التي تتسبب في ارتفاع استخدام CPU. للقيام بذلك، اتبع الخطوات التالية:

    1. تجميع سجلات خدمات معلومات إنترنت (IIS).

    2. استخدام الاستعلام Studio محلل السجل التالي لتعريف المستخدمين المشكلة والأجهزة:

      /* Find Device/User Info for 100% CPU while syncing contacts */Select TOP 5000 TO_TIMESTAMP(TO_DATE(date), TO_TIME(time)) as [Time],
      cs-username as [User],
      cs(user-agent) as DeviceID,
      TO_INT(EXTRACT_PREFIX(EXTRACT_SUFFIX(cs-uri-query, 0, '_RpcC'), 0, '_')) As RPCCount,
      sc-status as Status,
      sc-substatus as SubStatus,
      sc-bytes as [Bytes],
      DIV(sc-bytes, 1024) AS [KBytes], time-taken, DIV(time-taken, 1000) as Sec, cs-uri-query
      FROM '[LOGFILEPATH]'
      WHERE
      RPCCount > 2000 /* <-- Change RPC count as needed */
      AND cs-uri-query LIKE '%Cmd=Sync%'
      AND cs-uri-query LIKE '%Ty:Co%'
      ORDER BY [Bytes] DESC

      ملاحظة: وقتاً أطول من المهلة IIS لإكمال طلب، يتم إسقاط الطلب ولن تظهر في سجل IIS.

      ملاحظة: عادة، يكون المستخدمين المشكلة RPC عدد أكثر من ألفي شخص. حساب كثرة تكرار هذه RPC عند فواصل زمنية محددة.

  2. فحص البيانات التي تم إرجاعها لتحديد أنماط عدد RPC عالية للمستخدمين ثم المباراة هؤلاء المستخدمين للمستخدمين الذين لديهم حساب ارتفاع عنصر جهة الاتصال.

  3. اختبار المشكلة مرة أخرى. للقيام بذلك، اتبع الخطوات التالية:

    1. قم بتعطيل مستخدم من المزامنة.

    2. سلة المحذوفات MSExchangeSyncAppPool.

  4. بعد تحديد المستخدمين المشكلة والأجهزة، قم بأحد الإجراءات التالية:

    • تعطيل مزامنة مجلد جهات الاتصال على الجهاز.

    • منع مشاكل الأجهزة في جدار الحماية باستخدام سلسلة عامل المستخدم.

    • حظر المستخدمين لكل مستخدم على حدى.

    • تقليل عدد جهات الاتصال الموجودة في مجلد "جهات الاتصال" لمستخدم.

    • إعادة تدوير مجمع التطبيقات ActiveSync كل 30 دقيقة.

      ملاحظة: لا ننصح المحذوفات تجمع تطبيقات ActiveSync كل 30 دقيقة في بيئة إنتاج.

    • إذا كان الملقم يشغل Exchange Server 2010، تغيير "نهج التحكم" التي يتم تطبيقها على المستخدم. للقيام بذلك، قم بتشغيل cmdlet التالية:

      < ثروتلينجبوليسينامي > مجموعة ثروتلينجبوليسي-إيسبيرسينتيمينكاس 30ملاحظات

      • يمكن أن تكون نهج التحكم نهج الافتراضي أو نهج الذي تم تعيينه إلى المستخدم.

      • القيمة الافتراضية إيسبيرسينتيمينكاس هو 100. قد يطلب إعداد أقل إيجاد حل بديل لهذه المشكلة. نوصي بقيمة بداية من 30. ومع ذلك، يعتمد الإعداد الأكثر فعالية على البيئة. نوصي باختبار كل إعداد دقيق. إذا كانت قيمة إيسبيرسينتيمينكاس غير صحيحة، قد تتأثر الأجهزة التي تتسبب في حدوث المشكلة.

حالة تعذر التعرف على المستخدم أو الجهاز الذي يسبب استخدام CPU عالية، جمع مجموعة من ملفات تفريغ تعطل ومن ثم اتصل Microsoft التجارية التقنية الدعم (CTS). فحص ملفات تفريغ تعطل CTS وإصلاحها المشكلة. لتجميع مجموعة من ملفات تفريغ تعطل، اتبع الخطوات التالية:

  1. تحميل وتثبيت الأداة المساعدة بروكدومب. لمزيد من المعلومات حول الأداة المساعدة بروكدومب، قم بزيارة موقع TechNet التالي على الويب:

    http://technet.microsoft.com/en-us/sysinternals/dd996900

  2. انقر فوق ابدأواكتب cmd في مربع البحث في البرامج والملفات واضغط على Enter.

  3. في موجه الأوامر، اكتب الأمر التالي، ومن ثم اضغط Enter:

    C:\Windows\System32\InetSrv و appcmd التشغيل قائمة الفسفور الأبيضملاحظة: هذا الأمر باسترداد معرف العملية (PID) MSExchangeSyncAppPool.

  4. في موجه الأوامر، اكتب الأمر التالي فيها PID "معرف العملية" التي تم إرجاعها في الخطوة 2:

    بروكدومب-c:\temp\andy\w3wp.dmp-أكسيبتيولا-s 5-n 3 مللي أمبير [بيدوفسينكاببول]-c 90

  5. كرر الخطوات من 1 إلى 4 على الأقل ثلاث مرات، واتصل بالتجارة في الخدمات.

مزيد من المعلومات

عند حدوث المشكلة الموضحة في قسم "الأعراض"، يرسل الجهاز المحمول طلب المزامنة مرة أخرى بعد عدة دقائق إذا لم يتم تلقي استجابة. يمكن أن يسبب هذا متعددة مؤشرات الترابط التي تحاول مزامنتها نفس المجموعة من جهات الاتصال. احتمال عدم إنهاء الملقم CAS أي من الطلبات.

عندما يتم إسقاط طلب لأنه يستغرق وقتاً أطول من المهلة IIS لإكمال الطلب، يتم عرض رسالة إعلام بخطأ في سجل أخطاء HTTP API. رسالة الخطأ هذه لما يلي:

المراجع

لمزيد من المعلومات حول هذا الموضوع، راجع المستند التالي من Microsoft TechNet على الإنترنت:
http://blogs.technet.com/b/exchange/archive/2007/09/12/3403903.aspx 

لمزيد من المعلومات حول تسجيل محلل Studio، قم بزيارة موقع TechNet التالي على الويب:

http://gallery.technet.microsoft.com/Log-Parser-Studio-cd458765لمزيد من المعلومات حول التحكم في السياسات في Exchange Server 2010، قم بزيارة موقع TechNet التالي على الويب:

http://technet.microsoft.com/en-us/library/dd297964.aspxلمزيد من المعلومات حول الحالات حيث يتم إنشاء جهات الاتصال المكررة عندما يحاول مستخدم لمزامنة العديد من جهات الاتصال، راجع المقالة التالية في "قاعدة المعارف ل Microsoft":

2711181 يتم إنشاء جهات اتصال مكررة عند مزامنة جهاز محمول باستخدام Exchange ActiveSyncلمزيد من المعلومات حول أنواع الأخطاء التي سجلت قبل HTTP API وتنسيق سجلات الأخطاء HTTP API، راجع المقالة التالية في "قاعدة المعارف ل Microsoft":

820729 خطأ تسجيل الدخول HTTP API

هل تحتاج إلى مزيد من المساعدة؟

الخروج من الخيارات إضافية؟

استكشف مزايا الاشتراك، واستعرض الدورات التدريبية، وتعرف على كيفية تأمين جهازك، والمزيد.

تساعدك المجتمعات على طرح الأسئلة والإجابة عليها، وتقديم الملاحظات، وسماعها من الخبراء ذوي الاطلاع الواسع.

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟
بالضغط على "إرسال"، سيتم استخدام ملاحظاتك لتحسين منتجات Microsoft وخدماتها. سيتمكن مسؤول تكنولوجيا المعلومات لديك من جمع هذه البيانات. بيان الخصوصية.

نشكرك على ملاحظاتك!

×