تخطي إلى المحتوى الرئيسي
الدعم
تسجيل الدخول باستخدام حساب Microsoft
تسجيل الدخول أو إنشاء حساب.
مرحباً،
تحديد استخدام حساب مختلف!
لديك حسابات متعددة
اختر الحساب الذي تريد تسجيل الدخول باستخدامه.

الأعراض

قد يتعطل الخادم بعد تثبيت تحديث ASP.NET على كمبيوتر يقوم بتشغيل تطبيق سطح المكتب ثنائي الطبقات من Microsoft Visual Studio LightSwitch 2011 أو عند قيام خدمات معلومات إنترنت (IIS) باستضافة خادم Microsoft Visual Studio LightSwitch 2011. عند حدوث هذه المشكلة، قد يواجه المستخدمون النهائيون للتطبيق الفشل في تحميل البيانات في برنامج العميل. 

السبب

تحدث هذه المشكلة نظرًا لفقد بيانات التجميع اللازمة لعمل ميزة Assembly Unification الخاصة ببرنامج .NET Framework بشكل صحيح. لذلك، تقوم مجالات التطبيقات بتحميل إصدارين من نفس التجميع. 

ملاحظة تحدث هذه المشكلة فقط خلال الوقت المنقضي بين تثبيت أحد تحديثات ASP.NET وإعادة تشغيل التطبيق أو الخادم مرة أخرى.

الحل

لحل هذه المشكلة، استخدم إحدى الطرق التالية المناسبة للتطبيق. 

الطريقة الأولى

بالنسبة لتطبيق سطح المكتب ثنائي الطبقات، قم بإغلاق التطبيق وإعادة تشغيله مرة أخرى. 

الطريقة الثانية

بالنسبة للتطبيق ثلاثي الطبقات لسطح المكتب أو موقع الويب، استخدم حساب المسؤول لإعادة تشغيل الخادم الذي يقوم بتشغيل IIS. 

الطريقة الثالثة

إذا كان التطبيق قيد بدء التشغيل عن طريق استخدام Microsoft Visual Studio، فأعد تشغيل Visual Studio. 

مراجع

لمزيد من المعلومات حول Visual Studio LightSwitch 2011، قم بزيارة موقع Microsoft التالي على الويب:

معلومات عامة حول Visual Studio LightSwitch 2011لمزيد من المعلومات حول الميزة Assembly Unification، قم بزيارة موقع MSDN التالي على الويب:

معلومات عامة حول الميزة Assembly Unification

هل تحتاج إلى مزيد من المساعدة؟

الخروج من الخيارات إضافية؟

استكشف مزايا الاشتراك، واستعرض الدورات التدريبية، وتعرف على كيفية تأمين جهازك، والمزيد.

تساعدك المجتمعات على طرح الأسئلة والإجابة عليها، وتقديم الملاحظات، وسماعها من الخبراء ذوي الاطلاع الواسع.

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟
بالضغط على "إرسال"، سيتم استخدام ملاحظاتك لتحسين منتجات Microsoft وخدماتها. سيتمكن مسؤول تكنولوجيا المعلومات لديك من جمع هذه البيانات. بيان الخصوصية.

نشكرك على ملاحظاتك!

×