تخطي إلى المحتوى الرئيسي
الدعم
تسجيل الدخول باستخدام حساب Microsoft
تسجيل الدخول أو إنشاء حساب.
مرحباً،
تحديد استخدام حساب مختلف!
لديك حسابات متعددة
اختر الحساب الذي تريد تسجيل الدخول باستخدامه.

انتهى دعم Windows Vista Service Pack 1 (SP1) في 12 يوليو 2011. لمواصلة تلقي تحديثات الأمان لنظام التشغيل Windows، تأكد من تشغيل Windows Vista باستخدام Service Pack 2 (SP2). لمزيد من المعلومات، راجع صفحة Microsoft على الويب هذه: ينتهي الدعم لبعض إصدارات Windows.

الأعراض

تحاول تنزيل ملف يزيد حجمه عن 5000000 بايت من مجلد ويب على Windows XP Service Pack 2 (SP2) أو إصدار أحدث من Windows. قد تتلقى رسالة خطأ مماثلة للرسالة التالية:

يتعذر نسخ اسم الملف: يتعذر القراءة من الملف أو القرص المصدر

ملاحظة في رسالة الخطأ هذه، اسم الملف هو عنصر نائب لاسم الملف.

تحدث هذه المشكلة أيضا على كمبيوتر يستند إلى Windows Vista أو كمبيوتر يستند إلى Windows XP Service Pack 1 (SP1) تم تثبيت تحديث الأمان 896426 (MS05-028) عليه.

في هذا السيناريو على Windows 7 أو 8 أو 8.1، قد تتلقى رسالة الخطأ التالية:

نسخ المجلد

يحدث خطأ غير متوقع ويبقيك بعيدا عن نسخ المجلد. إذا استمر تلقي هذا الخطأ، يمكنك استخدام رمز الخطأ للبحث عن تعليمات حول هذه المشكلة.

خطأ 0x800700DF: يتجاوز حجم الملف الحد المسموح به ولا يمكن حفظه.

<اسم الملف>

حاول مرة أخرى إلغاء الأمر

السبب

تحدث هذه المشكلة لأن تغيير الأمان الذي تم إدخاله في Windows XP SP2 يؤثر على إعادة توجيه التأليف والإصدار الموزع على الويب (WebDAV). ويتأكد تغيير الأمان هذا من أن الخادم غير المصرح به لا يمكنه إجبار كمبيوتر عميل على هجوم رفض الخدمة. إذا حاولت تنزيل ملف يزيد حجمه عن 5000000 بايت، فيفسر الكمبيوتر العميل هذا التنزيل على أنه هجوم رفض الخدمة. وبالتالي، تتوقف عملية التنزيل.

الحل

هام يحتوي هذا المقطع أو الأسلوب أو المهمة على خطوات تعلمك بكيفية تعديل السجل. ومع ذلك، فقد تحدث مشاكل خطيرة في حالة تعديل السجل بطريقة غير صحيحة. ولذلك، يجب التأكد من اتباع الخطوات التالية بعناية. للحماية الإضافية، قم بعمل نسخة احتياطية من السجل قبل تعديله. يمكنك بعد ذلك استعادة السجل في حالة حدوث أية مشكلة. لمزيد من المعلومات حول كيفية عمل نسخة احتياطية من السجل واستعادته، انقر فوق رقم المقالة التالية لعرضها في "قاعدة المعارف لـ Microsoft":

322756 كيفية عمل نسخة جديدة من السجل واستعادته في Windows إذا كان لديك Windows XP SP2 أو Vista أو 7، فاذهب إلى القسم "إصلاح الأمر لي" لتشغيل
"إصلاح". إذا كنت تفضل حل هذه المشكلة بنفسك، أو كنت تستخدم Windows 8 أو 8.1، فاذهب إلى القسم "سأصلحها بنفسي".

Windows XP SP2 أو Vista أو 7: إصلاح ذلك من أجلي



لإصلاح هذه المشكلة تلقائيا، انقر فوق الزر "إصلاح" أو الارتباط. بعد ذلك، انقر فوق "تشغيل" في مربع الحوار "تنزيل الملف"، واتبع الخطوات في المعالج "إصلاح".

لاحظ أن هذا "الإصلاح" لا يعمل مع Windows 8 أو أي وقت لاحق.




الملاحظات

  • عند اتباع معالج الإصلاح، ستحتاج إلى إدخال قيمة FileSizeLimitInBytes أكبر من حجم الملف الذي تريد تنزيله.

  • قد لا يكون هذا المعالج متوفرًا إلا باللغة الإنجليزية. ومع ذلك، يعمل الإصلاح التلقائي أيضًا مع إصدارات Windows باللغات الأخرى.

  • إذا كنت لا تعمل على جهاز الكمبيوتر الذي توجد به المشكلة، فيمكنك حفظ حل Fix it على محرك قرص محمول أو قرص مضغوط ثم تشغيله على جهاز الكمبيوتر الذي توجد به المشكلة.


بعد ذلك، انتقل إلى القسم"هل قام هذا بإصلاح المشكلة؟"



إصلاح المشكلة بنفسي


لحل هذه المشكلة، اتبع الخطوات التالية:

  1. Windows XP SP2 أو Vista أو 7: انقر فوق "ابدأ"، وانقرفوق "تشغيل"، ثماكتب regedit، ثم انقر فوق "موافق".

    Windows 8 أو أي وقت لاحق: اسحب من اليسار لإحضار الرموز، ثم حدد "بحث" وا اكتب regedit (أو اكتب regedit من شاشة البدء). حدد regedit من نتائج البحث لتشغيله.

  2. حدد موقع مفتاح السجل الفرعي التالي، ثم انقر فوقه:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. في الجزء الأيمن، انقر ب زر الماوس الأيمن فوق القيمة
    FileSizeLimitInBytes، ثم انقر فوق
    "تعديل".

    إذا لم تتمكن من رؤية قيمة
    FileSizeLimitInBytes، انقر ب زر الماوس الأيمن فوق المساحة الفارغة في الجزء الأيمن، وانقر فوق "جديد"، وانقر فوق "قيمة DWORD"،وا اكتب FileSizeLimitInBytes، ثم انقر فوق "موافق".

  4. في المربع "تحرير قيمة DWORD"، انقر لتحديد الخيار "عشري". في المربع ضمن بيانات القيمة،اكتب قيمة أكبر من حجم الملف الذي تريد تنزيله. انقر فوق موافق.

    لاحظ أن القيمة الافتراضية للحد الأقصى لحجم الملف هي 5000000 بايت.

  5. قم بإنهاء "محرر السجل". أعد تشغيل الكمبيوتر.


هل عمل ذلك على إصلاح المشكلة؟

  • تحقق مما إذا كان قد تم إصلاح المشكلة أم لا. في حالة إصلاح المشكلة، لا يتطلب الأمر إكمال قراءة هذا القسم. أما في حالة عدم إصلاح المشكلة، يمكنك الاتصال بالدعم.

  • نحن نقدّر ملاحظاتك. لتقديم ملاحظات أو الإبلاغ عن أي مشاكل في هذا الحل، يرجى ترك تعليق على " إصلاح الأمرلي" المدونة أو إرسال رسالة بريد إلكتروني إلينا.

هل تحتاج إلى مزيد من المساعدة؟

الخروج من الخيارات إضافية؟

استكشف مزايا الاشتراك، واستعرض الدورات التدريبية، وتعرف على كيفية تأمين جهازك، والمزيد.

تساعدك المجتمعات على طرح الأسئلة والإجابة عليها، وتقديم الملاحظات، وسماعها من الخبراء ذوي الاطلاع الواسع.

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟
بالضغط على "إرسال"، سيتم استخدام ملاحظاتك لتحسين منتجات Microsoft وخدماتها. سيتمكن مسؤول تكنولوجيا المعلومات لديك من جمع هذه البيانات. بيان الخصوصية.

نشكرك على ملاحظاتك!

×