بالنسبة إلى إصدار Microsoft Publisher 98 من هذه المقالة ، راجع 191131.

الملخص

إذا واجهت سلوكا غير متوقع عند استخدام منشور في Microsoft Publisher ، فقد يكون المنشور تالفا. تتضمن اعراض المنشور التالف ما يلي:

  • تتلقي خطا صفحه غير صالح أو خطا حماية عام أو رسالة خطا إرشادات غير قانونيه.

  • عند محاولة فتح المنشور ، تظهر أحدي رسائل الخطا التالية:

    -هذا ليس منشور Publisher.

    -يتعذر علي Publisher فتح نوع الملف الذي يتم تمثيله بواسطة <filename>.

    -جزء من الملف مفقود.

  • تتلقي رسالة خطا "نفاد الذاكرة" أو رسالة خطا انخفاض في موارد النظام.

ملاحظة يتم إصدار Acrobat Reader من قِبل شركة Adobe Systems Inc.‎. قد تتلقي أحدي رسائل الخطا هذه لأسباب أخرى غير المنشور التالف. ومع ذلك ، إذا كان هذا السلوك يحدث فقط عند استخدام منشور معين ، فمن المحتمل ان يكون المنشور معطوبا.

مزيد من المعلومات

لاستكشاف هذه المشكلة وإصلاحها ، أعد تشغيل الكمبيوتر في الوضع الأمن. بعد ذلك ، استخدم أساليب استكشاف الأخطاء وإصلاحها المناسبة لمشكلتك.ملاحظة نظرًا لوجود عدد كبير من إصدارات أنظمة التشغيل Microsoft Windows، فقد تكون الخطوات التالية مختلفة على جهاز الكمبيوتر الخاص بك. في حالة اختلاف هذه الخطوات بالفعل، راجع وثائق المنتج لاستكمالها.

أعاده تشغيل الكمبيوتر في الوضع الأمن

لأعاده تشغيل الكمبيوتر في الوضع الأمن ، استخدم الأسلوب المناسب لإصدار Microsoft Windows الذي تستخدمه.

  1. قم بإيقاف تشغيل الكمبيوتر ، ثم أعد تشغيله.

  2. عند ظهور الرسالة "الرجاء تحديد نظام التشغيل الذي تريد بدء تشغيله" ، اضغط علي F8.

  3. في قائمه الخيارات المتقدمة في Windows ، استخدم مفاتيح الأسهم لتحديد الوضع الأمن، ثم اضغط علي مفتاح الإدخال ENTER.

  4. إذا كان لديك كمبيوتر ثنائي التمهيد أو كمبيوتر متعدد التشغيل ، فحدد نظام التشغيل المناسب من القائمة ، ثم اضغط علي مفتاح الإدخال ENTER.

لمزيد من المعلومات حول "الوضع الأمن" ، انقر فوق أرقام المقالات التالية لعرض المقالات في قاعده معارف Microsoft:

315222 وصف لخيارات التشغيل في الوضع الأمن في Windows XP

202485 وصف وضع التمهيد الأمن في Windows 2000

180902 كيفيه بدء تشغيل جهاز كمبيوتر يعمل بنظام التشغيل Windows 98 في الوضع الأمن

محاولة فتح المنشور

بعد بدء تشغيل الكمبيوتر في الوضع الأمن ، حاول فتح المنشور. إذا لم تتلقي رسالة خطا ، فقد يتداخل برنامج أو جهاز يتم تحميله عندما يكون الكمبيوتر في الوضع العادي علي المنشور.

إذا لم تتمكن من فتح المنشور

إذا لم تتمكن من فتح المنشور بعد بدء تشغيل الكمبيوتر في الوضع الأمن ، فاستخدم الطرق التالية بالترتيب الذي يتم تقديمها به.

لصق المنشور في ملف برنامج Publisher

قد تتمكن من فتح المنشور عن طريق لصقه في ملف برنامج Publisher. للقيام بذلك، اتبع الخطوات التالية:

  1. أبدا تشغيل "مستكشف Windows".

  2. حدد موقع ملف المنشور.

  3. انقر بزر الماوس الأيمن فوق ملف المنشور ، ثم انقر فوق نسخ.

  4. قم بإنهاء "مستكشف Windows".

  5. انقر فوق أبدا، وفوق تشغيل، واكتب أحد الأسطر التالية في المربع فتح ، ثم انقر فوق موافق:

    بالنسبة ل publisher 2003C:\Program Files\Microsoft Office\Office11for publisher 2002C:\Program Files\Microsoft Office\Office10For publisher 2000C:\Program Files\Microsoft Office\Office

  6. انقر بزر الماوس الأيمن فوق ملف برنامج mspub.exe ، ثم انقر فوق لصق.

إذا لم تتمكن من فتح المنشور ، فانتقل إلى الأسلوب التالي.

انقر نقرا مزدوجا فوق ملف المنشور في "مستكشف Windows"

النقر نقرا مزدوجا فوق ملف المنشور في "مستكشف Windows" ، اتبع الخطوات التالية:

  1. انقر فوق أبدا، وأشر إلى البرامج، ثم انقر فوق مستكشف Windows.

  2. حدد موقع ملف المنشور.

  3. انقر نقرا مزدوجا فوق ملف المنشور.

إذا لم تتمكن من فتح المنشور ، فانتقل إلى الأسلوب التالي.

تكوين Publisher لإخفاء الصور

لتكوين Publisher لإخفاء الصور ، اتبع الخطوات التالية:

  1. أبدا بتشغيل Publisher ، ثم افتح منشورا جديدا وفارغا.

  2. في القائمة عرض ، انقر فوق عرض الصورة في publisher 2000 أو انقر فوق صور في publisher 2003 أو في publisher 2002.

  3. انقر فوق إخفاء الصور، ثم انقر فوق موافق.

  4. من القائمة ملف، انقر فوق فتح.

  5. حدد موقع ملف المنشور.

  6. انقر لتحديد المنشور ، ثم انقر فوق فتح.

إذا كان بإمكانك فتح المنشور ، فقد يحتوي المنشور علي عنصر نائب لعنصر أو عنصر تالف. لأزاله عنصر نائب أو كائن معطوب أو استبداله ، انتقل إلى الأسلوب التالي. إذا لم تتمكن من فتح المنشور ، فانتقل إلى الأسلوب "نسخ المنشور إلى كمبيوتر آخر".

البحث عن عنصر نائب لعنصر أو عنصر تالف وأزالهه

للبحث عن عنصر نائب لكائن تالف أو عنصر أو ازالته ، اتبع الخطوات التالية:

  1. في المنشور ، انقر بزر الماوس الأيمن فوق عنصر نائب للعنصر ، ثم انقر فوق حذف عنصر.

  2. من القائمة ملف ، انقر فوق حفظ باسم.

  3. في المربع الاسم ، اكتب اسما جديدا للمنشور ، ثم انقر فوق حفظ.

  4. في القائمة عرض ، انقر فوق عرض الصورة في publisher 2000 أو انقر فوق صور في publisher 2003 أو في publisher 2002.

  5. انقر فوق عرض مفصل، ثم انقر فوق موافق.ملاحظة يتم إصدار Acrobat Reader من قِبل شركة Adobe Systems Inc.‎. إذا ظهرت رسالة خطا ، فانتقل إلى الخطوة 8.

  6. من القائمة ملف انقر فوق إغلاق.

  7. في القائمة ملف ، انقر فوق فتح، ثم انقر فوق المنشور الذي حفظته في الخطوة 3. إذا كان بإمكانك فتح المنشور ، فهذا يعني ان العنصر أو العنصر النائب للعنصر الذي حذفته في الخطوة 1 معطوب. ضبط التخطيط إلى العنصر النائب للعنصر أو الكائن المفقود. بدلا من ذلك ، ارسم عنصرا نائبا لكائن جديدا واستبدل الكائن المحذوف بملف غير تالف. للقيام بذلك ، استخدم الأسلوب المناسب لمصدر الكائن.من معرض القصاصات الClipArtه

    1. في قائمه ادراج ، أشر إلى صوره، ثم انقر فوق قصاصه فنيه.

    2. من أحدي الفئات المتوفرة ، انقر فوق لادراج الصورة أو الصوت أو قصاصه الحركة التي تريدها.

    3. احفظ المنشور ثم اغلقه. ثم حاول أعاده فتح المنشور.

    من موقع آخر غير معرض القصاصة الClipArtه

    1. استخدم أداه اطار الصورة لرسم عنصر نائب لكائن جديد.

    2. انقر لتحديد العنصر النائب ، وأشر إلى صوره من القائمة ادراج ، ثم انقر فوق من ملف.

    3. حدد موقع الصورة التي تريد ادراجها ، ثم انقر لتحديدها.

    4. انقر فوق ادراج.

    5. احفظ المنشور ثم اغلقه. ثم حاول أعاده فتح المنشور.

    إذا لم تتمكن من فتح المنشور ، فكرر الأسلوب "تكوين الناشر لإخفاء الصور". ثم انتقل إلى الخطوة 8.

  8. كرر الخطوات من 1 إلى 7 حتى تتمكن من فتح المنشور مع تمكين الخيار عرض مفصل .

  9. عندما تتمكن من فتح المنشور ، استخدم أحد الأساليب التالية:

    • استبدال العنصر النائب للعنصر أو العنصر المحذوف بواحد غير تالف.

    • ضبط التخطيط إلى العنصر النائب للعنصر أو الكائن المفقود.

  10. في القائمة ملف ، انقر فوق حفظ.

إذا لم تتمكن من فتح المنشور ، فانتقل إلى الأسلوب التالي.

نقل ملف المنشور إلى قرص آخر

إذا كان ملف المنشور موجودا علي قرص قابل للازاله ، مثل قرص مرن أو قرص مضغوط ، فقد لا يتمكن نظام التشغيل Windows من قراءه الملف. في هذا السيناريو ، انسخ الملف إلى القرص الثابت. إذا لم تتمكن من نسخ الملف من القرص القابل للازاله ، فقد يكون الملف مرتبطا بالملفات أو المجلدات الأخرى. بدلا من ذلك ، قد يكون الملف موجودا في مقطع تالف علي القرص. في اي من السيناريوهات ، انتقل إلى الأسلوب "تشغيل تدقيق الأخطاء علي القرص".

نسخ المنشور إلى كمبيوتر آخر

في بعض السيناريوهات ، يمكنك فتح منشور تالف بعد نسخ المنشور علي كمبيوتر ثان تم تثبيت Publisher عليه. للقيام بذلك، اتبع الخطوات التالية:

  1. أبدا تشغيل "مستكشف Windows".

  2. حدد موقع ملف المنشور.

  3. انقر بزر الماوس الأيمن فوق ملف المنشور ، ثم انقر فوق نسخ.

  4. استخدم أحدي الطرق التالية لنسخ المنشور إلى كمبيوتر آخر:

    • انسخ ملف المنشور إلى قرص قابل للازاله ، مثل قرص مرن أو قرص مضغوط. بعد ذلك ، انسخ المنشور من القرص القابل للازاله إلى كمبيوتر آخر.

    • انسخ ملف المنشور إلى كمبيوتر آخر علي الشبكة.

  5. في الكمبيوتر الثاني ، أبدا بتشغيل مستكشف Windows.

  6. حدد موقع ملف المنشور ، ثم انقر نقرا مزدوجا فوقه.

إذا كان بإمكانك فتح المنشور ، فافحص كل صفحه لتحديد ما إذا كانت اي عناصر نائبه للعناصر فارغه موجودة ام لا. بالنسبة إلى كل عنصر نائب للعنصر الفارغ الذي تبحث عنه ، انقر بزر الماوس الأيمن فوق الملف ، ثم انقر فوق حذف. احفظ المنشور ، ثم انسخ ملف المنشور مره أخرى إلى الكمبيوتر الأول. إذا لم تتمكن من فتح المنشور ، فانتقل إلى الأسلوب التالي.

تشغيل تدقيق الأخطاء علي القرص

تشغيل ميزه تدقيق الأخطاء لإصلاح كل الأخطاء الموجودة علي القرص. توجيه تدقيق الأخطاء لإصلاح كل الملفات المرتبطة بالبضائع وتحويل الأجزاء المفقودة إلى ملفات.ملاحظة يتم إصدار Acrobat Reader من قِبل شركة Adobe Systems Inc.‎. علي الرغم من ان تدقيق الأخطاء قد يحدد ان ملف المنشور مرتبط بالبضائع ثم إصلاح الملف ، فهذا الأسلوب لا يضمن انه بإمكان Publisher قراءه الملف بعد انتهاء تدقيق الأخطاء من البحث عن الأخطاء وإصلاحها. لتشغيل تدقيق الأخطاء ، اتبع الخطوات التالية:

  1. قم بإنهاء كافة البرامج التي يتم تشغيلها.

  2. انقر نقرا مزدوجا فوق أيقونه جهاز الكمبيوتر علي سطح المكتب.

  3. انقر بزر الماوس الأيمن فوق القرص المحلي الذي تريد التحقق منه ، ثم انقر فوق خصائص.

  4. علي علامة التبويب أدوات ، انقر فوق التدقيق الآن ضمن تدقيق الأخطاء.

  5. ضمن " خيارات التدقيق في القرص" ، انقر فوق خانه الاختيار البحث عن المقاطع التالفة ومحاولة استردادها . ثم انقر فوق أبدا.

  6. عندما تنتهي عمليه تدقيق الأخطاء في الفحص وإصلاح الأخطاء ، انقر فوق إغلاق.

  7. أبدا بتشغيل Publisher ، ثم حاول فتح المنشور.

إذا لم تتمكن من فتح المنشور ، فانتقل إلى الأسلوب التالي.

محاولة استرداد النص في المنشور

توضح هذه الطريقة كيفيه استرداد النص من المنشور التالف وكيفيه ادراج النص المسترد في منشور جديد وفارغ. يجب عليك عندئذ أعاده إنشاء التخطيط واعد ادراج كل العناصر من المنشور التالف في المنشور الجديد. لاسترداد النص من المنشور التالف ثم ادراج النص في منشور جديد ، اتبع الخطوات التالية:

  1. أبدا بتشغيل Publisher ، ثم أنشئ منشورا جديدا وفارغا بصفحه كامله.

  2. استخدم أداه اطار النص في Publisher 2000 أو أداه مربع النص في Publisher 2003 أو في Publisher 2002 لرسم اطار نص علي الصفحة الفارغة.

  3. في قائمه ادراج ، انقر فوق ملف نصي.

  4. في المربع ملفات من نوع ، انقر فوقملفات Publisher (* .pub).

  5. انقر فوق المنشور ، ثم انقر فوق موافق. إذا تلقيت رسالة توضح كيفيه ملاءمة النص الذي تريد ادراجه في الصفحة ، فانقر فوق نعم.

إذا كان بإمكانك فتح المنشور التالف

إذا كان بإمكانك فتح المنشور في الوضع الأمن ، فاستخدم أحدي الطرق التالية لأعاده إنشاء المنشور.

نسخ الصفحات من المنشور التالف إلى منشور جديد

لنسخ الصفحات من منشور تالف إلى منشور جديد ، اتبع الخطوات التالية:

  1. أبدا بتشغيل Publisher ، ثم افتح المنشور التالف.

  2. أبدا مثيل آخر من Publisher.

  3. إنشاء منشور جديد وفارغ تم تكوينه باعتباره المنشور التالف.

  4. في المنشور التالف ، حدد كل الكائنات علي صفحه معينه.

  5. في القائمة تحرير ، انقر فوق نسخ.

  6. اضغط علي ALT + TAB للتبديل إلى المنشور الجديد.

  7. من القائمة تحرير ، انقر فوق لصق.

  8. كرر الخطوات من 4 إلى 7 حتى يتم لصق كل الصفحات في المنشور الجديد.

ملاحظة يتم إصدار Acrobat Reader من قِبل شركة Adobe Systems Inc.‎. إذا لاحظت سلوكا فرديا في المنشور الجديد بعد نسخ صفحه إلى المنشور الجديد ، فمن المحتمل ان تحتوي هذه الصفحة المنسوخة علي كائن معطوب. في هذا السيناريو ، استخدم أحدي الطرق التالية لحل هذه المشكلة:

  • انسخ كائنا واحدا في كل مره من الصفحة المشكلة إلى المنشور الجديد لتحديد العنصر التالف. بعد ذلك ، تاكد من عدم تضمين الكائن التالف في المنشور الجديد.

  • أعد إنشاء صفحه المشكلة في المنشور الجديد.

إذا كانت كل صفحه في المنشور معطوبة ، فانتقل إلى الأسلوب التالي.

حفظ المنشور بتنسيق RTF (تنسيق النص المنسق)

إذا كان التلف في المنشور أكثر انتشارا ، فاحفظ المنشور بتنسيق RTF لاسترداد نص المنشور. للقيام بذلك، اتبع الخطوات التالية:

  1. افتح المنشور.

  2. انقر فوق اطار نص.

  3. في المربع حفظ بنوع ، انقر فوقتنسيق النص المنسق (* .rtf). Save as type

  4. في المربع اسم الملف ، اكتب اسم الملف الذي تريده.

  5. في المربع حفظ في ، انقر فوق المجلد الذي تريد حفظ نص المنشور فيه.

  6. انقر فوق حفظ، ثم فوق موافق.

  7. اغلق المنشور.

  8. من القائمة ملف، انقر فوق فتح.

  9. في المربع ملفات من نوع ، انقر فوقتنسيق النص المنسق (* .rtf).

  10. في قائمه الملفات ، انقر فوق الملف النصي الذي حفظته في الخطوة 6.

  11. انقر فوق Open (فتح).

  12. يمكنك تخطيط النص وتنسيقه بطريقه تكرر كيفيه تخطيط النص وتنسيقه في المنشور التالف.

المراجع

للحصول علي مزيد من المعلومات حول كيفيه استكشاف أخطاء منشورات Publisher التالفة وإصلاحها ، انقر فوق أرقام المقالات التالية لعرض المقالات في قاعده معارف Microsoft:

315222 وصف لخيارات التشغيل في الوضع الأمن في Windows XP

164519 استكشاف أخطاء Office Kernel32.dll في Windows 95 وإصلاحها

179095 رسالة خطا ارتباط ملف عند فتح Publisher

هل تحتاج إلى مزيد من المساعدة؟

توسيع المهارات

استكشاف التدريب >

الحصول على الميزات الجديدة أولاً

الانضمام إلى MICROSOFT INSIDERS >

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة اللغة؟
ما الذي أثّر في تجربتك؟

نشكرك على ملاحظاتك!

×