الأعراض
يتعذر على المستخدمين تسجيل الدخول إلى Outlook على ويب (OWA) أو لوحة التحكم في Exchange (ECP) بعد تثبيت تحديث الأمان ل يوليو 2021 أو أي تحديث لاحق ل Microsoft Exchange Server 2019 أو 2016 أو 2013.
السبب
تحدث الشروط التالية بعد تثبيت التحديث.
السبب 1
فشل تسجيل الدخول إلى OWA أو ECP وإرجاع رسالة الخطأ التالية إذا كانت شهادة Exchange Server (OAuth) مفقودة أو منتهية الصلاحية:
تأكيد: HMACProvider.GetCertificates:protectionCertificates.length<1
راجع "الدقة 1".
السبب 2
يرى المستخدمون صفحة ويب فارغة بعد محاولة تسجيل الدخول، أو تتحول عملية تسجيل الدخول إلى حلقة مستمرة. يحدث هذا الأمر في حالة وصول المستخدمين إلى الخوادم من خلال موازن تحميل، ولا يتم تحديث كل الخوادم في المجموعة بتحديث الأمان ل يوليو 2021 على الأقل. قد يؤدي هذا الشرط إلى إعادة توجيه المستخدمين إلى صفحة تسجيل الدخول عند استخدام OWA أو ECP.
راجع "الحل 2".
الحل
الحل 1
لحل المشكلة الموضحة في القسم "السبب 1"، اتبع الخطوات المذكورة في هذه المقالة لتجديد شهادة Exchange Server التخويل.
الحل 2
يجب أن تتوقف المشكلة الموضحة في القسم "السبب 2" عن حدوثها بعد تثبيت "SU" في يوليو 2021 أو تحديث لاحق على كل الخوادم التي يعالجها موازن التحميل.يمكنك تحديث كل الخوادم غير المحدثة في التجمع مرة واحدة. يمكنك أيضا تحديثها على دفعات عن طريق إزالة الخوادم غير المحدثة من المجموعة، وتطبيق SU يوليو أو التحديث الأخير، ثم تبديل تلك الخوادم ب الخوادم الأخرى التي لم يتم تحديثها بعد.
الحل البديل
يمكنك حل المشكلة الموضحة في المقطع "السبب 2" من خلال تعيين الثبات إلى "source-ip" في تكوين موازن التحميل.